ruby-rails_5.2.3+dfsg-1_all.deb


Advertisement

Description

ruby-rails - MVC ruby based framework geared for web application development

Property Value
Distribution Debian Sid
Repository Debian Main i386
Package filename ruby-rails_5.2.3+dfsg-1_all.deb
Package name ruby-rails
Package version 5.2.3+dfsg
Package release 1
Package architecture all
Package type deb
Category ruby
Homepage http://www.rubyonrails.org
License -
Maintainer Debian Ruby Extras Maintainers <pkg-ruby-extras-maintainers@lists.alioth.debian.org>
Download size 18.38 KB
Installed size 52.00 KB

Alternatives

Package Version Architecture Repository
ruby-rails_5.2.3+dfsg-1_all.deb 5.2.3+dfsg all Debian Main
ruby-rails - - -

Requires

Name Value
ruby-actioncable = 2:5.2.3+dfsg-1
ruby-actionmailer = 2:5.2.3+dfsg-1
ruby-actionpack = 2:5.2.3+dfsg-1
ruby-actionview = 2:5.2.3+dfsg-1
ruby-activejob = 2:5.2.3+dfsg-1
ruby-activemodel = 2:5.2.3+dfsg-1
ruby-activerecord = 2:5.2.3+dfsg-1
ruby-activestorage = 2:5.2.3+dfsg-1
ruby-activesupport = 2:5.2.3+dfsg-1
ruby-bundler >= 1.3.0
ruby-railties = 2:5.2.3+dfsg-1
ruby-sprockets-rails >= 2.3.2~

Download

Type URL
Mirror ftp.br.debian.org
Binary Package ruby-rails_5.2.3+dfsg-1_all.deb
Source Package rails

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-rails deb package:
    # sudo apt-get install ruby-rails

Files

Path
/usr/share/doc/ruby-rails/CONTRIBUTING.md
/usr/share/doc/ruby-rails/README.md.gz
/usr/share/doc/ruby-rails/changelog.Debian.gz
/usr/share/doc/ruby-rails/copyright
/usr/share/rubygems-integration/all/specifications/rails-5.2.3.gemspec

Changelog

2019-08-13 - Utkarsh Gupta <guptautkarsh2102@gmail.com>
rails (2:5.2.3+dfsg-1) unstable; urgency=medium
* New upstream version 5.2.3+dfsg
* Add salsa-ci.yml
* Bump Standards-Version to 4.4.0
* Bump debhelper-compat to 12
* Add myself as an uploader
2019-03-17 - Utkarsh Gupta <guptautkarsh2102@gmail.com>
rails (2:5.2.2.1+dfsg-1) unstable; urgency=medium
* Team upload
* New upstream version 5.2.2.1+dfsg (Closes: #924520, #924521)
(Fixes: CVE-2019-5418 CVE-2019-5419, CVE-2019-5420)
* Drop unused override
* Remove duplicate Depends entry for rake
* Add d/upstream/metadata
2019-03-01 - Pirate Praveen <praveen@debian.org>
rails (2:5.2.2+dfsg-6) unstable; urgency=medium
[ Antonio Terceiro ]
* debian/tests/control: remove explicit call to gem2deb-test-runner, as it
will be added automatically by autodep8.
[ Pirate Praveen ]
* Move all Recommends from ruby-rails to rails as Depends (Closes: #923507)
* Drop obsolete Breaks + Replaces rails3
* Drop needs-recommends restriction in newapp autopkgtest
* Add debian/node_modules path in activestorage/rollup.config.js for spark-md5
2019-02-08 - Pirate Praveen <praveen@debian.org>
rails (2:5.2.2+dfsg-5) unstable; urgency=medium
* Recommend ruby-chromedriver-helper in ruby-rails
2019-02-07 - Pirate Praveen <praveen@debian.org>
rails (2:5.2.2+dfsg-4) unstable; urgency=medium
* Allow ruby-sprockets-rails >= 3
* Bump Standards-Version to 4.3.0 (no changes needed)
2019-02-06 - Pirate Praveen <praveen@debian.org>
rails (2:5.2.2+dfsg-3) unstable; urgency=medium
* Build action_cable.js using blade build system for ruby-actioncable
2019-01-30 - Pirate Praveen <praveen@debian.org>
rails (2:5.2.2+dfsg-2) unstable; urgency=medium
* Use --gem-install option to dh_ruby as many components now has javascript
files targeted for asset pipeline.
* Fix typo in rules to correctly override dh_auto_build (Closes: #897641)
* Switch to rollup for building activestorage.js, like upstream
* Build rails-ujs as part of ruby-actionview with blade build system
2019-01-07 - Sruthi Chandran <srud@disroot.org>
rails (2:5.2.2+dfsg-1) unstable; urgency=medium
* New upstream version 5.2.2 (Closes: #914847, #914848)
(Fixes: CVE-2018-16476, CVE-2018-16477)
* Delete 0002-edit-activestorage-webpack-config-js.patch
* Add 0002-disable-uglify-in-activestorage-rollup-config-js.patch
2019-01-03 - Sruthi Chandran <srud@disroot.org>
rails (2:5.2.0+dfsg-2) unstable; urgency=medium
* Re-upload to unstable
2018-08-03 - Sruthi Chandran <srud@disroot.org>
rails (2:5.2.0+dfsg-1) experimental; urgency=medium
* New upstream release
* Add myself to uploaders
* Embed spark-md5
* Remove activestorage.js and syntaxhighlighter.js for dfsg
* Use webpack to build activestorage.js
* Bump Standards-Version to 4.2.0 (no changes needed)
* Update lintian overrides
* Use salsa.debian.org in Vcs-* fields
* Add nocheck build profile
* Remove shCore.js from missing-sources

See Also

Package Description
ruby-railties_5.2.3+dfsg-1_all.deb tools for creating, working with, and running Rails applications
ruby-rainbow_3.0.0-2_all.deb extension of Ruby String class enabling colored text on ANSI terminals
ruby-raindrops_0.19.0-1+b2_i386.deb Real-time stats for preforking Rack servers
ruby-rash-alt_0.4.3-1_all.deb simple extension to Hashie::Mash for rubyified keys
ruby-rb-inotify_0.9.10-1_all.deb Ruby wrapper for Linux's inotify, using FFI
ruby-rblineprof_0.3.7-2_i386.deb line-profiler for ruby
ruby-rbnacl_5.0.0-4_all.deb Ruby binding to the Networking and Cryptography (NaCl) library
ruby-rbpdf-font_1.19.5+ds.1-1_all.deb Ruby library for PDF generation (font definitions)
ruby-rbpdf_1.19.5+ds.1-1_all.deb Ruby library for PDF generation
ruby-rbtrace_0.4.10-1_i386.deb rbtrace: like strace but for ruby code
ruby-rbvmomi_1.8.2-1_all.deb Ruby interface to the VMware vSphere API
ruby-rc4_0.1.5-3_all.deb Ruby library implementing the RC4 algorithm
ruby-rchardet_1.6.1-1_all.deb Character encoding auto-detection for Ruby
ruby-rd_0.6.38-4_all.deb RDTool library for Ruby - library
ruby-rdiscount_2.1.8-1+b5_i386.deb Discount Markdown Processor for Ruby
Advertisement
Advertisement