python-docutils_0.14+dfsg-1_all.deb


Advertisement

Description

python-docutils - text processing system for reStructuredText (implemented in Python 2)

Distribution: Debian Sid
Repository: Debian Main i386
Package name: python-docutils
Package version: 0.14+dfsg
Package release: 1
Package architecture: all
Package type: deb
Installed size: 1.71 KB
Download size: 370.56 KB
Official Mirror: ftp.br.debian.org
Description: unavailable.

Alternatives

Provides

  • docutils

    Download

    Source package: python-docutils

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-docutils deb package:
      # sudo apt-get install python-docutils

    Changelog

    2017-09-19 - Dmitry Shachnev <mitya57@debian.org> python-docutils (0.14+dfsg-1) unstable; urgency=medium * New upstream release. * Update debian/watch to properly mangle upstream pre-releases. * Drop get_column_widths-compatibility.diff, applied upstream. * Refresh and rebase other patches. * Stop symlinking rst2html4 → rst2html, use upstream script instead. * Make sure that data paths in generated man pages are correct. * Update debian/copyright. * Drop ancient Breaks, Replaces and Conflicts. * Bump Standards-Version to 4.1.0, no changes needed.

    2017-01-19 - Dmitry Shachnev <mitya57@debian.org> python-docutils (0.13.1+dfsg-2) unstable; urgency=medium * Backport upstream change to make the return type of get_column_widths method of Table directive compatible with docutils 0.12 behavior (get_column_widths-compatibility.diff; closes: #851739).

    2016-12-11 - Dmitry Shachnev <mitya57@debian.org> python-docutils (0.13.1+dfsg-1) unstable; urgency=medium * New upstream release. - Escaping inside embedded URIs now works (closes: #795998). * Drop patches: - python3-pil-no-bytestrings.diff: no longer needed; - odt-writer-ascii-filenames.diff: partially applied upstream, the other part has been rejected upstream; - update-rstel.diff: this was a backport of upstream changes. * Update patches: - doc-debian-paths.diff: update for new tools added in 0.13; - move-data-to-usr-share.diff: rewrite to match new upstream code. * Update debian/watch to point to SourceForge (for the latest release upstream uploaded only wheels to PyPI). * Run cp with -L argument when copying the test/ directory for running the autopkgtest, because CSS files in test/functional/input/data/ are now symlinks. * Install rst2html4 as a symlink to rst2html, to match the documentation. This is a stop-gap measure until the new upstream release. * Minor debian/copyright update for upstream file move.

    2016-10-31 - Dmitry Shachnev <mitya57@debian.org> python-docutils (0.12+dfsg-2) unstable; urgency=medium [ SVN-Git Migration ] * Migrate from Subversion to Git, use git-dpm for patches. [ Dmitry Shachnev ] * Do not mention build-time locale in rst2html manpage (static-help-message.diff; closes: #791587). * Update my e-mail address. * Remove XS-Testsuite header, it became obsolete since dpkg 1.17.11. * Use new repacksuffix option in debian/watch. * Update rst.el to the latest upstream version, 1.5.0 (closes: #840658). * Bump Standards-Version to 3.9.8, no changes needed. * Bump debhelper compatibility level to 9. [ Ondřej Nový ] * Fixed VCS URL (https)

    2014-07-26 - Dmitry Shachnev <mitya57@gmail.com> python-docutils (0.12+dfsg-1) unstable; urgency=medium * New upstream release. * Drop python3.3-odt-writer.diff, applied upstream. * Drop test_nodes-2to3.diff, applied upstream. * Update debian/watch to watch PyPI, which is more reliable than sf.php. * Add explicit build-dependency on dh-python. * Convert debian/changelog to copyright format 1.0. * Exclude non-free biohazard.swf file from the tarball.

    2013-12-21 - Michael Schutte <michi@debian.org> python-docutils (0.11-3) unstable; urgency=low [ Jakub Wilk ] * Remove myself from Uploaders. [ Dmitry Shachnev ] * Fix package names in Recommends: python(3)-imaging → python(3)-pil. [ Michael Schutte ] * New patch test_nodes-2to3.diff: Do not rely on a bug in 2to3 string literal conversion in test_nodes.ElementTests.test_empty, closes: #732679. Thanks to Martin Pitt and Jakub Wilk for investigating. * Increase Standards-Version to 3.9.5; no changes required.

    Advertisement
    Advertisement