php-symfony-polyfill-php56_1.9.0-1_all.deb


Advertisement

Description

php-symfony-polyfill-php56 - Symfony polyfill backporting some PHP 5.6+ features to lower PHP versions

Property Value
Distribution Debian Sid
Repository Debian Main i386
Package filename php-symfony-polyfill-php56_1.9.0-1_all.deb
Package name php-symfony-polyfill-php56
Package version 1.9.0
Package release 1
Package architecture all
Package type deb
Category php
Homepage https://symfony.com
License -
Maintainer Debian PHP PEAR Maintainers <pkg-php-pear@lists.alioth.debian.org>
Download size 6.93 KB
Installed size 25.00 KB

Alternatives

Package Version Architecture Repository
php-symfony-polyfill-php56_1.9.0-1_all.deb 1.9.0 all Debian Main
php-symfony-polyfill-php56 - - -

Requires

Name Value
php-common -
php-symfony-polyfill-util << 2~~
php-symfony-polyfill-util >= 1.0

Download

Type URL
Mirror ftp.br.debian.org
Binary Package php-symfony-polyfill-php56_1.9.0-1_all.deb
Source Package php-symfony-polyfill

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install php-symfony-polyfill-php56 deb package:
    # sudo apt-get install php-symfony-polyfill-php56

Files

Path
/usr/share/doc/php-symfony-polyfill-php56/changelog.Debian.gz
/usr/share/doc/php-symfony-polyfill-php56/changelog.gz
/usr/share/doc/php-symfony-polyfill-php56/copyright
/usr/share/php/Symfony/Polyfill/Php56/Php56.php
/usr/share/php/Symfony/Polyfill/Php56/autoload.php
/usr/share/php/Symfony/Polyfill/Php56/bootstrap.php

Changelog

2018-08-09 - David Prévot <taffit@debian.org>
php-symfony-polyfill (1.9.0-1) unstable; urgency=medium
[ Fabien Potencier ]
* bumped version to 1.9
[ David Prévot ]
* Drop now useless autoload override for php73
* Update Standards-Version to 4.2.0
2018-07-05 - David Prévot <taffit@debian.org>
php-symfony-polyfill (1.8.0-1) unstable; urgency=medium
[ David Prévot ]
* Fix Vcs-* URLs
* Update homemade autoload to new dependencies
* Add new php-symfony-polyfill-ctype component
* Add new php-symfony-polyfill-php73 component
* Update Standards-Version to 4.1.5
* Update for PHPUnit 7.2 (Closes: 895604)
[ Gabriel Caruso ]
* Add is_countable under PHP 7.3
[ BackEndTea ]
* Add the cytpe polyfill
2018-02-27 - David Prévot <taffit@debian.org>
php-symfony-polyfill (1.7.0-1) unstable; urgency=medium
[ Nicolas Grekas ]
* Update LICENSE for 2018
* Add compatibility with namespaced PHPUnit
[ Robert Gust-Bardon ]
* Add polyfills for mb_*_numericentity
[ David Prévot ]
* Revert "Move to namespaced phpunit versions"
* Update copyright (years)
* Move project repository to salsa.d.o
* Update Standards-Version to 4.1.3
2017-12-01 - David Prévot <taffit@debian.org>
php-symfony-polyfill (1.6.0-2) unstable; urgency=medium
* Move to namespaced phpunit versions (Closes: 882930)
2017-10-19 - David Prévot <taffit@debian.org>
php-symfony-polyfill (1.6.0-1) unstable; urgency=medium
[ Nicolas Grekas ]
* Add SessionUpdateTimestampHandlerInterface polyfill
[ David Prévot ]
* Update Standards-Version to 4.1.1
2017-09-22 - David Prévot <taffit@debian.org>
php-symfony-polyfill (1.5.0-1) unstable; urgency=medium
[ Nicolas Grekas ]
* Polyfills for mb_chr(), mb_ord() and mb_scrub()
* Allow Symfony 4.0
* Add Php72 polyfill, abandon Xml polyfill
[ Richard Fussenegger ]
* Added PHP_INT_MIN constant
[ David Prévot ]
* Install main README in php-symfony-polyfill
* Update copyright (years)
* Update for new binary packages
- php-symfony-polyfill-php71
- php-symfony-polyfill-php72
* Update Standards-Version to 4.1.0
* Require bootstrap.php at a latter stage
2016-05-19 - David Prévot <taffit@debian.org>
php-symfony-polyfill (1.2.0-1) unstable; urgency=medium
[ Nicolas Grekas ]
* Add CHANGELOG
[ Andreas Lemke ]
* allow paragonie/random_compat 2.0
[ David Prévot ]
* Drop now useless recommendation
* Update Standards-Version to 3.9.8
* Document that two tests are failing with php-apcu-bc
[ Fabien Potencier ]
* bumped version to 1.2
2016-03-12 - David Prévot <taffit@debian.org>
php-symfony-polyfill (1.1.1-1) unstable; urgency=medium
[ David Prévot ]
* Fix composer.json syntax
* Update php-symfony-polyfill-intl-icu description
* Trim autoload.php for Apcu (removed Resources/stubs)
* PHP 7.0 transition:
- Depend on php-* instead of php5-*
- Build with recent pkg-php-tools
2016-02-14 - David Prévot <taffit@debian.org>
php-symfony-polyfill (1.1.0-1) unstable; urgency=low
* Initial release (new symfony and owncloud dependencies)

See Also

Package Description
php-symfony-polyfill-php70_1.9.0-1_all.deb Symfony polyfill backporting some PHP 7.0+ features to lower PHP versions
php-symfony-polyfill-php71_1.9.0-1_all.deb Symfony polyfill backporting some PHP 7.1+ features to lower PHP versions
php-symfony-polyfill-php72_1.9.0-1_all.deb Symfony polyfill backporting some PHP 7.2+ features to lower PHP versions
php-symfony-polyfill-php73_1.9.0-1_all.deb Symfony polyfill backporting some PHP 7.3+ features to lower PHP versions
php-symfony-polyfill-util_1.9.0-1_all.deb Symfony utilities for portability of PHP codes
php-symfony-polyfill-xml_1.9.0-1_all.deb Symfony polyfill for xml's utf8_encode and utf8_decode functions
php-symfony-polyfill_1.9.0-1_all.deb Symfony polyfills backporting features to lower PHP versions
php-symfony-postmark-mailer_4.3.5+dfsg-1_all.deb Symfony Postmark Mailer Bridge
php-symfony-process_4.3.5+dfsg-1_all.deb execute commands in sub-processes
php-symfony-property-access_4.3.5+dfsg-1_all.deb read from and write to an object or array
php-symfony-property-info_4.3.5+dfsg-1_all.deb extract information about properties of PHP classes
php-symfony-proxy-manager-bridge_4.3.5+dfsg-1_all.deb integration for ProxyManager with Symfony Components
php-symfony-routing_4.3.5+dfsg-1_all.deb associate a request with code that generates a response
php-symfony-security-acl_3.0.2-2_all.deb Symfony Security Component - ACL (Access Control List)
php-symfony-security-bundle_4.3.5+dfsg-1_all.deb configurable security system for the Symfony framework
Advertisement
Advertisement