opensmtpd_6.0.3p1-6_i386.deb


Advertisement

Description

opensmtpd - secure, reliable, lean, and easy-to configure SMTP server

Property Value
Distribution Debian Sid
Repository Debian Main i386
Package filename opensmtpd_6.0.3p1-6_i386.deb
Package name opensmtpd
Package version 6.0.3p1
Package release 6
Package architecture i386
Package type deb
Category mail
Homepage https://www.opensmtpd.org/
License -
Maintainer Ryan Kavanagh <rak@debian.org>
Download size 279.23 KB
Installed size 908.00 KB

Alternatives

Package Version Architecture Repository
opensmtpd_6.0.3p1-6+b1_amd64.deb 6.0.3p1 amd64 Debian Main
opensmtpd - - -

Requires

Name Value
adduser -
debconf >= 0.5
debconf-2.0 -
ed -
init-system-helpers >= 1.54~
libasr0 >= 1.0.2
libc6 >= 2.28
libdb5.3 -
libevent-2.1-6 >= 2.1.8-stable
libpam0g >= 0.99.7.1
libssl1.1 >= 1.1.0
lsb-base >= 3.0-6
zlib1g >= 1:1.1.4

Provides

Name Value
mail-transport-agent -

Conflicts

Name Value
mail-transport-agent -
sendmail-base -

Replaces

Name Value
mail-transport-agent -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package opensmtpd_6.0.3p1-6_i386.deb
Source Package opensmtpd

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install opensmtpd deb package:
    # sudo apt-get install opensmtpd

Files

Path
/etc/smtpd.conf
/etc/init.d/opensmtpd
/lib/systemd/system/opensmtpd.service
/usr/libexec/opensmtpd/encrypt
/usr/libexec/opensmtpd/mail.local
/usr/sbin/makemap
/usr/sbin/newaliases
/usr/sbin/sendmail
/usr/sbin/smtpctl
/usr/sbin/smtpd
/usr/share/doc/opensmtpd/NEWS.Debian.gz
/usr/share/doc/opensmtpd/README.Debian
/usr/share/doc/opensmtpd/changelog.Debian.gz
/usr/share/doc/opensmtpd/copyright
/usr/share/lintian/overrides/opensmtpd
/usr/share/man/man5/aliases.5.gz
/usr/share/man/man5/forward.5.gz
/usr/share/man/man5/smtpd.conf.5.gz
/usr/share/man/man5/table.5.gz
/usr/share/man/man8/makemap.8.gz
/usr/share/man/man8/newaliases.8.gz
/usr/share/man/man8/sendmail.8.gz
/usr/share/man/man8/smtpctl.8.gz
/usr/share/man/man8/smtpd.8.gz

Changelog

2019-08-17 - Ryan Kavanagh <rak@debian.org>
opensmtpd (6.0.3p1-6) unstable; urgency=medium
[ Felix Lechner ]
* Give different software licenses unique names; create missing License
stanzas. (Closes: #827060)
* Remove unused lintian overrides for DEP-5 copyright; add quotes to
multi-word spelling correction.
[ Ryan Kavanagh ]
* set debhelper compat to 12
* Bump standards version to 4.4.0
* Add missing Pre-Depends on ${misc:Pre-Depends}
2019-02-06 - Ryan Kavanagh <rak@debian.org>
opensmtpd (6.0.3p1-5) unstable; urgency=medium
[ Ondřej Nový ]
* d/copyright: Use https protocol in Format field
[ Ryan Kavanagh ]
* Handle empty strings in postinst (Closes: #921429)
* Handle missing /etc/mailname (Closes: #913318)
* Update init script dependencies in comments
* Bump standards-version to 4.3.0; no changes required
* Drop check for ancient package version from postinst
* No longer install documentation for migration from version 5.3 to 5.4
2018-04-30 - Ryan Kavanagh <rak@debian.org>
opensmtpd (6.0.3p1-4) unstable; urgency=medium
* Don't use 'smtpctl stop' in the init script either (Closes: #893367)
* Bump standards version to 4.1.4
2018-03-22 - Ryan Kavanagh <rak@debian.org>
opensmtpd (6.0.3p1-3) unstable; urgency=medium
* Update build-depends to not require OpenSSL be version 1.0
2018-03-18 - Ryan Kavanagh <rak@debian.org>
opensmtpd (6.0.3p1-2) unstable; urgency=medium
* Fix the stop target in the systemd service (Closes: #893367)
* Update Vcs-* fields to point to salsa
* Enable OpenSSL 1.1 support, 11_ssl_1.1.diff (Closes: #859544)
Thanks to Sebastian Andrzej Siewior for the patch.
* Conflict with sendmail-base: provides various commands such as
"newaliases" that could cause confusion with our own commands
(Closes: #888290)
2018-01-16 - Ryan Kavanagh <rak@debian.org>
opensmtpd (6.0.3p1-1) unstable; urgency=medium
* New upstream release
* Updated copyright years
* Added documentation key to smtpd systemd unit file
2018-01-07 - Ryan Kavanagh <rak@debian.org>
opensmtpd (6.0.2p1-3) unstable; urgency=medium
* Set Git branch in Vcs-Git to debian/sid
* Bump debhelper build-dependency to >= 11 and compat to 11
* Drop dh-autoreconf: not needed with dh >= 11
* Bump standards-version to 4.1.3
* Added systemd unit file (Closes: #733315, #871311)
* Change priority to optional
* Use https for URLs in debian/watch and for Homepage
* Turn on all hardening options
* Suggest ca-certificates, which provides /etc/ssl/certs/ca-certificates.crt
2017-03-07 - Ryan Kavanagh <rak@debian.org>
opensmtpd (6.0.2p1-2) unstable; urgency=medium
* Let smtpd create its spool directory tree instead of shipping it.
This fixes errors regarding directories with incorrect owners.
Thanks to Harald Dunkel for a patch. (Closes: #843978)
* Actually remove the spool directory on purge.
2016-11-25 - Ryan Kavanagh <rak@debian.org>
opensmtpd (6.0.2p1-1) unstable; urgency=medium
* Added Brazilian Portuguese debconf templates translation (Closes: #829336)
* Added missing dependency on ed (Closes: #834280)
* Switch B-D to libssl1.0-dev while upstream determines how to best
transition to OpenSSL 1.1 (Closes: #828473)
* Fix manpage formatting issues (Closes: #832008)
* Added missing dependency on lsb-base
* Add missing build-dependency on zlib1g-dev
* Add lintian override for spelling mistake in copyright text

See Also

Package Description
opensp_1.5.2-13+b1_i386.deb OpenJade group's SGML parsing tools
openssh-client-ssh1_7.5p1-11_i386.deb secure shell (SSH) client for legacy SSH1 protocol
openssh-client_8.1p1-1_i386.deb secure shell (SSH) client, for secure access to remote machines
openssh-known-hosts_0.6.2-1_all.deb download, filter and merge known_hosts for OpenSSH
openssh-server_8.1p1-1_i386.deb secure shell (SSH) server, for secure access from remote machines
openssh-sftp-server_8.1p1-1_i386.deb secure shell (SSH) sftp server module, for SFTP access from remote machines
openssh-tests_8.1p1-1_i386.deb OpenSSH regression tests
openssl_1.1.1d-2_i386.deb Secure Sockets Layer toolkit - cryptographic utility
openssn-data_1.4-3_all.deb modern submarine tactical simulator (data)
openssn_1.4-3_i386.deb modern submarine tactical simulator
openstack-clients_0.26_all.deb Metapackage to install all Openstack clients
openstack-cloud-identity_0.26_all.deb Metapackage to install an Openstack keystone
openstack-cloud-services_0.26_all.deb Metapackage to install all Openstack service dependencies
openstack-cluster-installer-cli_21_all.deb automatic PXE and puppet-master installer for OpenStack - API client
openstack-cluster-installer-poc_21_all.deb automatic PXE and puppet-master installer for OpenStack - PoC
Advertisement
Advertisement