oasis_0.4.11-1_i386.deb


Advertisement

Description

oasis - Build-system generation for OCaml projects -- binaries

Property Value
Distribution Debian Sid
Repository Debian Main i386
Package filename oasis_0.4.11-1_i386.deb
Package name oasis
Package version 0.4.11
Package release 1
Package architecture i386
Package type deb
Category ocaml
Homepage http://oasis.forge.ocamlcore.org/
License -
Maintainer Debian OCaml Maintainers <debian-ocaml-maint@lists.debian.org>
Download size 985.90 KB
Installed size 3.90 MB

Alternatives

Package Version Architecture Repository
oasis_0.4.11-1_amd64.deb 0.4.11 amd64 Debian Main
oasis - - -

Requires

Name Value
libc6 >= 2.28
liboasis-ocaml-dev -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package oasis_0.4.11-1_i386.deb
Source Package oasis

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install oasis deb package:
    # sudo apt-get install oasis

Files

Path
/usr/bin/oasis
/usr/share/doc-base/oasis-manual
/usr/share/doc/oasis/MANUAL.mkd.gz
/usr/share/doc/oasis/changelog.Debian.gz
/usr/share/doc/oasis/changelog.gz
/usr/share/doc/oasis/copyright
/usr/share/man/man1/oasis.1.gz

Changelog

2019-08-20 - Stéphane Glondu <glondu@debian.org>
oasis (0.4.11-1) unstable; urgency=medium
* New upstream release
* Disable tests (they depend on camlp4), clean up Build-Depends
2019-08-06 - Stéphane Glondu <glondu@debian.org>
oasis (0.4.10-3) unstable; urgency=high
* Force rebuild of all packages on buildds
* Bump debhelper compat level to 12
* Update Vcs-*
* Bump Standards-Version to 4.4.0
* Remove Hendrik from Uploaders
2017-07-21 - Stéphane Glondu <glondu@debian.org>
oasis (0.4.10-2) unstable; urgency=medium
* Team upload
* Add ocamlbuild to liboasis-ocaml-dev's Depends
2017-07-21 - Stéphane Glondu <glondu@debian.org>
oasis (0.4.10-1) unstable; urgency=medium
* Team upload
* New upstream release
- Remove patch (does not apply anymore)
* Add ocamlbuild and libexpect-ocaml-dev to Build-Depends
2016-08-16 - Stéphane Glondu <glondu@debian.org>
oasis (0.4.6-1) unstable; urgency=medium
[ Mehdi Dogguy ]
* Team upload
* New upstream release
- Drop libexpect-ocaml-dev from Build-Depends
* Install .cmt, cmti and .annot files in liboasis-ocaml-dev
* Bump Standards-Version to 3.9.8, no changes required.
[ Stéphane Glondu ]
* Update Vcs-*
2015-09-03 - Stéphane Glondu <glondu@debian.org>
oasis (0.4.5-1) unstable; urgency=low
[ Stéphane Glondu ]
* Team upload
* New upstream release
* Add camlp4 to Build-Depends
* Disable tests
[ Sylvain Le Gall ]
* Remove Sylvain Le Gall from Uploaders.
2014-06-14 - Stéphane Glondu <glondu@debian.org>
oasis (0.4.4-2) unstable; urgency=medium
* Team upload
* debian/patches:
+ Remove dynrun_for_release test (it times out on mips*)
* Bump Standards-Version to 3.9.5
2014-06-12 - Stéphane Glondu <glondu@debian.org>
oasis (0.4.4-1) unstable; urgency=low
[ Stéphane Glondu ]
* Team upload
* Imported upstream version 0.4.4 (Closes: #716728)
* Remove last patch, it has been applied upstream
[ Sylvain Le Gall ]
* Imported Upstream version 0.4.2.
* Remove most of the patches, they have been applied upstream.
2014-05-10 - Mehdi Dogguy <mehdi@debian.org>
oasis (0.3.0-5) unstable; urgency=medium
* Team upload.
* text.byte requires Extlib through TestCommon. Fixes "FTBFS: Error:
Unbound module ExtString" (Closes: #746095)
2013-12-08 - Stéphane Glondu <glondu@debian.org>
oasis (0.3.0-4) unstable; urgency=low
* Team upload
* debian/patches:
• switch patches to dom-{save,apply}-patches workflow
+ Update ocamldoc-related test for OCaml 4.01.0 (Closes: #731636)

See Also

Package Description
oathtool_2.6.1-1.3_i386.deb OATH Toolkit oathtool command line tool
obconf-qt-l10n_0.14.1-1_all.deb Language package for obconf-qt
obconf-qt_0.14.1-1_i386.deb Openbox configuration with a Qt interface
obconf_2.0.4+git20150213-2_i386.deb preferences manager for Openbox window manager
obex-data-server_0.4.6-1+b2_i386.deb D-Bus service for OBEX client and server side functionality
obexfs_0.11-2+b1_i386.deb mount filesystem of ObexFTP capable devices
obexftp_0.24-6+b1_i386.deb file transfer utility for devices that use the OBEX protocol
obexpushd_0.11.2-1.1+b1_i386.deb program for receiving files via Bluetooth or IRDA
obfs4proxy_0.0.7-4+b12_i386.deb pluggable transport proxy for Tor, implementing obfs4
obfsproxy_0.2.13-3_all.deb pluggable transport proxy for Tor
objcryst-fox_1.9.6.0-2.1+b1_i386.deb Free Objects for Xtallography
obmenu_1.0-4_i386.deb Graphical menu editor for openbox
obs-api_2.9.4-2_all.deb Open Build Service (API)
obs-build_20180831-3_all.deb scripts for building RPM/debian packages for multiple distributions
obs-productconverter_2.9.4-2_all.deb Open Build Service (product definition utility)
Advertisement
Advertisement