libwxbase3.0-0v5_3.0.4+dfsg-8_i386.deb


Advertisement

Description

libwxbase3.0-0v5 - wxBase library (runtime) - non-GUI support classes of wxWidgets toolkit

Property Value
Distribution Debian Sid
Repository Debian Main i386
Package filename libwxbase3.0-0v5_3.0.4+dfsg-8_i386.deb
Package name libwxbase3.0-0v5
Package version 3.0.4+dfsg
Package release 8
Package architecture i386
Package type deb
Category libs role::shared-lib
Homepage https://www.wxwidgets.org/
License -
Maintainer wxWidgets Maintainers <team+wx@tracker.debian.org>
Download size 1.09 MB
Installed size 3.26 MB

Alternatives

Package Version Architecture Repository
libwxbase3.0-0v5_3.0.4+dfsg-8_amd64.deb 3.0.4+dfsg amd64 Debian Main
libwxbase3.0-0v5 - - -

Requires

Name Value
libc6 >= 2.28
libexpat1 >= 2.0.1
libgcc1 >= 1:4.2
libstdc++6 >= 5.2
zlib1g >= 1:1.1.4

Replaces

Name Value
libwxbase3.0-0 -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libwxbase3.0-0v5_3.0.4+dfsg-8_i386.deb
Source Package wxwidgets3.0

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libwxbase3.0-0v5 deb package:
    # sudo apt-get install libwxbase3.0-0v5

Files

Path
/usr/lib/i386-linux-gnu/libwx_baseu-3.0.so.0
/usr/lib/i386-linux-gnu/libwx_baseu-3.0.so.0.4.0
/usr/lib/i386-linux-gnu/libwx_baseu_net-3.0.so.0
/usr/lib/i386-linux-gnu/libwx_baseu_net-3.0.so.0.4.0
/usr/lib/i386-linux-gnu/libwx_baseu_xml-3.0.so.0
/usr/lib/i386-linux-gnu/libwx_baseu_xml-3.0.so.0.4.0
/usr/share/doc/libwxbase3.0-0v5/README.Debian
/usr/share/doc/libwxbase3.0-0v5/changelog.Debian.gz
/usr/share/doc/libwxbase3.0-0v5/changelog.gz
/usr/share/doc/libwxbase3.0-0v5/copyright
/usr/share/lintian/overrides/libwxbase3.0-0v5

Changelog

2019-01-02 - Scott Talbert <swt@techie.net>
wxwidgets3.0 (3.0.4+dfsg-8) unstable; urgency=medium
* Implement multi-arch support for wx-common and -dev packages
(Closes: #917022)
2018-11-22 - Olly Betts <olly@survex.com>
wxwidgets3.0 (3.0.4+dfsg-7) unstable; urgency=medium
* Adjust egrep merged-usr fix - configure doesn't honour EGREP, but setting
GREP works.  (really Closes: #914086)
2018-11-21 - Olly Betts <olly@survex.com>
wxwidgets3.0 (3.0.4+dfsg-6) unstable; urgency=medium
* Fix not to capture /usr/bin/egrep path when built on a merged-usr system.
(Closes: #914086)
2018-11-19 - Olly Betts <olly@survex.com>
wxwidgets3.0 (3.0.4+dfsg-5) unstable; urgency=medium
* Cherry-pick three patches from upstream WX_3_0_BRANCH branch to fix warnings
from GCC8 when building applications using wxWidgets.
* debian/control.in: Note conformance with Standards-Version 4.2.1.
2018-05-30 - Scott Talbert <swt@techie.net>
wxwidgets3.0 (3.0.4+dfsg-4) unstable; urgency=medium
* Update team email address due to alioth retirement (Closes: #899727)
2018-03-28 - Gianfranco Costamagna <locutusofborg@debian.org>
wxwidgets3.0 (3.0.4+dfsg-3) unstable; urgency=medium
* Team upload.
* d/p/wx-config-conditionalise-webview-in-std.patch:
tweak patch to dpkg -l for the new package name.
2018-03-23 - Scott Talbert <swt@techie.net>
wxwidgets3.0 (3.0.4+dfsg-2) unstable; urgency=medium
* debian/control.in: Fix Depends for gtk3 media and webview -dev packages
2018-03-14 - Scott Talbert <swt@techie.net>
wxwidgets3.0 (3.0.4+dfsg-1) unstable; urgency=medium
* Add build of GTK+3 packages
* debian/watch: Use official tarballs instead of github-generated ones
* New upstream release
+ debian/patches/: drop WebKit2 patch (incorporated upstream)
* debian/control.in: Add myself to Uploaders
* debian/control.in: Note conformance with Standards-Version 4.1.3.
* debian/control.in: Update VCS URLs to reflect new salsa VCS location
* debian/rules: Replace deprecated dh_autotools-dev_updateconfig
* debian/control.in: Multi-Arch changes (Closes: #887378)
+ Change wx3.0-headers to Architecture: all and Multi-Arch: foreign
+ Change wx3.0-i18n to Multi-Arch: foreign
+ Change wx3.0-examples to Multi-Arch: foreign
+ Change wx3.0-doc to Multi-Arch: foreign
+ Change wx3.0-headers dependents from binary to source version
2017-09-29 - Olly Betts <olly@survex.com>
wxwidgets3.0 (3.0.3.1+dfsg2-1) unstable; urgency=medium
* Drop the webview packages as they require an obsolete webkitgtk version.
To get them back, we'll need to migrate to GTK+ 3 which is a longer term
project.  (Closes: #790222)
* README.Debian: Update for -dbg to dbgsym change, and to indicate that we
now have a wx3.0-doc package.
* debian/control.in: Note conformance with Standards-Version 4.1.0.
* Update repack of sources to remove prebuilt Java .class files without
sources.

See Also

Package Description
libwxbase3.0-dev_3.0.4+dfsg-8_i386.deb wxBase library (development) - non-GUI support classes of wxWidgets toolkit
libwxgtk-media3.0-0v5_3.0.4+dfsg-8_i386.deb wxWidgets Cross-platform C++ GUI toolkit (GTK+ media library runtime)
libwxgtk-media3.0-dev_3.0.4+dfsg-8_i386.deb wxWidgets Cross-platform C++ GUI toolkit (GTK+ media library development)
libwxgtk-media3.0-gtk3-0v5_3.0.4+dfsg-8_i386.deb wxWidgets Cross-platform C++ GUI toolkit (GTK+ 3 media library runtime)
libwxgtk-media3.0-gtk3-dev_3.0.4+dfsg-8_i386.deb wxWidgets Cross-platform C++ GUI toolkit (GTK+ 3 media library development)
libwxgtk-webview3.0-gtk3-0v5_3.0.4+dfsg-8_i386.deb wxWidgets Cross-platform C++ GUI toolkit (GTK+ 3 webview library runtime)
libwxgtk-webview3.0-gtk3-dev_3.0.4+dfsg-8_i386.deb wxWidgets Cross-platform C++ GUI toolkit (GTK+ 3 webview library development)
libwxgtk3.0-0v5_3.0.4+dfsg-8_i386.deb wxWidgets Cross-platform C++ GUI toolkit (GTK+ runtime)
libwxgtk3.0-dev_3.0.4+dfsg-8_i386.deb wxWidgets Cross-platform C++ GUI toolkit (GTK+ development)
libwxgtk3.0-gtk3-0v5_3.0.4+dfsg-8_i386.deb wxWidgets Cross-platform C++ GUI toolkit (GTK+ 3 runtime)
libwxgtk3.0-gtk3-dev_3.0.4+dfsg-8_i386.deb wxWidgets Cross-platform C++ GUI toolkit (GTK+ 3 development)
libwxsmithlib-dev_16.01+dfsg-2.1_i386.deb wxSmith development files (Code::Blocks plugin for RAD GUI editing)
libwxsmithlib0_16.01+dfsg-2.1_i386.deb wxSmith shared library (Code::Blocks plugin for RAD GUI editing)
libwxsqlite3-3.0-0_3.4.1~dfsg-3_i386.deb SQLite3 C++ wrapper for use in programs based on the wxWidgets
libwxsqlite3-3.0-dev_3.4.1~dfsg-3_i386.deb Development files for wxSQLite3
Advertisement
Advertisement