libtumbler-1-dev_0.2.7-2_i386.deb


Advertisement

Description

libtumbler-1-dev - library for tumbler, a D-Bus thumbnailing service (development)

Property Value
Distribution Debian Sid
Repository Debian Main i386
Package filename libtumbler-1-dev_0.2.7-2_i386.deb
Package name libtumbler-1-dev
Package version 0.2.7
Package release 2
Package architecture i386
Package type deb
Category devel::library libdevel role::devel-lib
Homepage https://www.xfce.org/
License -
Maintainer Debian Xfce Maintainers <debian-xfce@lists.debian.org>
Download size 74.79 KB
Installed size 141.00 KB

Alternatives

Package Version Architecture Repository
libtumbler-1-dev_0.2.7-2_amd64.deb 0.2.7 amd64 Debian Main
libtumbler-1-dev - - -

Requires

Name Value
libglib2.0-dev -
libtumbler-1-0 = 0.2.7-2

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libtumbler-1-dev_0.2.7-2_i386.deb
Source Package tumbler

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libtumbler-1-dev deb package:
    # sudo apt-get install libtumbler-1-dev

Files

Path
/usr/include/tumbler-1/tumbler/tumbler-abstract-thumbnailer.h
/usr/include/tumbler-1/tumbler/tumbler-cache-plugin.h
/usr/include/tumbler-1/tumbler/tumbler-cache.h
/usr/include/tumbler-1/tumbler/tumbler-config.h
/usr/include/tumbler-1/tumbler/tumbler-enum-types.h
/usr/include/tumbler-1/tumbler/tumbler-error.h
/usr/include/tumbler-1/tumbler/tumbler-file-info.h
/usr/include/tumbler-1/tumbler/tumbler-glib-extensions.h
/usr/include/tumbler-1/tumbler/tumbler-marshal.h
/usr/include/tumbler-1/tumbler/tumbler-provider-factory.h
/usr/include/tumbler-1/tumbler/tumbler-provider-plugin.h
/usr/include/tumbler-1/tumbler/tumbler-thumbnail-flavor.h
/usr/include/tumbler-1/tumbler/tumbler-thumbnail.h
/usr/include/tumbler-1/tumbler/tumbler-thumbnailer-provider.h
/usr/include/tumbler-1/tumbler/tumbler-thumbnailer.h
/usr/include/tumbler-1/tumbler/tumbler-util.h
/usr/include/tumbler-1/tumbler/tumbler.h
/usr/lib/i386-linux-gnu/libtumbler-1.so
/usr/lib/i386-linux-gnu/pkgconfig/tumbler-1.pc
/usr/share/doc/libtumbler-1-dev/changelog.Debian.gz
/usr/share/doc/libtumbler-1-dev/changelog.gz
/usr/share/doc/libtumbler-1-dev/copyright

Changelog

2019-08-21 - Yves-Alexis Perez <corsac@debian.org>
tumbler (0.2.7-2) unstable; urgency=medium
* d/patches: prepend XDG_DATA_HOME to thumbnailers dirs
2019-08-15 - Yves-Alexis Perez <corsac@debian.org>
tumbler (0.2.7-1) unstable; urgency=medium
* New upstream version 0.2.7
2019-07-13 - Yves-Alexis Perez <corsac@debian.org>
tumbler (0.2.4-1) unstable; urgency=medium
[ Mateusz Łukasik ]
* New upstream version 0.2.4.
[ Unit 193 ]
* d/compat, d/control:
- Drop d/compat in favor of debhelper-compat, bump to 11.
* d/rules:
- Drop the now-default option '--disable-silent-rules'.
- Drop dbgsym migration, it is complete.
* Update Standards-Version to 4.4.0.
[ Yves-Alexis Perez ]
* update symbols file for new release
* d/control: update tumbler-common long description
2018-09-14 - Yves-Alexis Perez <corsac@debian.org>
tumbler (0.2.3-1) unstable; urgency=medium
* New upstream version 0.2.2
* d/control: drop Lionel from Uploaders, thanks!
* New upstream version 0.2.3
2018-04-07 - Yves-Alexis Perez <corsac@debian.org>
tumbler (0.2.1-1) unstable; urgency=medium
[ Yves-Alexis Perez ]
* add patch to use multithreading (closes: #483040)
* add a d/gbp.conf configuration file
[ Unit 193 ]
* New upstream version 0.2.1
* Update Standards-Version to 4.1.4.
* d/changelog: Remove trailing whitespace from previous entry.
* d/control, d/copyright, d/watch: Use https where possible.
* d/control: Move libtumbler-1-0 to section 'libs'.
* d/rules: Replace the override on dh_install with dh_missing.
2018-03-23 - Yves-Alexis Perez <corsac@debian.org>
tumbler (0.2.0-2) unstable; urgency=medium
* Moved the package to git on salsa.debian.org
* Updated the maintainer address to debian-xfce@lists.debian.org
* d/compat bumped to 10
* run xdt-autogen when running autoreconf
2017-09-04 - Yves-Alexis Perez <corsac@debian.org>
tumbler (0.2.0-1) experimental; urgency=medium
[ Yves-Alexis Perez ]
* New upstream stable release.
[ Unit 193 ]
* d/control:
- Remove duplicated 'section' field.
2017-06-24 - Yves-Alexis Perez <corsac@debian.org>
tumbler (0.1.92.1-1) experimental; urgency=medium
[ Yves-Alexis Perez ]
* New upstream development release.
* debian/control:
- update standards version to 4.0.0.
* Run wrap-and-sort.
[ Unit 193 ]
* d/control:
- Drop libtumbler-1-dbg.
- Drop build-dep on libdbus-glib-1-dev, gdbus is now used.
* d/rules:
- Migrate to dbgsym packages.
* d/tumbler.install:
- Install the new tumbler-desktop-thumbnailer.so plugin.
2017-06-18 - Yves-Alexis Perez <corsac@debian.org>
tumbler (0.1.32-1) unstable; urgency=medium
* New upstream release.
* debian/patches:
- 01_fix-typo-tumbler-rc removed, included upstream.
* debian/control:
- update standards version to 3.9.8.
2015-05-06 - Yves-Alexis Perez <corsac@debian.org>
tumbler (0.1.31-2) unstable; urgency=medium
* Upload to unstable.

See Also

Package Description
libturbojpeg0-dev_1.5.2-2+b1_i386.deb Development files for the TurboJPEG library
libturbojpeg0_1.5.2-2+b1_i386.deb TurboJPEG runtime library - SIMD optimized
libtut-dev_0.0.20070706-2_all.deb elegant C++ unit test framework
libtuxcap-dev_1.4.0.dfsg2-2.3+b3_i386.deb framework for developing 2D games - development files
libtuxcap4.0_1.4.0.dfsg2-2.3+b3_i386.deb framework for developing 2D games - runtime libraries
libtwatch-perl_0.0.7-1_all.deb watch torrent trackers and automatically download new torrents
libtweeny-dev_3-1_all.deb modern C++ tweening library
libtwelvemonkeys-java-doc_3.4.2-1_all.deb Documentation for libtwelvemonkeys-java
libtwelvemonkeys-java_3.4.2-1_all.deb collection of plugins and extensions for Java's ImageIO
libtwin-dev_13.05.03.15.06-g287d16c-2.2+b2_i386.deb tiny window system (development files)
libtwin0_13.05.03.15.06-g287d16c-2.2+b2_i386.deb tiny window system (library)
libtwitter-api-perl_1.0005-1_all.deb Twitter REST API library for Perl
libtwofish-dev_0.3-5+b1_i386.deb Niels Ferguson's Twofish cryptographic algorithm library
libtwofish0_0.3-5+b1_i386.deb Niels Ferguson's Twofish cryptographic library -- runtime package
libtwolame-dev_0.4.0-2_i386.deb MPEG Audio Layer 2 encoder (development files)
Advertisement
Advertisement