libswscale5_4.1.4-1+b2_i386.deb


Advertisement

Description

libswscale5 - FFmpeg library for image scaling and various conversions - runtime files

Property Value
Distribution Debian Sid
Repository Debian Main i386
Package filename libswscale5_4.1.4-1+b2_i386.deb
Package name libswscale5
Package version 4.1.4
Package release 1+b2
Package architecture i386
Package type deb
Category libs role::shared-lib
Homepage https://ffmpeg.org/
License -
Maintainer Debian Multimedia Maintainers <debian-multimedia@lists.debian.org>
Download size 195.38 KB
Installed size 711.00 KB

Alternatives

Package Version Architecture Repository
libswscale5_4.2.1-dmo6_amd64.deb 4.2.1 amd64 Multimedia Main
libswscale5_4.2.1-dmo6_i386.deb 4.2.1 i386 Multimedia Main
libswscale5_4.1.4-1+b2_amd64.deb 4.1.4 amd64 Debian Main
libswscale5 - - -

Requires

Name Value
libavutil56 = 7:4.1.4-1+b2
libc6 >= 2.4

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libswscale5_4.1.4-1+b2_i386.deb
Source Package ffmpeg

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libswscale5 deb package:
    # sudo apt-get install libswscale5

Files

Path
/usr/lib/i386-linux-gnu/libswscale.so.5
/usr/lib/i386-linux-gnu/libswscale.so.5.3.100
/usr/share/doc/libswscale5/changelog.Debian.gz
/usr/share/doc/libswscale5/changelog.Debian.i386.gz
/usr/share/doc/libswscale5/changelog.gz
/usr/share/doc/libswscale5/copyright
/usr/share/lintian/overrides/libswscale5

Changelog

2019-07-27 - James Cowgill <jcowgill@debian.org>
ffmpeg (7:4.1.4-1) unstable; urgency=medium
[ James Cowgill ]
* New upstream release. (LP: #1837480)
- avformat/aadec: Check for scanf() failure (CVE-2019-12730)
(Closes: #932469)
* d/copyright: Remove paragraph containing license files.
* d/control: Bump standards version to 4.4.0.
* d/ffmpeg-doc.doc-base*:
- Move API docs to Programming/C section.
- Index the main manual pages as well.
Thanks to 積丹尼 Dan Jacobson for the suggestion. (Closes: #924528)
* d/rules:
- Disable crystalhd. (Closes: #917292)
- Generate index.html file for the HTML manual pages.
[ Ondřej Nový ]
* d/control:
- Use debhelper-compat instead of debian/compat.
2019-05-19 - Sebastian Ramacher <sramacher@debian.org>
ffmpeg (7:4.1.3-1) unstable; urgency=high
* Team upload.
* New upstream release. (Closes: #926666)
- Fix bug in subtitle decoder enabling DoS attacks (CVE-2019-9718,
CVE-2019-9721)
- Fix bug in studio profile decoder enabling DoS attacks (CVE-2019-11339)
- Fix bug mishandling HEVC data enabling DoS attacks (CVE-2019-11338)
2019-02-15 - James Cowgill <jcowgill@debian.org>
ffmpeg (7:4.1.1-1) unstable; urgency=medium
* New upstream release.
- cbs_av1: Fix reading of overlong uvlc codes (CVE-2019-1000016)
(Closes: #922066)
2018-12-22 - James Cowgill <jcowgill@debian.org>
ffmpeg (7:4.1-1) unstable; urgency=low
* New upstream release.
- Fixes DSF decoding noise at end of file. (Closes: #896190)
* d/control:
- Add version restriction to libva-dev build dependency.
* d/copyright: Updates for 4.1.
* d/rules:
* - Disable opencv. (Closes: #915544)
- Enable liblensfun in libavfilter-extra.
- Update list of disabled libraries.
* d/*.symbols: Update symbols files for 4.1.
* d/tests: Update encdec_list.txt.
* d/upstream/signing-key.asc: Minimize key.
2018-11-03 - James Cowgill <jcowgill@debian.org>
ffmpeg (7:4.0.3-1) unstable; urgency=medium
* New upstream release.
- avformat/flvenc: Check audio packet size. (CVE-2018-15822)
* d/control: Bump standards to 4.2.1.
* d/*.symbols: Add missing Build-Depends-Package fields.
* d/rules: Enable libvidstab. (Closes: #781938)
2018-09-22 - James Cowgill <jcowgill@debian.org>
ffmpeg (7:4.0.2-2) unstable; urgency=medium
[ James Cowgill ]
* Enable libaom. (Closes: #907032)
- d/tests: Enable libaom-av1 codec tests in encdec_list.
* Use versioned Provides instead of alternatives for -extra package
dependencies.  (Closes: #904163)
[ Fabian Greffrath ]
* Handle internal library dependencies by generating a
debian/shlibs.local file.
2018-07-21 - James Cowgill <jcowgill@debian.org>
ffmpeg (7:4.0.2-1) unstable; urgency=medium
[ James Cowgill ]
* New upstream release.
- avformat/movenc: Do not pass AVCodecParameters in avpriv_request_sample.
(CVE-2018-13300)
- avcodec/mpeg4videodec: Check read profile before setting it.
(CVE-2018-13301)
- avformat/movenc: Check that frame_types other than
EAC3_FRAME_TYPE_INDEPENDENT have a supported substream id.
(CVE-2018-13302)
- avcodec/ac3_parser: Check init_get_bits8() for failure.
(CVE-2018-13303)
- avcodec/mpeg4videodec: Remove use of FF_PROFILE_MPEG4_SIMPLE_STUDIO as
indicator of studio profile. (CVE-2018-13304)
- avformat/movenc: Check input sample count. (CVE-2018-14394)
- avformat/movenc: Write version 2 of audio atom if channels is not known.
(CVE-2018-14395)
* debian/control:
- Add winff Breaks. (See: #904141)
* debian/rules:
- Only pass --target-os when cross compiling. (Closes: #904052)
[ YunQiang Su ]
* debian/rules: Fix FTBFS with MIPS R6. (Closes: #904178)
2018-07-18 - James Cowgill <jcowgill@debian.org>
ffmpeg (7:4.0.1-2) unstable; urgency=medium
* Upload to unstable.

See Also

Package Description
libswt-cairo-gtk-4-jni_4.12.0-1_i386.deb Standard Widget Toolkit for GTK+ Cairo JNI library
libswt-glx-gtk-4-jni_4.12.0-1_i386.deb Standard Widget Toolkit for GTK+ GLX JNI library
libswt-gtk-4-java_4.12.0-1_i386.deb Standard Widget Toolkit for GTK+ Java library
libswt-gtk-4-jni_4.12.0-1_i386.deb Standard Widget Toolkit for GTK+ JNI library
libswt-webkit-gtk-4-jni_4.12.0-1_i386.deb Standard Widget Toolkit for GTK+ WebKit JNI library
libswtcalendar-java_0.5-2_all.deb GUI date picker for Java using SWT
libswtchart-java-doc_0.10.0-3_all.deb Chart drawing SWT component (documentation)
libswtchart-java_0.10.0-3_all.deb Chart drawing SWT component
libsx-dev_2.08-4_i386.deb Development files (headers and static libraries) for libsx
libsx0_2.08-4_i386.deb Simple X library
libsxclient-dev_2.0+ds-4+b1_i386.deb Scalable public and private cloud storage
libsxclient3_2.0+ds-4+b1_i386.deb Scalable public and private cloud storage
libsybdb5_1.1.6-1+b1_i386.deb libraries for connecting to MS SQL and Sybase SQL servers
libsylfilter0_0.8-7_i386.deb generic spam filter library
libsylph-dev_1.1.0-20_i386.deb e-mail client library derived from Sylpheed - devel files
Advertisement
Advertisement