libsdl-net1.2_1.2.8-6+b1_i386.deb


Advertisement

Description

libsdl-net1.2 - Network library for Simple DirectMedia Layer 1.2, libraries

Property Value
Distribution Debian Sid
Repository Debian Main i386
Package filename libsdl-net1.2_1.2.8-6+b1_i386.deb
Package name libsdl-net1.2
Package version 1.2.8
Package release 6+b1
Package architecture i386
Package type deb
Category libs role::shared-lib
Homepage https://www.libsdl.org/projects/SDL_net/
License -
Maintainer Debian SDL packages maintainers <pkg-sdl-maintainers@lists.alioth.debian.org>
Download size 15.72 KB
Installed size 42.00 KB

Alternatives

Package Version Architecture Repository
libsdl-net1.2_1.2.8-6+b1_amd64.deb 1.2.8 amd64 Debian Main
libsdl-net1.2 - - -

Requires

Name Value
libc6 >= 2.28
libsdl1.2debian >= 1.2.11

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libsdl-net1.2_1.2.8-6+b1_i386.deb
Source Package sdl-net1.2

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libsdl-net1.2 deb package:
    # sudo apt-get install libsdl-net1.2

Files

Path
/usr/lib/i386-linux-gnu/libSDL_net-1.2.so.0
/usr/lib/i386-linux-gnu/libSDL_net-1.2.so.0.8.0
/usr/share/doc/libsdl-net1.2/README
/usr/share/doc/libsdl-net1.2/changelog.Debian.gz
/usr/share/doc/libsdl-net1.2/changelog.Debian.i386.gz
/usr/share/doc/libsdl-net1.2/changelog.gz
/usr/share/doc/libsdl-net1.2/copyright
/usr/share/lintian/overrides/libsdl-net1.2

Changelog

2018-10-23 - Manuel A. Fernandez Montecelo <mafm@debian.org>
sdl-net1.2 (1.2.8-6) unstable; urgency=medium
* Bump Policy Standards-Version to 4.2.1 (no changes needed)
* Drop Build-Depends on "dpkg-dev (>= 1.16.1~)", it is very old and
satisfied everywhere
* d/copyright: use https in Format and Source URLs
* d/watch:
- Switch to version=4
- Use https in URL
* d/control:
- Set "Rules-Requires-Root: no"
- Use https in Homepage URL
- Update Vcs-* URLs
* Switch to debhelper compat level v11
* d/rules:
- Drop override of dh_auto_installchangelogs, nowadays it is
unnecessary and in addition it was wrong (it should have been override
of dh_installchangelogs)
2017-08-02 - Manuel A. Fernandez Montecelo <mafm@debian.org>
sdl-net1.2 (1.2.8-5) unstable; urgency=medium
* Bump Policy Standards-Version to 4.0.0 (no changes needed)
* Switch to debhelper compat level v10
- dh flags --parallel are not needed
- autoreconf is invoked by default
* Use automatic dbgsym packages, drop -dbg
* Update Vcs-* URLs
* d/copyright: Fix missing "General" in LGPL license blurb
2013-12-20 - Manuel A. Fernandez Montecelo <mafm@debian.org>
sdl-net1.2 (1.2.8-4) unstable; urgency=medium
* Bump Policy Standards-Version to 3.9.5 (no changes needed)
* Regenerate with dh_autoreconf without using upstream's autogen.sh
2013-05-09 - Manuel A. Fernandez Montecelo <mafm@debian.org>
sdl-net1.2 (1.2.8-3) unstable; urgency=low
* Update debian/copyright format now that 1.0 is approved (quells lintian
unversioned-copyright-format-uri)
* Bump Policy Standards-Version to 3.9.4 (no changes needed)
* Add package -dbg with debugging information
* Remove field "DM-Upload-Allowed: yes", obsolete
* Change maintainer address
2012-04-26 - Manuel A. Fernandez Montecelo <manuel.montezelo@gmail.com>
sdl-net1.2 (1.2.8-2) unstable; urgency=low
* Bump Standards-Version to 3.9.3 (no changes needed)
* Build-Depends on debhelper>=9~, quells lintian warning
"package-needs-versioned-debhelper-build-depends 9"
* Build-Depends and Depends on SDL with added ~ to the version number, in
order to allow to work with backported/local versions
* Adding lintian overrides for the slightly different names "libsdl-net1.2"
and "libSDL-net-1.2-0" -- the package names are not going to change by now
for the 1.2 series
2012-01-20 - Manuel A. Fernandez Montecelo <manuel.montezelo@gmail.com>
sdl-net1.2 (1.2.8-1) unstable; urgency=low
* New upstream release
- debian/copyright: License switched to zlib/libpng
* Modifying slightly the long description: removing the URL from there, it's
in the Homepage field since a while ago
* Disabled patches:
- pkgconfig_hgd61d0055d08c.patch: Picked from upsteam, now released
* Refresh patches:
- arm.patch
- endian.patch
- UDP_Bind.patch
2011-12-21 - Manuel A. Fernandez Montecelo <manuel.montezelo@gmail.com>
sdl-net1.2 (1.2.7-5) unstable; urgency=low
* Add also 'Multi-Arch: same' to -dev package, since the headers are all
architecture-independent. Thanks to Steve Langasek. (Closes: #652873)
2011-12-19 - Manuel A. Fernandez Montecelo <manuel.montezelo@gmail.com>
sdl-net1.2 (1.2.7-4) unstable; urgency=low
* Remove previous uploader, inactive for years
* Switch to debhelper compat level v9
* Build for multiarch
* Quell lintian warnings:
- binary-control-field-duplicates-source (remove field from binary package
libsdl-net1.2)

See Also

Package Description
libsdl-ocaml-dev_0.9.1-3_i386.deb OCaml bindings for SDL - development files
libsdl-ocaml_0.9.1-3_i386.deb OCaml bindings for SDL - runtime files
libsdl-pango-dev_0.1.2-8+b1_i386.deb text rendering with Pango in SDL applications (development)
libsdl-pango1_0.1.2-8+b1_i386.deb text rendering with Pango in SDL applications (shared library)
libsdl-perl_2.548-1+b2_i386.deb SDL bindings for the Perl language
libsdl-sge-dev_030809dfsg-9+b1_i386.deb extension of graphic functions for the SDL multimedia, development files
libsdl-sge_030809dfsg-9+b1_i386.deb extension of graphic functions for SDL multimedia libraries
libsdl-sound-gst_3.2.5-1.3_all.deb SDL_sound bindings for GNU Smalltalk
libsdl-sound1.2-dev_1.0.3-9+b1_i386.deb Sound library for Simple DirectMedia Layer 1.2, development files
libsdl-sound1.2_1.0.3-9+b1_i386.deb Sound library for Simple DirectMedia Layer 1.2, libraries
libsdl-ttf-gst_3.2.5-1.3_all.deb SDL_ttf bindings for GNU Smalltalk
libsdl-ttf2.0-0_2.0.11-6_i386.deb TrueType Font library for Simple DirectMedia Layer 1.2, libraries
libsdl-ttf2.0-dev_2.0.11-6_i386.deb TrueType Font library for Simple DirectMedia Layer 1.2, development files
libsdl1.2-dev_1.2.15+dfsg2-5_i386.deb Simple DirectMedia Layer development files
libsdl1.2debian_1.2.15+dfsg2-5_i386.deb Simple DirectMedia Layer
Advertisement
Advertisement