libqwt-qt5-dev_6.1.4-1.1_i386.deb


Advertisement

Description

libqwt-qt5-dev - Qt widgets library for technical applications (development, qt5)

Property Value
Distribution Debian Sid
Repository Debian Main i386
Package filename libqwt-qt5-dev_6.1.4-1.1_i386.deb
Package name libqwt-qt5-dev
Package version 6.1.4
Package release 1.1
Package architecture i386
Package type deb
Category devel::library libdevel role::devel-lib
Homepage http://qwt.sourceforge.net
License -
Maintainer Gudjon I. Gudjonsson <gudjon@gudjon.org>
Download size 104.96 KB
Installed size 592.00 KB

Alternatives

Package Version Architecture Repository
libqwt-qt5-dev_6.1.4-1.1_amd64.deb 6.1.4 amd64 Debian Main
libqwt-qt5-dev - - -

Requires

Name Value
libc6 >= 2.4
libgcc1 >= 1:3.0
libqt5core5a >= 5.11.0~rc1
libqt5designer5 >= 5.6.0~beta
libqt5gui5 >= 5.0.2
libqt5widgets5 >= 5.0.2
libqwt-qt5-6 = 6.1.4-1.1
libstdc++6 >= 5

Replaces

Name Value
libqwt-headers << 6.1.4-1.1~

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libqwt-qt5-dev_6.1.4-1.1_i386.deb
Source Package qwt

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libqwt-qt5-dev deb package:
    # sudo apt-get install libqwt-qt5-dev

Files

Path
/usr/include/qwt/qwt.h
/usr/include/qwt/qwt_abstract_legend.h
/usr/include/qwt/qwt_abstract_scale.h
/usr/include/qwt/qwt_abstract_scale_draw.h
/usr/include/qwt/qwt_abstract_slider.h
/usr/include/qwt/qwt_analog_clock.h
/usr/include/qwt/qwt_arrow_button.h
/usr/include/qwt/qwt_clipper.h
/usr/include/qwt/qwt_color_map.h
/usr/include/qwt/qwt_column_symbol.h
/usr/include/qwt/qwt_compass.h
/usr/include/qwt/qwt_compass_rose.h
/usr/include/qwt/qwt_compat.h
/usr/include/qwt/qwt_counter.h
/usr/include/qwt/qwt_curve_fitter.h
/usr/include/qwt/qwt_date.h
/usr/include/qwt/qwt_date_scale_draw.h
/usr/include/qwt/qwt_date_scale_engine.h
/usr/include/qwt/qwt_dial.h
/usr/include/qwt/qwt_dial_needle.h
/usr/include/qwt/qwt_dyngrid_layout.h
/usr/include/qwt/qwt_event_pattern.h
/usr/include/qwt/qwt_global.h
/usr/include/qwt/qwt_graphic.h
/usr/include/qwt/qwt_interval.h
/usr/include/qwt/qwt_interval_symbol.h
/usr/include/qwt/qwt_knob.h
/usr/include/qwt/qwt_legend.h
/usr/include/qwt/qwt_legend_data.h
/usr/include/qwt/qwt_legend_label.h
/usr/include/qwt/qwt_magnifier.h
/usr/include/qwt/qwt_math.h
/usr/include/qwt/qwt_mathml_text_engine.h
/usr/include/qwt/qwt_matrix_raster_data.h
/usr/include/qwt/qwt_null_paintdevice.h
/usr/include/qwt/qwt_painter.h
/usr/include/qwt/qwt_painter_command.h
/usr/include/qwt/qwt_panner.h
/usr/include/qwt/qwt_picker.h
/usr/include/qwt/qwt_picker_machine.h
/usr/include/qwt/qwt_pixel_matrix.h
/usr/include/qwt/qwt_plot.h
/usr/include/qwt/qwt_plot_abstract_barchart.h
/usr/include/qwt/qwt_plot_barchart.h
/usr/include/qwt/qwt_plot_canvas.h
/usr/include/qwt/qwt_plot_curve.h
/usr/include/qwt/qwt_plot_dict.h
/usr/include/qwt/qwt_plot_directpainter.h
/usr/include/qwt/qwt_plot_glcanvas.h
/usr/include/qwt/qwt_plot_grid.h
/usr/include/qwt/qwt_plot_histogram.h
/usr/include/qwt/qwt_plot_intervalcurve.h
/usr/include/qwt/qwt_plot_item.h
/usr/include/qwt/qwt_plot_layout.h
/usr/include/qwt/qwt_plot_legenditem.h
/usr/include/qwt/qwt_plot_magnifier.h
/usr/include/qwt/qwt_plot_marker.h
/usr/include/qwt/qwt_plot_multi_barchart.h
/usr/include/qwt/qwt_plot_panner.h
/usr/include/qwt/qwt_plot_picker.h
/usr/include/qwt/qwt_plot_rasteritem.h
/usr/include/qwt/qwt_plot_renderer.h
/usr/include/qwt/qwt_plot_rescaler.h
/usr/include/qwt/qwt_plot_scaleitem.h
/usr/include/qwt/qwt_plot_seriesitem.h
/usr/include/qwt/qwt_plot_shapeitem.h
/usr/include/qwt/qwt_plot_spectrocurve.h
/usr/include/qwt/qwt_plot_spectrogram.h
/usr/include/qwt/qwt_plot_svgitem.h
/usr/include/qwt/qwt_plot_textlabel.h
/usr/include/qwt/qwt_plot_tradingcurve.h
/usr/include/qwt/qwt_plot_zoneitem.h
/usr/include/qwt/qwt_plot_zoomer.h
/usr/include/qwt/qwt_point_3d.h
/usr/include/qwt/qwt_point_data.h
/usr/include/qwt/qwt_point_mapper.h
/usr/include/qwt/qwt_point_polar.h
/usr/include/qwt/qwt_raster_data.h
/usr/include/qwt/qwt_round_scale_draw.h
/usr/include/qwt/qwt_samples.h
/usr/include/qwt/qwt_sampling_thread.h
/usr/include/qwt/qwt_scale_div.h
/usr/include/qwt/qwt_scale_draw.h
/usr/include/qwt/qwt_scale_engine.h
/usr/include/qwt/qwt_scale_map.h
/usr/include/qwt/qwt_scale_widget.h
/usr/include/qwt/qwt_series_data.h
/usr/include/qwt/qwt_series_store.h
/usr/include/qwt/qwt_slider.h
/usr/include/qwt/qwt_spline.h
/usr/include/qwt/qwt_symbol.h
/usr/include/qwt/qwt_system_clock.h
/usr/include/qwt/qwt_text.h
/usr/include/qwt/qwt_text_engine.h
/usr/include/qwt/qwt_text_label.h
/usr/include/qwt/qwt_thermo.h
/usr/include/qwt/qwt_transform.h
/usr/include/qwt/qwt_wheel.h
/usr/include/qwt/qwt_widget_overlay.h
/usr/lib/libqwt-qt5.so
/usr/lib/i386-linux-gnu/qt5/mkspecs/features/qwt.prf
/usr/lib/i386-linux-gnu/qt5/mkspecs/features/qwtconfig.pri
/usr/lib/i386-linux-gnu/qt5/mkspecs/features/qwtfunctions.pri
/usr/lib/i386-linux-gnu/qt5/plugins/designer/libqwt_designer_plugin.so
/usr/lib/pkgconfig/Qt5Qwt6.pc
/usr/share/doc/libqwt-qt5-dev/changelog.Debian.gz
/usr/share/doc/libqwt-qt5-dev/changelog.gz
/usr/share/doc/libqwt-qt5-dev/copyright

Changelog

2019-08-25 - Lisandro Damián Nicanor Pérez Meyer <lisandro@debian.org>
qwt (6.1.4-1.1) unstable; urgency=medium
* Non-maintainer upload.
* Switch to debhelper compat 12.
* Install man pages.
* Fail in case of files not being installed.
* Drop the Qt 4 version (Closes: #875165).
- Remove unneeded build dependencies.
- Remove related packages.
- Make libqwt-headers-dev a transitional package that depends upon
libqwt-qt5-dev.
- Add Breaks + Replaces.
- Modify debian/rules accordingly.
* Bump Standards-Version to 4.4.0. No changes required.
* Move qwtmathml.prf to libqwtmathml-qt5-dev, adding proper Breaks+Replaces.
2019-02-28 - Gudjon I. Gudjonsson <gudjon@gudjon.org>
qwt (6.1.4-1) unstable; urgency=medium
* New upstream release
* Change watch file url to https.
* Bump standards version to 4.3.0.2
* Refresh all patches
* Change 6.1.3 to 6.1.4 in rules file
* Update symbols files
* Don't exclude build of qt4 designer plugin
2018-01-12 - Gudjon I. Gudjonsson <gudjon@gudjon.org>
qwt (6.1.3-1) unstable; urgency=medium
* New upstream version
* Bump standards version to 4.1.3, no changes needed
* Change compat level to 9
* Remove unwanted man1 manpages (Closes: #850641)
* Change myself to maintainer (Closes: #879431)
* Update symbols files with buildds' logs. Yet again.
(Closes: #886171)
* Override dh_makeshlibs to not fail on symbols changes,
and set upstream version (thanks to Bas Couwenberg)
* Add README.source file
2016-09-05 - Lisandro Damián Nicanor Pérez Meyer <lisandro@debian.org>
qwt (6.1.2-6) unstable; urgency=medium
* Non-maintainer upload.
* Update symbols files with buildds' logs. Yet again.
2016-09-04 - Lisandro Damián Nicanor Pérez Meyer <lisandro@debian.org>
qwt (6.1.2-5.4) unstable; urgency=medium
* Non-maintainer upload.
* Update symbols files with buildds' logs.
2016-09-04 - Lisandro Damián Nicanor Pérez Meyer <lisandro@debian.org>
qwt (6.1.2-5.3) unstable; urgency=medium
* Non-maintainer upload.
* Update symbols files with buildds' and current build logs
(Closes: #835755).
2016-07-16 - Lisandro Damián Nicanor Pérez Meyer <lisandro@debian.org>
qwt (6.1.2-5.2) unstable; urgency=medium
* Non-maintainer upload.
* Update symbols files with buildd's logs.
2016-07-15 - Lisandro Damián Nicanor Pérez Meyer <lisandro@debian.org>
qwt (6.1.2-5.1) unstable; urgency=medium
[ Bas Couwenberg ]
* Non-maintainer upload.
* Update symbols for amd64 (recent logs), sparc64 & x32 (old logs).
[ Lisandro Damián Nicanor Pérez Meyer ]
* Mark optional symbols as such to prevent further FTBFSs.
* Fix typo in previous changelog entry.
* Bump Standards-Version to 3.9.8, no changes required.
2016-03-07 - Lisandro Damián Nicanor Pérez Meyer <lisandro@debian.org>
qwt (6.1.2-5) unstable; urgency=medium
* Team upload to unstable.
* Update Standards-Version to 3.9.7, no changes required.
2016-01-25 - Gudjon I. Gudjonsson <gudjon@gudjon.org>
qwt (6.1.2-4) experimental; urgency=medium
* Update symbol files from builds

See Also

Package Description
libqwt5-doc_5.2.3-1_all.deb Qt widgets library for technical applications (documentation)
libqwt5-qt4-dev_5.2.3-1+b2_i386.deb Qt4 widgets library for technical applications (development)
libqwt5-qt4_5.2.3-1+b2_i386.deb Qt4 widgets library for technical applications (runtime)
libqwt6abi1_6.1.4-1_i386.deb Qt widgets library for technical applications (runtime, qt4)
libqwtmathml-dev_6.1.4-1_i386.deb Text Engine for Qwt (development, qt4)
libqwtmathml-qt5-6_6.1.4-1.1_i386.deb Text Engine for Qwt (runtime, qt5)
libqwtmathml-qt5-dev_6.1.4-1.1_i386.deb Text Engine for Qwt (development, qt5)
libqwtmathml6abi1_6.1.4-1_i386.deb Text Engine for Qwt (runtime, qt4)
libqwtplot3d-doc_0.2.7+svn191+gcc7-3_all.deb 3D plotting library based on Qt/OpenGL (documentation)
libqwtplot3d-qt5-0_0.2.7+svn191+gcc7-3_i386.deb 3D plotting library based on Qt5/OpenGL (runtime)
libqwtplot3d-qt5-dev_0.2.7+svn191+gcc7-3_i386.deb 3D plotting library based on Qt5/OpenGL (development)
libqxmpp-dev_1.0.0-4+b1_i386.deb Development files for the QXmpp library
libqxmpp-doc_1.0.0-4_all.deb Documentation for the QXmpp library
libqxmpp1_1.0.0-4+b1_i386.deb QXmpp library for XMPP client and server applications
libqxp-0.0-0_0.0.2-1_i386.deb library for reading and converting QuarkXPress files
Advertisement
Advertisement