libqca-qt5-2-dev_2.2.1-2_i386.deb


Advertisement

Description

libqca-qt5-2-dev - development files for the Qt Cryptographic Architecture

Property Value
Distribution Debian Sid
Repository Debian Main i386
Package filename libqca-qt5-2-dev_2.2.1-2_i386.deb
Package name libqca-qt5-2-dev
Package version 2.2.1
Package release 2
Package architecture i386
Package type deb
Category devel::library libdevel role::devel-lib
Homepage https://userbase.kde.org/QCA
License -
Maintainer Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
Download size 81.57 KB
Installed size 465.00 KB

Alternatives

Package Version Architecture Repository
libqca-qt5-2-dev_2.2.1-2_amd64.deb 2.2.1 amd64 Debian Main
libqca-qt5-2-dev - - -

Requires

Name Value
libqca-qt5-2 = 2.2.1-2
qtbase5-dev -

Conflicts

Name Value
qca-dev -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libqca-qt5-2-dev_2.2.1-2_i386.deb
Source Package qca2

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libqca-qt5-2-dev deb package:
    # sudo apt-get install libqca-qt5-2-dev

Files

Path
/usr/include/Qca-qt5/QtCrypto/QtCrypto
/usr/include/Qca-qt5/QtCrypto/qca.h
/usr/include/Qca-qt5/QtCrypto/qca_basic.h
/usr/include/Qca-qt5/QtCrypto/qca_cert.h
/usr/include/Qca-qt5/QtCrypto/qca_core.h
/usr/include/Qca-qt5/QtCrypto/qca_export.h
/usr/include/Qca-qt5/QtCrypto/qca_keystore.h
/usr/include/Qca-qt5/QtCrypto/qca_publickey.h
/usr/include/Qca-qt5/QtCrypto/qca_safetimer.h
/usr/include/Qca-qt5/QtCrypto/qca_securelayer.h
/usr/include/Qca-qt5/QtCrypto/qca_securemessage.h
/usr/include/Qca-qt5/QtCrypto/qca_support.h
/usr/include/Qca-qt5/QtCrypto/qca_textfilter.h
/usr/include/Qca-qt5/QtCrypto/qca_tools.h
/usr/include/Qca-qt5/QtCrypto/qca_version.h
/usr/include/Qca-qt5/QtCrypto/qcaprovider.h
/usr/include/Qca-qt5/QtCrypto/qpipe.h
/usr/lib/i386-linux-gnu/libqca-qt5.so
/usr/lib/i386-linux-gnu/cmake/Qca-qt5/Qca-qt5Config.cmake
/usr/lib/i386-linux-gnu/cmake/Qca-qt5/Qca-qt5ConfigVersion.cmake
/usr/lib/i386-linux-gnu/cmake/Qca-qt5/Qca-qt5Targets-debian.cmake
/usr/lib/i386-linux-gnu/cmake/Qca-qt5/Qca-qt5Targets.cmake
/usr/lib/i386-linux-gnu/pkgconfig/qca2-qt5.pc
/usr/lib/i386-linux-gnu/qt5/mkspecs/features/crypto.prf
/usr/share/doc/libqca-qt5-2-dev/changelog.Debian.gz
/usr/share/doc/libqca-qt5-2-dev/copyright

Changelog

2019-08-26 - Felix Geyer <fgeyer@debian.org>
qca2 (2.2.1-2) unstable; urgency=medium
* Stop building packages for Qt 4. (Closes: #875133)
* Switch to debhelper compat level 12.
2019-07-14 - Felix Geyer <fgeyer@debian.org>
qca2 (2.2.1-1) unstable; urgency=medium
* New upstream release.
* Drop patches that have been fixed upstream:
- Add_support_for_OpenSSL_1.1.0.diff
- Disable_missed_openssl_cipher_suites.diff
* Update symbols files.
* Adapt watch file to new URL.
* Point Vcs contorl fields to salsa.d.o
* Switch to new upstream URL.
* Update copyright file.
2018-01-21 - Felix Geyer <fgeyer@debian.org>
qca2 (2.1.3-2) unstable; urgency=medium
* Switch to OpenSSL 1.1. (Closes: #850897)
Backport upstream patches:
- Disable_missed_openssl_cipher_suites.diff
- Add_support_for_OpenSSL_1.1.0.diff
* Remove transitional packages. (Closes: #874758)
* Migrate to -dbgsym packages.
* Update symbols files.
* Fix acc autopkgtest by allowing stderr output.
* Switch to debhelper compat level 11.
2017-06-18 - Felix Geyer <fgeyer@debian.org>
qca2 (2.1.3-1) unstable; urgency=medium
* New upstream release.
* Remove patches that have been applied upstream:
- fix_build_without_sslv3.diff
- fix_base64_decoding_on_ARM.diff
2016-11-15 - Felix Geyer <fgeyer@debian.org>
qca2 (2.1.1-4) unstable; urgency=medium
* Fix FTBFS on architectures where char is unsigned.
- Add fix_base64_decoding_on_ARM.diff
2016-11-15 - Felix Geyer <fgeyer@debian.org>
qca2 (2.1.1-3) unstable; urgency=medium
* Keep using openssl 1.0 since upstream doesn't support 1.1 and adapting
the codebase seems non-trivial. (bug #828519)
* Update symbols files.
2015-11-04 - Felix Geyer <fgeyer@debian.org>
qca2 (2.1.1-2) unstable; urgency=medium
* Fix build without SSLv3.
- Cherry-pick fix_build_without_sslv3.diff from upstream.
2015-10-28 - Felix Geyer <fgeyer@debian.org>
qca2 (2.1.1-1) unstable; urgency=medium
* New upstream release.
- Fixes FTBFS with Qt 5.5. (Closes: #803238)
* Update watch file.
* Remove inactive uploaders from the list.
2015-08-05 - Maximiliano Curia <maxy@debian.org>
qca2 (2.1.0.3-4) unstable; urgency=medium
* Update symbols files from buildds logs (2.1.0.3-3).
* Update symbols files for gcc5 compatibility. (Closes: #778083)
Thanks to Matthias Klose
* Update symbols files.
2015-06-08 - Felix Geyer <fgeyer@debian.org>
qca2 (2.1.0.3-3) unstable; urgency=medium
* Team upload to unstable.
* Update symbols files.

See Also

Package Description
libqca-qt5-2-plugins_2.2.1-2_i386.deb QCA plugins for libqca2
libqca-qt5-2_2.2.1-2_i386.deb libraries for the Qt Cryptographic Architecture
libqca2-doc_2.2.1-2_all.deb API documentation for the Qt Cryptographic Architecture
libqcheck-core-ocaml-dev_0.9-2_i386.deb QuickCheck inspired property-based testing for OCaml (Development package)
libqcheck-core-ocaml_0.9-2_i386.deb QuickCheck inspired property-based testing for OCaml (Runtime library)
libqcheck-ocaml-dev_0.9-2_i386.deb QuickCheck inspired property-based testing for OCaml (Development package)
libqcheck-ocaml-doc_0.9-2_all.deb Documentation for ocaml-qcheck
libqcheck-ocaml_0.9-2_i386.deb QuickCheck inspired property-based testing for OCaml (Runtime library)
libqcheck-ounit-ocaml-dev_0.9-2_i386.deb QCheck integration with OUnit (Development package)
libqcheck-ounit-ocaml_0.9-2_i386.deb QCheck integration with OUnit (Runtime library)
libqcow-dev_20181227-1_i386.deb QEMU Copy-On-Write image format access library -- development files
libqcow-utils_20181227-1_i386.deb QEMU Copy-On-Write image format access library -- Utilities
libqcow1_20181227-1_i386.deb QEMU Copy-On-Write image format access library
libqcsxcad0_0.0.35+dfsg.1-4_i386.deb QT Gui Library for Visualization of Continuous Structure XML
libqcustomplot-dev_2.0.1+dfsg1-1_i386.deb Qt C++ widget for plotting - header
Advertisement
Advertisement