libpackagekit-glib2-18_1.1.12-5+b1_i386.deb


Advertisement

Description

libpackagekit-glib2-18 - Library for accessing PackageKit using GLib

Property Value
Distribution Debian Sid
Repository Debian Main i386
Package filename libpackagekit-glib2-18_1.1.12-5+b1_i386.deb
Package name libpackagekit-glib2-18
Package version 1.1.12
Package release 5+b1
Package architecture i386
Package type deb
Category libs role::shared-lib
Homepage https://www.freedesktop.org/software/PackageKit/
License -
Maintainer Matthias Klumpp <mak@debian.org>
Download size 113.92 KB
Installed size 464.00 KB

Alternatives

Package Version Architecture Repository
libpackagekit-glib2-18_1.1.12-5+b1_amd64.deb 1.1.12 amd64 Debian Main
libpackagekit-glib2-18 - - -

Requires

Name Value
libc6 >= 2.7
libglib2.0-0 >= 2.46

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libpackagekit-glib2-18_1.1.12-5+b1_i386.deb
Source Package packagekit

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpackagekit-glib2-18 deb package:
    # sudo apt-get install libpackagekit-glib2-18

Files

Path
/usr/lib/i386-linux-gnu/libpackagekit-glib2.so.18
/usr/lib/i386-linux-gnu/libpackagekit-glib2.so.18.1.3
/usr/share/doc/libpackagekit-glib2-18/changelog.Debian.gz
/usr/share/doc/libpackagekit-glib2-18/changelog.Debian.i386.gz
/usr/share/doc/libpackagekit-glib2-18/copyright

Changelog

2019-03-02 - Matthias Klumpp <mak@debian.org>
packagekit (1.1.12-5) unstable; urgency=medium
* Fix FTBFS on !amd64 architectures by removing the
GTK+2 plugin properly.
2019-03-02 - Matthias Klumpp <mak@debian.org>
packagekit (1.1.12-4) unstable; urgency=medium
* Add aptcc-frontend-locking.patch
- This implements APT frontend locking, which prevents other programs
from stealing the dpkg lock in race conditions where apt(cc) has to
release the lock in order to run dpkg.
2019-03-01 - Matthias Klumpp <mak@debian.org>
packagekit (1.1.12-3) unstable; urgency=medium
* Do not ship the GTK+2 plugin (Closes: #922118)
- Unfortunately we still need to build-depend on GTK+2 to
enable the GTK plugin build.
2019-02-26 - Matthias Klumpp <mak@debian.org>
packagekit (1.1.12-2) unstable; urgency=medium
[ Matthias Klumpp ]
* Remove Ubuntu-specific patch series, handle vendor config by
conditionally installing it in d/rules (Closes: #915352)
* Add no-distupgrade.patch:
- Disable GetDistroUpgrades() completely, it was partially
disabled before but still caused problems.
* Add keep-ref-on-transaction-while-doing-polkit-call.patch
- Avoids some log spam
[ Andrew Hayzen ]
* Add aptcc-use-correct-return-type-in-function.patch:
- Fix function return type, which resolves packagekitd crash
when gnome-software launches, causing gnome-software to hang
(Closes: #917812, #922236)
2018-12-22 - Matthias Klumpp <mak@debian.org>
packagekit (1.1.12-1) unstable; urgency=medium
* New upstream version: 1.1.12
- Applied aptcc patches carried in Debian
- common: Handle quoted strings in /etc/os-release
- offline update: Fix translations to show up
* Drop aptcc patches: Applied upstream
2018-10-15 - Matthias Klumpp <mak@debian.org>
packagekit (1.1.11-1) unstable; urgency=medium
* New upstream version: 1.1.11
* Never restart packagekitd via systemd after an upgrade of the daemon
* Add aptcc-always-do-multiarch-lookups.patch
- Always check multi-arch paths for .list files, as dpkg always adds the
architecture, even on non-multiarch systems.
* Add aptcc-update-section-mappings.patch
- Updates aptcc section mappings (Closes: #880484)
* Bump standards version: No changes needed
* Mark packagekit-docs as MA-foreign
2018-04-23 - Matthias Klumpp <mak@debian.org>
packagekit (1.1.10-1) unstable; urgency=high
* New upstream release: 1.1.10
- This release fixes CVE-2018-1106 (Closes: #896703)
- aptcc: Not all downloads have to be packages
- aptcc: Return multiple packages when using '|' operator
- aptcc: Simplify search methods
* Bump standards version: No changes needed
* Update Vcs-* URLs to point to Salsa
* Use auth_admin instead of auth_admin_keep as default authorization
for downgrades and package removals.
2018-03-12 - Matthias Klumpp <mak@debian.org>
packagekit (1.1.9-1) unstable; urgency=medium
* New upstream version: 1.1.9
* Drop patches: Applied upstream
* Adjust for dh compat level 11
* Update symbols file
* d/watch: Use https URL
* d/rules: Drop obsolete dh modules
2017-09-24 - Matthias Klumpp <mak@debian.org>
packagekit (1.1.7-1) unstable; urgency=medium
[ Matthias Klumpp ]
* New upstream version: 1.1.7
* Drop all patches: Applied upstream
* Add aptcc-fix-mimetype-search.patch: Don't fail when searching for mimetypes
- See LP: #1719077
* Bump standards and dh version
* Fail on missing files
* Add missing build-dependency on libappstream-dev
[ Iain Lane ]
* Always rebuild gtk-doc documentation

See Also

Package Description
libpackagekit-glib2-dev_1.1.12-5+b1_i386.deb Library for accessing PackageKit using GLib (development files)
libpackagekitqt5-1_1.0.1-1+b1_i386.deb Library for accessing PackageKit using Qt5
libpackagekitqt5-dev_1.0.1-1+b1_i386.deb Library for accessing PackageKit using Qt5 (development files)
libpacketdump3-dev_3.0.21-1+b2_i386.deb development headers for the libpacketdump library
libpacketdump3_3.0.21-1+b2_i386.deb network packet parsing and human-readable display library
libpacklib-lesstif1-dev_20061220+dfsg3-4.4_i386.deb CERNLIB data analysis suite - core GUI library (development files)
libpacklib-lesstif1-gfortran_20061220+dfsg3-4.4_i386.deb CERNLIB data analysis suite - core GUI library
libpacklib1-dev_20061220+dfsg3-4.4_i386.deb CERNLIB data analysis suite - core library (development files)
libpacklib1-gfortran_20061220+dfsg3-4.4_i386.deb CERNLIB data analysis suite - core library
libpacparser-dev_1.3.6-1.1+b4_i386.deb library to parse proxy auto-config files (development files)
libpacparser1_1.3.6-1.1+b4_i386.deb library to parse proxy auto-config files
libpadwalker-perl_2.3-1+b2_i386.deb module to inspect and manipulate lexical variables
libpagemaker-0.0-0_0.0.4-1_i386.deb Library for importing and converting PageMaker Documents
libpagemaker-dev_0.0.4-1_i386.deb Library for importing and converting PageMaker Documents -- development
libpaje-dev_1.3.4-3+b1_i386.deb Parsing, manipulation and simulation of paje trace files (dev)
Advertisement
Advertisement