libownet-php_3.2p3+dfsg1-4_all.deb


Advertisement

Description

libownet-php - Dallas 1-wire support: PHP OWNet library

Property Value
Distribution Debian Sid
Repository Debian Main i386
Package filename libownet-php_3.2p3+dfsg1-4_all.deb
Package name libownet-php
Package version 3.2p3+dfsg1
Package release 4
Package architecture all
Package type deb
Category php
Homepage http://owfs.org/
License -
Maintainer Vincent Danjean <vdanjean@debian.org>
Download size 17.55 KB
Installed size 66.00 KB

Alternatives

Package Version Architecture Repository
libownet-php_3.2p3+dfsg1-4_all.deb 3.2p3+dfsg1 all Debian Main
libownet-php - - -

Requires

Name Value
php -
php-cli -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libownet-php_3.2p3+dfsg1-4_all.deb
Source Package owfs

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libownet-php deb package:
    # sudo apt-get install libownet-php

Files

Path
/usr/share/doc/libownet-php/changelog.Debian.gz
/usr/share/doc/libownet-php/changelog.gz
/usr/share/doc/libownet-php/copyright
/usr/share/doc/libownet-php/examples/bcadd.php
/usr/share/doc/libownet-php/examples/ownet_example.php
/usr/share/php/OWNet/ownet.php

Changelog

2019-08-23 - Vincent Danjean <vdanjean@debian.org>
owfs (3.2p3+dfsg1-4) unstable; urgency=medium
* Reupload as source-only
2019-07-25 - Vincent Danjean <vdanjean@debian.org>
owfs (3.2p3+dfsg1-3) unstable; urgency=medium
* add -fPIC when compiling python modules (Closes: #932299)
* Use debhelper-compat for dh supported version
* bump Standards-Version
* Fix systemd glitches found by lintian
* Force correct LDFLAGS on python packages
* Fix typo in manpages (for upstream)
2018-12-18 - Vincent Danjean <vdanjean@debian.org>
owfs (3.2p3+dfsg1-2) unstable; urgency=medium
* Fix python raise syntax to support python3 (Closes: #916559)
2018-12-11 - Vincent Danjean <vdanjean@debian.org>
owfs (3.2p3+dfsg1-1) unstable; urgency=medium
[ Ondřej Nový ]
* d/watch: Use https protocol
[ Vincent Danjean ]
* Add Debian CI
* d/watch: switch to github
* Add support for python3
[ upstream ]
* v3.2p3 is mainly a bugfix & cleanup release.
* New Functions
+ Added owcapi "OW_visible" method
+ PHP7 support
+ Add pkg-config entry for owcapi
* Minor Fixes
+ Fixed OW_init() fail when parsing command line options before calling it
+ Fix glibc major() compat (Closes: #913105)
+ Fix uninstall in certain modules
+ Portable getpagesize
+ Fix generation of OW.pm
+ Add explicit avahi include dir, when enabled
+ Typos in manpages
2018-09-23 - Vincent Danjean <vdanjean@debian.org>
owfs (3.2p2-2) unstable; urgency=medium
* Remove transitional owfs-dbg package
* Make systemd service files uses /etc/owfs.conf (as was doing
previous init scripts)
* use Debian-ow user to run owftpd and owhttpd
2018-09-23 - Vincent Danjean <vdanjean@debian.org>
owfs (3.2p2-1) unstable; urgency=medium
* New upstream release (Closes: #908025)
* Use upstream systemd init files (Closes: #834018)
* compile with fdti support (Closes: #904850)
* add owusbprobe into ow-shell
* re-enable php binding (Closes: 823661)
2017-10-02 - Vincent Danjean <vdanjean@debian.org>
owfs (3.1p5-2) unstable; urgency=medium
* Fix "owfs FTBFS with debhelper 10.9" (Closes: #876692)
The libow-php5 was removed (see 3.1p1-4 below) but still in
the dh_makeshlibs invocation (to be excluded...)
2017-01-08 - Vincent Danjean <vdanjean@debian.org>
owfs (3.1p5-1) unstable; urgency=medium
* New upstream release
* fix watch file to avoid to look at non-release files
2016-09-30 - Vincent Danjean <vdanjean@debian.org>
owfs (3.1p4-1) unstable; urgency=medium
* New upstream release
+ remove patches that upstream applied
+ rename libraies (new soname as for each upstream release)
* Fix new typos found by lintian
* Add missing "Breaks: libow-2.8-15" (wheezy package) for owfs-common
as owfs-common take over its conffile (Closes: #838144)
* Remove libfuse-dev B-D on hurd-i386 (unavailable). Lets see if the
package still compile on this arch (Closes: #815466)
2016-05-16 - Vincent Danjean <vdanjean@debian.org>
owfs (3.1p1-6) unstable; urgency=medium
* Fix lintian-found (minor) bugs

See Also

Package Description
liboxford-calendar-perl_2.11-1_all.deb University of Oxford calendar conversion routines
liboxygenstyle5-5_5.14.5-2_i386.deb style library for the Oxygen desktop theme
liboxygenstyleconfig5-5_5.14.5-2_i386.deb style library configuration for the Oxygen desktop theme
libp11-3_0.4.10-1_i386.deb pkcs#11 convenience library
libp11-dev_0.4.10-1_i386.deb pkcs#11 convenience library - development files
libp11-kit-dev_0.23.17-2_i386.deb library for loading and coordinating access to PKCS#11 modules - development
libp11-kit0_0.23.17-2_i386.deb library for loading and coordinating access to PKCS#11 modules - runtime
libp8-platform-dev_2.1.0.1+dfsg1-3_i386.deb Pulse-Eight's platform support library -- development files
libp8-platform2_2.1.0.1+dfsg1-3_i386.deb Pulse-Eight's platform support library
libpa-ounit-camlp4-dev_113.00.00-3_i386.deb OCaml Syntax extension for writing inline tests
libpackage-constants-perl_0.06-1_all.deb module to list constants defined in a package
libpackage-deprecationmanager-perl_0.17-1_all.deb module for managing deprecation warnings for Perl distributions
libpackage-locator-perl_0.10-2_all.deb module to find a package among CPAN-like repositories
libpackage-new-perl_0.07-2_all.deb simple base package from which to inherit
libpackage-pkg-perl_0.0020-1_all.deb collection of package manipulation utilities
Advertisement
Advertisement