libopenthreads20_3.2.3+dfsg1-3+b1_i386.deb


Advertisement

Description

libopenthreads20 - Object-Oriented (OO) thread interface for C++, shared libs

Property Value
Distribution Debian Sid
Repository Debian Main i386
Package filename libopenthreads20_3.2.3+dfsg1-3+b1_i386.deb
Package name libopenthreads20
Package version 3.2.3+dfsg1
Package release 3+b1
Package architecture i386
Package type deb
Category libs role::shared-lib
Homepage http://www.openscenegraph.org/
License -
Maintainer Loic Dachary (OuoU) <loic@debian.org>
Download size 27.53 KB
Installed size 76.00 KB

Alternatives

Package Version Architecture Repository
libopenthreads20_3.2.3+dfsg1-3+b1_amd64.deb 3.2.3+dfsg1 amd64 Debian Main
libopenthreads20 - - -

Requires

Name Value
libc6 >= 2.4
libgcc1 >= 1:3.0
libstdc++6 >= 5

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libopenthreads20_3.2.3+dfsg1-3+b1_i386.deb
Source Package openscenegraph

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libopenthreads20 deb package:
    # sudo apt-get install libopenthreads20

Files

Path
/usr/lib/i386-linux-gnu/libOpenThreads.so.20
/usr/lib/i386-linux-gnu/libOpenThreads.so.3.2.1
/usr/share/doc/libopenthreads20/changelog.Debian.gz
/usr/share/doc/libopenthreads20/changelog.Debian.i386.gz
/usr/share/doc/libopenthreads20/copyright

Changelog

2019-01-07 - Alberto Luaces Fernández <aluaces@udc.es>
openscenegraph (3.2.3+dfsg1-3) unstable; urgency=medium
* Use the new version of libcoin (Closes: #917082, #912866).
2016-05-16 - Alberto Luaces Fernández <aluaces@udc.es>
openscenegraph (3.2.3+dfsg1-2) unstable; urgency=medium
* Fix FTBFS on Hurd.  Thanks Bas Couwenberg (Closes: #824395).
* Update standards to 3.9.8.  No changes required.
* Corrected copyright file according to lintian.
2016-03-22 - Alberto Luaces Fernández <aluaces@udc.es>
openscenegraph (3.2.3+dfsg1-1) unstable; urgency=medium
* Remove jasper dependency (Closes: #818211).
* Fixed source retrieval rule when using DFSG versions.
* Imported Upstream version 3.2.3+dfsg1
2016-03-11 - Alberto Luaces Fernández <aluaces@udc.es>
openscenegraph (3.2.2+dfsg1-1) unstable; urgency=medium
* Updated to new stable release (Closes: #814555).
* Debug packages are now generated automatically (Closes: #775368).
* Fixed my name in uploaders so lintian no longer triggers a warning
about NMUs.
* Fix doxygen configuration when reading header files.
* De-embed copies of jquery.js found on doxygen configuration.
* Update Vcs-Browser URL in debian/control.
* Update debian/copyright file.
* Fix FTBFS with ffmpeg 2.9 (Closes: #803849).  Thanks to Andreas
Cadhalpun.
2015-12-19 - Alberto Luaces Fernández <aluaces@udc.es>
openscenegraph (3.2.1-9) unstable; urgency=medium
* Added a compatibility fix for building with giflib5.  Thanks
Sebastiaan Couwenberg and Matthias Klose. (Closes: 803300)
* Modified debian/rules to set HTML_TIMESTAMP=NO for doxygen to make the
package reproducible.  Thanks to Maria Valentina Marin (Closes:
789264)
2015-10-19 - Alberto Luaces Fernández <aluaces@udc.es>
openscenegraph (3.2.1-8) unstable; urgency=medium
* Adding upstream patch for GDAL 2.0 support, needed by upcoming
transition.  Thanks to Bas Couwenberg. (Closes: 802266)
[ Matthias Klose ]
* Re-add a copy of the xine_xmalloc_aligned function, removed in
newer upstream versions. (Closes: 792320)
2015-08-30 - Manuel A. Fernandez Montecelo <mafm@debian.org>
openscenegraph (3.2.1-7) unstable; urgency=medium
[ Martin Pitt ]
* Rename libopenscenegraph100 to -v5 for gcc5 transition (Closes: #791231)
Note that libopenthreads20 can keep its name, its symbols don't change
under g++ 5.
2015-02-04 - Alberto Luaces Fernández <aluaces@udc.es>
openscenegraph (3.2.1-6) unstable; urgency=medium
[ Andreas Beckmann ]
* libopenscenegraph100: Add Breaks: libgdal1 for smooth upgrades from
wheezy. A little incentive that helps apt to take the right decision
between libgdal1 and libgdal1h.  (Closes: 777026)
2014-10-31 - Alberto Luaces Fernández <aluaces@udc.es>
openscenegraph (3.2.1-5) unstable; urgency=medium
* Update fix for correctly loading plugins on platforms other than amd64.
(Closes: 763821)
* Cherry-pick bug fix from upstream, SVN revision 14400.
Thanks to Rebecca N. Palmer (Closes: 765855)
* Update Standards version to 3.9.6.  No further changes required.
2014-10-03 - Alberto Luaces Fernández <aluaces@udc.es>
openscenegraph (3.2.1-4) unstable; urgency=medium
* A preprocessor substitution was interferring with the architecture name for loading plugins.
(Closes: 763816)

See Also

Package Description
libopentk-cil-dev_1.1.4c+dfsg-2.1_all.deb Open Toolkit wrapper for OpenGL, OpenAL and OpenCL - Dev files
libopentk1.1-cil_1.1.4c+dfsg-2.1_all.deb Open Toolkit wrapper for OpenGL, OpenAL and OpenCL - Assemblies
libopentoken-doc_6.0b-9_all.deb OpenToken lexical analysis library for Ada: documentation
libopentoken10_6.0b-9_i386.deb OpenToken lexical analysis library for Ada: shared library
libopentoken7-dev_6.0b-9_i386.deb OpenToken lexical analysis library for Ada: development
libopenturns-dev_1.10-5_i386.deb headers and development libraries for OpenTURNS
libopenturns0.11_1.10-5_i386.deb dynamic libraries for OpenTURNS
libopenusb-dev_1.1.11-2+b1_i386.deb alternative userspace USB programming library
libopenusb-doc_1.1.11-2_all.deb alternative userspace USB programming library
libopenusb0_1.1.11-2+b1_i386.deb alternative userspace USB programming library
libopenvas-dev_9.0.3-1+b2_i386.deb remote network security auditor - static libraries and headers
libopenvas-doc_9.0.3-1_all.deb remote network security auditor - libraries documentation
libopenvas9_9.0.3-1+b2_i386.deb remote network security auditor - shared libraries
libopenvdb-dev_5.2.0-7_i386.deb Sparse Volume Processing toolkit - dev
libopenvdb-doc_5.2.0-7_all.deb Sparse Volume Processing toolkit - doc
Advertisement
Advertisement