libofapi-dev_0git20070620-8+b1_i386.deb


Advertisement

Description

libofapi-dev - OpenFirmware device-tree parsing library - development files

Property Value
Distribution Debian Sid
Repository Debian Main i386
Package filename libofapi-dev_0git20070620-8+b1_i386.deb
Package name libofapi-dev
Package version 0git20070620
Package release 8+b1
Package architecture i386
Package type deb
Category devel::examples devel::library libdevel role::devel-lib
Homepage -
License -
Maintainer Debian Mactel <team+pkg-mactel-devel@tracker.debian.org>
Download size 10.04 KB
Installed size 42.00 KB

Alternatives

Package Version Architecture Repository
libofapi-dev_0git20070620-8+b1_amd64.deb 0git20070620 amd64 Debian Main
libofapi-dev - - -

Requires

Name Value
libofapi0 = 0git20070620-8+b1

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libofapi-dev_0git20070620-8+b1_i386.deb
Source Package oflib

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libofapi-dev deb package:
    # sudo apt-get install libofapi-dev

Files

Path
/usr/include/ofapi/of_api.h
/usr/include/ofapi/of_externals.h
/usr/include/ofapi/of_internals.h
/usr/include/ofapi/of_standard.h
/usr/lib/i386-linux-gnu/libofapi.a
/usr/lib/i386-linux-gnu/libofapi.so
/usr/share/doc/libofapi-dev/changelog.Debian.gz
/usr/share/doc/libofapi-dev/changelog.Debian.i386.gz
/usr/share/doc/libofapi-dev/copyright

Changelog

2018-06-02 - Nobuhiro Iwamatsu <iwamatsu@debian.org>
oflib (0git20070620-8) unstable; urgency=medium
* Update debian/control.
- Change Maintainer field. (Closes: #899854)
Maintainer: Debian Mactel <team+pkg-mactel-devel@tracker.debian.org>
- Update debhelper to 11.
- Bump Standards-Version to 4.1.4.
- Update description of package.
- Change Priority to optional.
* Update debian/copyright.
- Get rid of lintian 'insecure-copyright-format-uri'.
* 
2013-07-03 - Nobuhiro Iwamatsu <iwamatsu@debian.org>
oflib (0git20070620-7) unstable; urgency=low
* Update debian/control.
- Bump Standard Version: 3.9.4
- Change Maintainer field and Add Uploaders field. (Closes: #688545)
Maintainer: Debian Mactel <pkg-mactel-devel@lists.alioth.debian.org>
Uploaders: Nobuhiro Iwamatsu <iwamatsu@debian.org>
- Update debhelper to 9.
- Add libofapi-example package. This was separated from libofapi-dev.
- Add "Breaks: libofapi-dev (<= 0git20070620-6)" to libofapi-example.
- Add "Multi-Arch: same" to libofapi-dev.
* Update debian/copyright, convert to DEP5.
* Update debian/compat to 9.
* Convert debian/rules to dh.
* Enable hardening.
- Update patches/Makefile_mods_debian.patch.
2011-06-13 - Julien BLACHE <jblache@debian.org>
oflib (0git20070620-6) unstable; urgency=low
* Multiarch conversion.
* debian/control:
+ Bump Standards-Version to 3.9.2 (no changes).
+ Bump debhelper build-dep to >= 8.1.3 for multiarch.
+ Add Pre-Depends: ${misc:Pre-Depends} to libofapi0.
+ Tag libofapi0 with Multi-Arch: same.
* debian/rules:
+ Add DEB_HOST_MULTIARCH to make install invocation.
* debian/*.install:
+ Adapt for multiarch.
* debian/*.dirs:
+ Removed; unneeded.
* debian/patches/Makefile_mods_debian.patch:
+ Take multiarch path into account.
2011-01-12 - Julien BLACHE <jblache@debian.org>
oflib (0git20070620-5) unstable; urgency=low
* Switch to source format 3.0 (quilt).
* debian/control:
+ Bump Standards-Version to 3.9.1 (no changes).
+ Add ${misc:Depends} to libofapi-dev. 
* debian/patches/fix_examples.patch:
+ Added; fix the soundbus example and enable it (closes: #609796).
2008-03-01 - Julien BLACHE <jblache@debian.org>
oflib (0git20070620-4) unstable; urgency=low
* debian/control:
+ Bump Standards-Version to 3.7.3.
2007-12-04 - Julien BLACHE <jblache@debian.org>
oflib (0git20070620-3) unstable; urgency=low
* Makefile:
+ Use $(MAKE) instead of make, needed for parallel builds.
2007-08-02 - Julien BLACHE <jblache@debian.org>
oflib (0git20070620-2) unstable; urgency=low
* debian/rules:
+ Do not ignore errors from make clean.
2007-06-20 - Julien BLACHE <jblache@debian.org>
oflib (0git20070620-1) unstable; urgency=low
* New snapshot.
+ Patches for the libofapi.so.0 soname merged upstream.
* debian/control:
+ Rename library package to libofapi0.
+ Use ${binary:Version} instead of ${Source-Version}.
* debian/copyright:
+ Updated upstream's email address.
2007-03-01 - Julien BLACHE <jblache@debian.org>
oflib (0git20070301-1) unstable; urgency=low
* Initial release (Closes: #413022).

See Also

Package Description
libofapi-example_0git20070620-8_all.deb OpenFirmware device-tree parsing library - example files
libofapi0_0git20070620-8+b1_i386.deb OpenFirmware device-tree parsing library - runtime
libofx-dev_0.9.15-2_i386.deb development package for libofx7
libofx-doc_0.9.15-2_all.deb documentation for libofx7
libofx7_0.9.15-2_i386.deb library to support the Open Financial Exchange format
libogdf-tulip-4.8-0_4.8.0dfsg-2+b7_i386.deb Open Graph Drawing Framework shared library, built for Tulip
libogdi-dev_4.1.0+ds-1_i386.deb Open Geographic Datastore Interface Library -- development
libogdi4.1_4.1.0+ds-1_i386.deb Open Geographic Datastore Interface Library -- library
libogg-dev_1.3.2-1+b1_i386.deb Ogg bitstream library development files
libogg-ocaml-dev_0.5.2-1_i386.deb OCaml bindings for the Ogg bitstream library
libogg-ocaml_0.5.2-1_i386.deb OCaml bindings for the Ogg bitstream library
libogg-vorbis-decoder-perl_0.9-3+b6_i386.deb module for decoding Ogg Vorbis streams
libogg-vorbis-header-pureperl-perl_1.0-4_all.deb pure Perl interface to Ogg Vorbis information fields
libogg0_1.3.2-1+b1_i386.deb Ogg bitstream library
liboggkate-dev_0.4.1-9_i386.deb Codec for karaoke and text encapsulation for Ogg (dev)
Advertisement
Advertisement