libmaven-invoker-plugin-java_3.0.1-2_all.deb


Advertisement

Description

libmaven-invoker-plugin-java - Maven Invoker Plugin

Property Value
Distribution Debian Sid
Repository Debian Main i386
Package filename libmaven-invoker-plugin-java_3.0.1-2_all.deb
Package name libmaven-invoker-plugin-java
Package version 3.0.1
Package release 2
Package architecture all
Package type deb
Category java
Homepage http://maven.apache.org/plugins/maven-invoker-plugin/
License -
Maintainer Debian Java Maintainers <pkg-java-maintainers@lists.alioth.debian.org>
Download size 100.98 KB
Installed size 129.00 KB

Alternatives

Package Version Architecture Repository
libmaven-invoker-plugin-java_3.0.1-2_all.deb 3.0.1 all Debian Main
libmaven-invoker-plugin-java - - -

Requires

Name Value
groovy -
libbsh-java >= 2.0b4
libcommons-io-java -
libdoxia-core-java >= 1.7
libdoxia-sitetools-java >= 1.7.4
libmaven-artifact-transfer-java >= 0.9.1
libmaven-invoker-java >= 3.0.0
libmaven-reporting-api-java >= 3.0
libmaven-reporting-impl-java -
libmaven-script-interpreter-java >= 1.2
libmaven-shared-utils-java >= 3.1.0
libmaven3-core-java >= 3.5.0
libplexus-i18n-java -
libplexus-interpolation-java >= 1.24
libplexus-utils2-java >= 2.x

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libmaven-invoker-plugin-java_3.0.1-2_all.deb
Source Package maven-invoker-plugin

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libmaven-invoker-plugin-java deb package:
    # sudo apt-get install libmaven-invoker-plugin-java

Files

Path
/usr/share/doc/libmaven-invoker-plugin-java/changelog.Debian.gz
/usr/share/doc/libmaven-invoker-plugin-java/copyright
/usr/share/maven-repo/org/apache/maven/plugins/maven-invoker-plugin/3.0.1/maven-invoker-plugin-3.0.1.jar
/usr/share/maven-repo/org/apache/maven/plugins/maven-invoker-plugin/3.0.1/maven-invoker-plugin-3.0.1.pom

Changelog

2017-08-27 - Emmanuel Bourg <ebourg@apache.org>
maven-invoker-plugin (3.0.1-2) unstable; urgency=medium
* Team upload.
* Depend on libmaven-reporting-api-java instead of libmaven2-core-java
* Standards-Version updated to 4.1.0
2017-07-27 - Emmanuel Bourg <ebourg@apache.org>
maven-invoker-plugin (3.0.1-1) unstable; urgency=medium
* Team upload.
* New upstream release
- New dependency on libmaven-artifact-transfer-java
- Build depend on junit4 instead of junit
- Depend on libmaven-invoker-java (>= 3.0.0)
- Depend on libmaven3-core-java instead of libmaven2-core-java
* Standards-Version updated to 4.0.0
* Switch to debhelper level 10
2016-05-19 - Emmanuel Bourg <ebourg@apache.org>
maven-invoker-plugin (2.0.0-1) unstable; urgency=medium
* Team upload.
* New upstream release (Closes: #796391)
- New dependency on libmaven-script-interpreter-java
- Depend on libplexus-utils2-java instead of libplexus-utils-java
- Tightened the dependency on libmaven2-core-java (>= 2.2.1-26~)
* Enabled the unit tests
* Standards-Version updated to 3.9.8 (no changes)
* Use XZ compression for the upstream tarball
* Depend on groovy instead of groovy2
* Use secure Vcs-* URLs
2015-11-20 - Emmanuel Bourg <ebourg@apache.org>
maven-invoker-plugin (1.5-5) unstable; urgency=medium
* Team upload.
[ Emmanuel Bourg ]
* Transition to Groovy 2
* Build with the DH sequencer instead of CDBS
[ Miguel Landaeta ]
* Moved the package to Git
2015-07-09 - Emmanuel Bourg <ebourg@apache.org>
maven-invoker-plugin (1.5-4) unstable; urgency=medium
* Team upload.
* Fixed the build failure with modello-maven-plugin 1.8
* Standards-Version updated to 3.9.6 (no changes)
* Switch to debhelper level 9
2014-05-26 - Miguel Landaeta <nomadium@debian.org>
maven-invoker-plugin (1.5-3) unstable; urgency=low
* Team upload.
* Update Maven settings to use correct coordinates for Groovy 1.8.x.
* Bump Standards-Versions to 3.9.5. No changes were required.
* Update copyright file to make it compliant with format 1.0.
* Use canonical URLs in Vcs-* fields.
2011-09-06 - Miguel Landaeta <miguel@miguel.cc>
maven-invoker-plugin (1.5-2) unstable; urgency=low
* Team upload.
* Add Build-Depends on libmaven-plugin-tools-java (>= 2.8) (Closes: #640751)
2011-08-14 - Miguel Landaeta <miguel@miguel.cc>
maven-invoker-plugin (1.5-1) unstable; urgency=low
* Team upload.
* New upstream release.
* Bump Standards-Versions to 3.9.2. No changes were required.
* Migrate to source format 3.0 (quilt).
* Make copyright file DEP-5 compliant.
* Add versioned Build-Depends on libmaven-invoker-java (>= 2.0.11~).
2009-08-14 - Ludovic Claude <ludovic.claude@laposte.net>
maven-invoker-plugin (1.3-2) unstable; urgency=low
* Fix FTBFS: add libjline-java to Build-Depends
2009-07-22 - Ludovic Claude <ludovic.claude@laposte.net>
maven-invoker-plugin (1.3-1) experimental; urgency=low
* Initial release (Closes: #540047)

See Also

Package Description
libmaven-jar-plugin-java_3.1.2-1_all.deb Maven Jar Plugin
libmaven-javadoc-plugin-java_3.0.1-3_all.deb Maven Javadoc Plugin
libmaven-jaxb2-plugin-java-doc_0.13.3-1_all.deb Documentation for Maven JAXB 2.x Plugin Project
libmaven-jaxb2-plugin-java_0.14.0-1_all.deb Maven JAXB 2.x Plugin Project
libmaven-mapping-java_3.0.0-1_all.deb Apache Maven Mapping
libmaven-parent-java_31-2_all.deb Maven metadata for Apache Maven itself
libmaven-plugin-testing-java-doc_2.1-1_all.deb Documentation for Maven Plugin Testing
libmaven-plugin-testing-java_3.3.0-1_all.deb Maven Plugin Testing
libmaven-plugin-tools-java_3.6.0-1_all.deb Maven Plugin Tools
libmaven-processor-plugin-java_3.3.3-1_all.deb Maven plugin to process annotations for Java 6 at compile time
libmaven-reporting-api-java_3.0-1_all.deb Maven Reporting API
libmaven-reporting-exec-java_1.4-2_all.deb Apache Maven Reporting Executor
libmaven-reporting-impl-java-doc_3.0.0-2_all.deb Documentation for Maven Reporting API Implementation
libmaven-reporting-impl-java_3.0.0-2_all.deb Maven Reporting API Implementation
libmaven-repository-builder-java-doc_1.0-3_all.deb Documentation for Maven Repository Builder
Advertisement
Advertisement