libmaven-doxia-tools-java_1.4-3_all.deb


Advertisement

Description

libmaven-doxia-tools-java - utilities for integrating Doxia in Maven

Distribution: Debian Sid
Repository: Debian Main i386
Package name: libmaven-doxia-tools-java
Package version: 1.4
Package release: 3
Package architecture: all
Package type: deb
Installed size: 73 B
Download size: 39.12 KB
Official Mirror: ftp.br.debian.org
Description: unavailable.

Alternatives

    Download

    Source package: maven-doxia-tools

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libmaven-doxia-tools-java deb package:
      # sudo apt-get install libmaven-doxia-tools-java

    Changelog

    2017-09-19 - Emmanuel Bourg <ebourg@apache.org> maven-doxia-tools (1.4-3) unstable; urgency=medium * Team upload. * Added the missing build dependency on junit

    2017-08-28 - Emmanuel Bourg <ebourg@apache.org> maven-doxia-tools (1.4-2) unstable; urgency=medium * Team upload. * Depend on libmaven-reporting-api-java instead of libmaven2-core-java * Standards-Version updated to 4.1.0

    2017-07-28 - Emmanuel Bourg <ebourg@apache.org> maven-doxia-tools (1.4-1) unstable; urgency=medium * Team upload. * New upstream release - Refreshed the patches - Updated the Maven rules * Depend on libplexus-container-default1.5-java instead of libplexus-container-default-java * Depend on libmaven3-core-java for the core Maven classes * Build with the DH sequencer instead of CDBS * Moved the package to Git * Standards-Version updated to 4.0.0 * Switch to debhelper level 10 * Use XZ compression for the upstream tarball

    2011-09-28 - Torsten Werner <twerner@debian.org> maven-doxia-tools (1.2.1-2) unstable; urgency=low * Ignore test errors and failures because some tests require network access. (Closes: #643545)

    2011-09-11 - Torsten Werner <twerner@debian.org> maven-doxia-tools (1.2.1-1) unstable; urgency=low * Newer but not newest upstream release. * Refresh patches. * Update Standards-Version: 3.9.2. * Use Maven to build the package. * Add a documentation package. * Update debian/copyright.

    2010-03-20 - Damien Raude-Morvan <drazzib@debian.org> maven-doxia-tools (1.2-3) unstable; urgency=low * Add myself as Uploaders * Replace usage of outdated libplexus-component-metadata-java by libplexus-maven-plugin-java (to generate Plexus component.xml): - debian/control: Build-Depends on libplexus-maven-plugin-java, velocity and libplexus-velocity-java - debian/rules: Pass "1.3.8" to build.xml as plexus-maven-plugin.version - debian/build.properties: Use plexus-maven-plugin:descriptor goal This should fix issue "Component descriptor cannot be found in the component repository: org.apache.maven.artifact.resolver.ArtifactResolver" when using maven-site-plugin.

    2010-03-10 - Torsten Werner <twerner@debian.org> maven-doxia-tools (1.2-2) unstable; urgency=low * Rebuild package with maven-repo-helper 1.0.4.

    2010-02-26 - Gabriele Giacone <1o5g4r8o@gmail.com> maven-doxia-tools (1.2-1) unstable; urgency=low * New upstream version * Standards-Version to 3.8.4 * debhelper compat to 7 * Source format 3.0 (quilt) - removed quilt as build dependency * Updated plexus patch * Added patch to remove setLastModified call

    2009-07-26 - Ludovic Claude <ludovic.claude@laposte.net> maven-doxia-tools (1.0.2-2) unstable; urgency=low * Fix groupId for maven-plugin-testing-harness dependency in the Maven POM.

    2009-05-15 - Ludovic Claude <ludovic.claude@laposte.net> maven-doxia-tools (1.0.2-1) experimental; urgency=low * New upstream version, add myself to Uploaders * Change section to java, bump up Standards-Version to 3.8.1 * Bump up debhelper to 6 * Add the Maven POM to the package, * Add a Build-Depends-Indep dependency on maven-repo-helper * Use mh_installpom and mh_installjar to install the POM and the jar to the Maven repository * Remove Depends on Java runtimes as it is a library * Use default-jdk for the build * Remove the patch for the POM as it's no longer needed, use ant for the build instead of Maven (to avoid circular build dependencies from maven-debian-helper) * Add a dependency on doxia-sitetools and maven2-core * Remove the dependency on doxia, as it is transitively reachable from doxia-sitetools

    Advertisement
    Advertisement