libguichan-allegro-0.8.1-1v5_0.8.2-18+b1_i386.deb


Advertisement

Description

libguichan-allegro-0.8.1-1v5 - small, efficient C++ GUI library (allegro integration)

Property Value
Distribution Debian Sid
Repository Debian Main i386
Package filename libguichan-allegro-0.8.1-1v5_0.8.2-18+b1_i386.deb
Package name libguichan-allegro-0.8.1-1v5
Package version 0.8.2
Package release 18+b1
Package architecture i386
Package type deb
Category libs role::shared-lib
Homepage http://guichan.sourceforge.net/
License -
Maintainer Patrick Matthäi <pmatthaei@debian.org>
Download size 28.42 KB
Installed size 82.00 KB

Alternatives

Package Version Architecture Repository
libguichan-allegro-0.8.1-1v5_0.8.2-18+b1_amd64.deb 0.8.2 amd64 Debian Main
libguichan-allegro-0.8.1-1v5 - - -

Requires

Name Value
libc6 >= 2.4
libgcc1 >= 1:3.0
libstdc++6 >= 5.2

Replaces

Name Value
libguichan-allegro-0.8.1-1 -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libguichan-allegro-0.8.1-1v5_0.8.2-18+b1_i386.deb
Source Package guichan

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libguichan-allegro-0.8.1-1v5 deb package:
    # sudo apt-get install libguichan-allegro-0.8.1-1v5

Files

Path
/usr/lib/i386-linux-gnu/libguichan_allegro-0.8.1.so.1
/usr/lib/i386-linux-gnu/libguichan_allegro-0.8.1.so.1.1.0
/usr/share/doc/libguichan-allegro-0.8.1-1v5/changelog.Debian.gz
/usr/share/doc/libguichan-allegro-0.8.1-1v5/changelog.Debian.i386.gz
/usr/share/doc/libguichan-allegro-0.8.1-1v5/changelog.gz
/usr/share/doc/libguichan-allegro-0.8.1-1v5/copyright
/usr/share/lintian/overrides/libguichan-allegro-0.8.1-1v5

Changelog

2017-08-02 - Patrick Matthäi <pmatthaei@debian.org>
guichan (0.8.2-18) unstable; urgency=medium
*  Drop now useless dh-autoreconf.
2017-07-21 - Patrick Matthäi <pmatthaei@debian.org>
guichan (0.8.2-17) unstable; urgency=medium
* Bump debian/compat to level 10.
* Bump Standards-Version to 4.0.0 (no changes required).
* Drop dbg package.
* Remove trigger files again.
2016-12-23 - Patrick Matthäi <pmatthaei@debian.org>
guichan (0.8.2-16) unstable; urgency=medium
* Bump Standards-Version to 3.9.8 (no changes required).
* Remove obsolete URL from debian/watch. The project is inactive.
* Enable full hardening.
* Add patch 04-spelling-errors to fix spelling errors.
* Use debhelper triggers.
2015-08-04 - Patrick Matthäi <pmatthaei@debian.org>
guichan (0.8.2-15) unstable; urgency=medium
* Add patch 02-extended-utf8-support to enhance UTF8 support.
Closes: #702994
* Append/Bump library names with v5 for the GCC 5 transition.
Closes: #791064
* Add patch 03-no-focushandler to fix a potential crash if no focushandler
is set.
* Remove unused override.
2015-07-29 - Patrick Matthäi <pmatthaei@debian.org>
guichan (0.8.2-14) unstable; urgency=medium
* Bump Standards-Version to 3.9.6 (no changes needed).
* Remove deprecated hardening-wrapper.
* Overwrite lintian warning about missing GPG signature.
* Enable multi arch for all library packages.
* Update to DEP5 debian/copyright format.
* Adjust lintian overrides.
* Fix lintian warning static-library-has-unneeded-section.
2013-12-12 - Patrick Matthäi <pmatthaei@debian.org>
guichan (0.8.2-13) unstable; urgency=low
* Replace my old e-mail address in debian/copyright.
* Bump Standards-Version to 3.9.5 (no changes needed).
* Don't explicitly request xz compression - dpkg 1.17 does this by default.
* Remove unused hardening-no-fortify-functions lintian override.
2013-05-05 - Patrick Matthäi <pmatthaei@debian.org>
guichan (0.8.2-12) unstable; urgency=low
* Uploading to unstable.
2013-01-14 - Patrick Matthäi <pmatthaei@debian.org>
guichan (0.8.2-11) experimental; urgency=low
* Bump Standards-Version to 3.9.4 (no changes needed).
* Switch to xz compression and add a Pre-Depends on dpkg.
* Move to minimal debhelper.
- Adjust lintian overrides.
* Use dh-autoreconf.
* Overwrite false positive dev-pkg-without-shlib-symlink lintian warnings.
2012-06-05 - Patrick Matthäi <pmatthaei@debian.org>
guichan (0.8.2-10) unstable; urgency=low
* Add patch 01-sdl-dependent-link from Stephen M. Webb, which adds SDL to
avoid runtime errors of applications build against guichan.
Closes: #674219
* Overwrite false positive hardening-no-fortify-functions lintian warnings.
2012-03-10 - Patrick Matthäi <pmatthaei@debian.org>
guichan (0.8.2-9) unstable; urgency=low
* Fix again debian/watch.
* Wrap all debian/control fields.

See Also

Package Description
libguichan-dev_0.8.2-18+b1_i386.deb small, efficient C++ GUI library (development headers)
libguichan-opengl-0.8.1-1v5_0.8.2-18+b1_i386.deb small, efficient C++ GUI library (OpenGL integration)
libguichan-sdl-0.8.1-1v5_0.8.2-18+b1_i386.deb small, efficient C++ GUI library (SDL integration)
libguile-ssh11_0.11.3-2_i386.deb guile bindings for libssl
libgulkan-0.12-0_0.12.1-1_i386.deb GLib Vulkan helper library
libgulkan-dev_0.12.1-1_i386.deb GLib Vulkan helper library -- development files
libgulkan-doc_0.12.1-1_all.deb GLib Vulkan helper library -- documentation files
libgumbo-dev_0.10.1+dfsg-2.3+b1_i386.deb pure-C HTML5 parser development files
libgumbo1_0.10.1+dfsg-2.3+b1_i386.deb pure-C HTML5 parser
libgupnp-1.0-4_1.0.3-3_i386.deb GObject-based library for UPnP
libgupnp-1.0-dev_1.0.3-3_i386.deb GObject-based library for UPnP (development files)
libgupnp-av-1.0-2_0.12.11-2_i386.deb Audio/Visual utility library for GUPnP
libgupnp-av-1.0-dev_0.12.11-2_i386.deb Audio/Visual utility library for GUPnP (development files)
libgupnp-av-doc_0.12.11-2_all.deb Audio/Visual utility library for GUPnP (documentation)
libgupnp-dlna-2.0-3_0.10.5-4_i386.deb DLNA utility library for GUPnP
Advertisement
Advertisement