libgpm-dev_1.20.7-5+b1_i386.deb


Advertisement

Description

libgpm-dev - General Purpose Mouse - development files

Property Value
Distribution Debian Sid
Repository Debian Main i386
Package filename libgpm-dev_1.20.7-5+b1_i386.deb
Package name libgpm-dev
Package version 1.20.7
Package release 5+b1
Package architecture i386
Package type deb
Category devel::lang:c devel::library hardware::input hardware::input:mouse implemented-in::c libdevel role::devel-lib
Homepage https://nico.schottelius.org/software/gpm/
License -
Maintainer Axel Beckert <abe@debian.org>
Download size 38.30 KB
Installed size 79.00 KB

Alternatives

Package Version Architecture Repository
libgpm-dev_1.20.7-5+b1_amd64.deb 1.20.7 amd64 Debian Main
libgpm-dev - - -

Requires

Name Value
libc-dev -
libc6-dev -
libgpm2 = 1.20.7-5+b1

Provides

Name Value
libgpmg1-dev -

Conflicts

Name Value
libgpmg1-dev -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libgpm-dev_1.20.7-5+b1_i386.deb
Source Package gpm

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libgpm-dev deb package:
    # sudo apt-get install libgpm-dev

Files

Path
/usr/include/gpm.h
/usr/lib/i386-linux-gnu/libgpm.a
/usr/lib/i386-linux-gnu/libgpm.so
/usr/share/doc/libgpm-dev/changelog.Debian.gz
/usr/share/doc/libgpm-dev/changelog.Debian.i386.gz
/usr/share/doc/libgpm-dev/changelog.gz
/usr/share/doc/libgpm-dev/copyright

Changelog

2018-01-30 - Axel Beckert <abe@debian.org>
gpm (1.20.7-5) unstable; urgency=medium
* Update Vcs-* headers for switch to salsa.debian.org.
* Fix syslog format string in
092_fix-format-not-a-string-literal-and-no-format-arguments.patch.
Thanks William Blough and Samuel Thibault! (Closes: #888792, #888797)
2018-01-11 - Axel Beckert <abe@debian.org>
gpm (1.20.7-4) unstable; urgency=low
* Upload to unstable again to fix #886903 also in unstable.
+ Mention #886903 in debian/patches/94_gpm-1.20.7-glibc-2.26-1.patch
and the 1.20.7-2 debian/changelog entry.
+ Set urgency=low.
* Add lintian-override for too-long-extended-description-in-templates:
The list of possible device types cannot be shortened without loosing
essential information for the administrator.
* Switch watch file and Homepage to HTTPS and drop "www.".
* debian/clean: Add all files reported by "git clean -dxf" (even after
having run "debclean"), partially by using wildcards. Makes package
building twice in a row again.
* Drop "Priority: standard" for libgpm2: It's no more required that all
dependencies of a package only have the same or higher priority.
* Declare compliance with Debian Policy 4.1.3. (No changes needed.)
* Bump debhelper compatibility to 11.
+ Update versioned build-dependency on debhelper accordingly.
2017-09-21 - Axel Beckert <abe@debian.org>
gpm (1.20.7-3) experimental; urgency=low
* Convert debian/copyright to machine-readable DEP5 format.
+ Update copyright years.
+ Add missing copyright holders.
+ Add missing GPL-3.0+ for two files under scripts/.
* Remove Makefile in debian/rules before dh_auto_clean is called.
* Install README.versions as documentation.
* Add contrib/emacs/t-mouse.elc to debian/clean.
* Restrict architecture to linux-any for now. (Closes: #745168)
* Add man page for gpm-microtouch-setup(8) by Fran├žois Wendling. Thanks!
(Closes: #496868)
2017-09-20 - Axel Beckert <abe@debian.org>
gpm (1.20.7-2) experimental; urgency=low
[ Axel Beckert ]
* Pre-emptively add patch from NuTyX/LFS to fix FTBFS with glibc 2.26.
(Closes: #886903)
* Retroactively mention #490657 in previous changelog entry.
* debian/clean: Add Makefile and src/.depend to be able to build twice
in a row.
[ Samuel Thibault ]
* Bump Standards-Versions to 4.1.0 (no changes).
[ Andreas Henriksson ]
* Re-add Gpm_Wgetch symbol and fix 050_dont_link_libcurses patch.
(Closes: #873568)

See Also

Package Description
libgpm2_1.20.7-5+b1_i386.deb General Purpose Mouse - shared library
libgpod-cil-dev_0.8.3-15_i386.deb CLI bindings for libgpod -- development files
libgpod-cil_0.8.3-15_i386.deb CLI bindings for libgpod
libgpod-common_0.8.3-15_i386.deb common files for libgpod
libgpod-dev_0.8.3-15_i386.deb development files for libgpod
libgpod-doc_0.8.3-15_all.deb documentation for libgpod
libgpod4_0.8.3-15_i386.deb library to read and write songs and artwork to an iPod
libgportugol-dev_1.1-5+b1_i386.deb Development files for the G-Portugol library
libgportugol0_1.1-5+b1_i386.deb G-Portugol library
libgpr18_2018-6_i386.deb support for programs processing GNAT projects (runtime)
libgpr2-dev_2018-6_i386.deb support for programs processing GNAT projects (development)
libgps-dev_3.19-2_i386.deb Global Positioning System - development files
libgps-point-perl_0.20-2_all.deb module providing an object interface for a GPS point
libgps23_3.17-7_i386.deb Global Positioning System - library
libgps25_3.19-2_i386.deb Global Positioning System - library
Advertisement
Advertisement