libghc-th-expand-syns-dev_0.4.4.0-4_i386.deb


Advertisement

Description

libghc-th-expand-syns-dev - expands type synonyms in Template Haskell ASTs

Property Value
Distribution Debian Sid
Repository Debian Main i386
Package filename libghc-th-expand-syns-dev_0.4.4.0-4_i386.deb
Package name libghc-th-expand-syns-dev
Package version 0.4.4.0
Package release 4
Package architecture i386
Package type deb
Category haskell
Homepage https://github.com/DanielSchuessler/th-expand-syns
License -
Maintainer Debian Haskell Group <pkg-haskell-maintainers@lists.alioth.debian.org>
Download size 46.38 KB
Installed size 264.00 KB

Alternatives

Package Version Architecture Repository
libghc-th-expand-syns-dev_0.4.4.0-4_amd64.deb 0.4.4.0 amd64 Debian Main
libghc-th-expand-syns-dev - - -

Requires

Name Value
libatomic1 >= 4.8
libc6 >= 2.1.3
libghc-base-dev-4.12.0.0-701e2 -
libghc-containers-dev-0.6.0.1-77e77 -
libghc-syb-dev-0.7.1-17adb -
libghc-template-haskell-dev-2.14.0.0-505e5 -
libgmp10 -

Provides

Name Value
libghc-th-expand-syns-dev-0.4.4.0-531fe -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libghc-th-expand-syns-dev_0.4.4.0-4_i386.deb
Source Package haskell-th-expand-syns

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libghc-th-expand-syns-dev deb package:
    # sudo apt-get install libghc-th-expand-syns-dev

Files

Path
/usr/lib/haskell-packages/ghc/lib/i386-linux-ghc-8.6.5/libHSth-expand-syns-0.4.4.0-ACeG5Fd2nA9J5jHwfmyY63-ghc8.6.5.so
/usr/lib/haskell-packages/ghc/lib/i386-linux-ghc-8.6.5/th-expand-syns-0.4.4.0-ACeG5Fd2nA9J5jHwfmyY63/libHSth-expand-syns-0.4.4.0-ACeG5Fd2nA9J5jHwfmyY63.a
/usr/lib/haskell-packages/ghc/lib/i386-linux-ghc-8.6.5/th-expand-syns-0.4.4.0-ACeG5Fd2nA9J5jHwfmyY63/Language/Haskell/TH/ExpandSyns.dyn_hi
/usr/lib/haskell-packages/ghc/lib/i386-linux-ghc-8.6.5/th-expand-syns-0.4.4.0-ACeG5Fd2nA9J5jHwfmyY63/Language/Haskell/TH/ExpandSyns.hi
/usr/lib/haskell-packages/ghc/lib/i386-linux-ghc-8.6.5/th-expand-syns-0.4.4.0-ACeG5Fd2nA9J5jHwfmyY63/Language/Haskell/TH/ExpandSyns/SemigroupCompat.dyn_hi
/usr/lib/haskell-packages/ghc/lib/i386-linux-ghc-8.6.5/th-expand-syns-0.4.4.0-ACeG5Fd2nA9J5jHwfmyY63/Language/Haskell/TH/ExpandSyns/SemigroupCompat.hi
/usr/share/doc/libghc-th-expand-syns-dev/buildinfo_i386.gz
/usr/share/doc/libghc-th-expand-syns-dev/changelog.Debian.gz
/usr/share/doc/libghc-th-expand-syns-dev/copyright
/usr/share/lintian/overrides/libghc-th-expand-syns-dev
/var/lib/ghc/package.conf.d/th-expand-syns-0.4.4.0.conf

Changelog

2019-08-23 - Gianfranco Costamagna <locutusofborg@debian.org>
haskell-th-expand-syns (0.4.4.0-4) unstable; urgency=medium
* Patch for newer deps
2018-09-30 - Ilias Tsitsimpis <iliastsi@debian.org>
haskell-th-expand-syns (0.4.4.0-3) unstable; urgency=medium
[ Clint Adams ]
* Set Rules-Requires-Root to no.
[ Ilias Tsitsimpis ]
* Bump debhelper compat level to 10
2018-04-09 - Clint Adams <clint@debian.org>
haskell-th-expand-syns (0.4.4.0-2) unstable; urgency=medium
[ Ilias Tsitsimpis ]
* Use salsa.debian.org URLs in Vcs-{Browser,Git} fields
[ Clint Adams ]
* Bump to Standards-Version 4.1.4.
2018-01-07 - Clint Adams <clint@debian.org>
haskell-th-expand-syns (0.4.4.0-1) unstable; urgency=medium
[ Ilias Tsitsimpis ]
* Change Priority to optional. Since Debian Policy version 4.0.1,
priority extra has been deprecated.
* Use the HTTPS form of the copyright-format URL
* Modify d/watch and Source field in d/copyright to use HTTPS
* Declare compliance with Debian policy 4.1.1
[ Clint Adams ]
* New upstream release
2017-06-18 - Clint Adams <clint@debian.org>
haskell-th-expand-syns (0.4.3.0-1) unstable; urgency=medium
* New upstream release
2016-10-27 - Clint Adams <clint@debian.org>
haskell-th-expand-syns (0.4.0.0-3) unstable; urgency=medium
* Upload to unstable as part of GHC 8 transition.
2016-10-15 - Clint Adams <clint@debian.org>
haskell-th-expand-syns (0.4.0.0-2) experimental; urgency=medium
* Temporarily build-depend on ghc 8.
2016-05-30 - Joachim Breitner <nomeata@debian.org>
haskell-th-expand-syns (0.4.0.0-1) unstable; urgency=medium
[ Dmitry Bogatov ]
* Use secure (https) uri in Vcs-Git field in 'debian/control'
* Bump standards version to 3.9.8 (no changes needed)
[ Joachim Breitner ]
* New upstream release
2015-12-03 - Clint Adams <clint@debian.org>
haskell-th-expand-syns (0.3.0.6-4) unstable; urgency=medium
* Switch Vcs-Git/Vcs-Browser headers to new location.
2015-08-20 - Joachim Breitner <nomeata@debian.org>
haskell-th-expand-syns (0.3.0.6-3) experimental; urgency=medium
* Depend on haskell-devscripts >= 0.10 to ensure that this package
builds against GHC in experimental

See Also

Package Description
libghc-th-expand-syns-doc_0.4.4.0-4_all.deb expands type synonyms in Template Haskell ASTs; documentation
libghc-th-expand-syns-prof_0.4.4.0-4_i386.deb expands type synonyms in Template Haskell ASTs; profiling libraries
libghc-th-extras-dev_0.0.0.4-5+b3_i386.deb grab bag of functions for use with Template Haskell
libghc-th-extras-doc_0.0.0.4-5_all.deb grab bag of functions for use with Template Haskell; documentation
libghc-th-extras-prof_0.0.0.4-5+b3_i386.deb grab bag of functions for use with Template Haskell; profiling libraries
libghc-th-lift-dev_0.7.11-1+b3_i386.deb derive Template Haskell's Lift class for datatypes
libghc-th-lift-doc_0.7.11-1_all.deb derive Template Haskell's Lift class for datatypes.; documentation
libghc-th-lift-instances-dev_0.1.12-1_i386.deb Lift instances for template-haskell for common data types
libghc-th-lift-instances-doc_0.1.12-1_all.deb Lift instances for template-haskell for common data types; documentation
libghc-th-lift-instances-prof_0.1.12-1_i386.deb Lift instances for template-haskell for common data types; profiling libraries
libghc-th-lift-prof_0.7.11-1+b3_i386.deb derive Template Haskell's Lift class for datatypes.; profiling libraries
libghc-th-orphans-dev_0.13.7-1_i386.deb orphan instances for TH datatypes
libghc-th-orphans-doc_0.13.7-1_all.deb orphan instances for TH datatypes; documentation
libghc-th-orphans-prof_0.13.7-1_i386.deb orphan instances for TH datatypes; profiling libraries
libghc-th-reify-compat-dev_0.0.1.5-1+b3_i386.deb compatibility for the result type of TH reify
Advertisement
Advertisement