libghc-postgresql-libpq-dev_0.9.4.2-1_i386.deb


Advertisement

Description

libghc-postgresql-libpq-dev - low-level binding to libpq

Property Value
Distribution Debian Sid
Repository Debian Main i386
Package filename libghc-postgresql-libpq-dev_0.9.4.2-1_i386.deb
Package name libghc-postgresql-libpq-dev
Package version 0.9.4.2
Package release 1
Package architecture i386
Package type deb
Category haskell
Homepage https://github.com/phadej/postgresql-libpq
License -
Maintainer Debian Haskell Group <pkg-haskell-maintainers@lists.alioth.debian.org>
Download size 175.36 KB
Installed size 1.61 MB

Alternatives

Package Version Architecture Repository
libghc-postgresql-libpq-dev_0.9.4.2-1_amd64.deb 0.9.4.2 amd64 Debian Main
libghc-postgresql-libpq-dev - - -

Requires

Name Value
libatomic1 >= 4.8
libc6 >= 2.3.6-6~
libghc-base-dev-4.12.0.0-701e2 -
libghc-bytestring-dev-0.10.8.2-ab20c -
libghc-unix-dev-2.7.2.2-58a43 -
libgmp10 -
libpq-dev -
libpq5 >= 9.2~beta3

Provides

Name Value
libghc-postgresql-libpq-dev-0.9.4.2-fdc2f -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libghc-postgresql-libpq-dev_0.9.4.2-1_i386.deb
Source Package haskell-postgresql-libpq

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libghc-postgresql-libpq-dev deb package:
    # sudo apt-get install libghc-postgresql-libpq-dev

Files

Path
/usr/lib/haskell-packages/ghc/lib/i386-linux-ghc-8.6.5/libHSpostgresql-libpq-0.9.4.2-ESFRzPMlpoIJlnfIQXdn9C-ghc8.6.5.so
/usr/lib/haskell-packages/ghc/lib/i386-linux-ghc-8.6.5/postgresql-libpq-0.9.4.2-ESFRzPMlpoIJlnfIQXdn9C/libHSpostgresql-libpq-0.9.4.2-ESFRzPMlpoIJlnfIQXdn9C.a
/usr/lib/haskell-packages/ghc/lib/i386-linux-ghc-8.6.5/postgresql-libpq-0.9.4.2-ESFRzPMlpoIJlnfIQXdn9C/Database/PostgreSQL/LibPQ.dyn_hi
/usr/lib/haskell-packages/ghc/lib/i386-linux-ghc-8.6.5/postgresql-libpq-0.9.4.2-ESFRzPMlpoIJlnfIQXdn9C/Database/PostgreSQL/LibPQ.hi
/usr/lib/haskell-packages/ghc/lib/i386-linux-ghc-8.6.5/postgresql-libpq-0.9.4.2-ESFRzPMlpoIJlnfIQXdn9C/Database/PostgreSQL/LibPQ/Internal.dyn_hi
/usr/lib/haskell-packages/ghc/lib/i386-linux-ghc-8.6.5/postgresql-libpq-0.9.4.2-ESFRzPMlpoIJlnfIQXdn9C/Database/PostgreSQL/LibPQ/Internal.hi
/usr/share/doc/libghc-postgresql-libpq-dev/buildinfo_i386.gz
/usr/share/doc/libghc-postgresql-libpq-dev/changelog.Debian.gz
/usr/share/doc/libghc-postgresql-libpq-dev/changelog.gz
/usr/share/doc/libghc-postgresql-libpq-dev/copyright
/usr/share/lintian/overrides/libghc-postgresql-libpq-dev
/var/lib/ghc/package.conf.d/postgresql-libpq-0.9.4.2.conf

Changelog

2019-07-28 - Clint Adams <clint@debian.org>
haskell-postgresql-libpq (0.9.4.2-1) unstable; urgency=medium
* New upstream release
2018-09-30 - Ilias Tsitsimpis <iliastsi@debian.org>
haskell-postgresql-libpq (0.9.4.1-2) unstable; urgency=medium
[ Clint Adams ]
* Set Rules-Requires-Root to no.
[ Ilias Tsitsimpis ]
* Bump debhelper compat level to 10
2018-04-09 - Clint Adams <clint@debian.org>
haskell-postgresql-libpq (0.9.4.1-1) unstable; urgency=medium
[ Ilias Tsitsimpis ]
* Change Priority to optional. Since Debian Policy version 4.0.1,
priority extra has been deprecated.
* Use the HTTPS form of the copyright-format URL
* Modify d/watch and Source field in d/copyright to use HTTPS
* Declare compliance with Debian policy 4.1.1
* Use salsa.debian.org URLs in Vcs-{Browser,Git} fields
[ Clint Adams ]
* Bump to Standards-Version 4.1.4.
* New upstream release
2017-06-17 - Clint Adams <clint@debian.org>
haskell-postgresql-libpq (0.9.3.1-1) unstable; urgency=medium
* New upstream release
2016-10-27 - Clint Adams <clint@debian.org>
haskell-postgresql-libpq (0.9.2.0-3) unstable; urgency=medium
* Upload to unstable as part of GHC 8 transition.
2016-10-14 - Clint Adams <clint@debian.org>
haskell-postgresql-libpq (0.9.2.0-2) experimental; urgency=medium
* Temporarily build-depend on ghc 8.
2016-08-28 - Clint Adams <clint@debian.org>
haskell-postgresql-libpq (0.9.2.0-1) unstable; urgency=medium
[ Dmitry Bogatov ]
* Use secure (https) uri in Vcs-Git field in 'debian/control'
* Bump standards version to 3.9.8 (no changes needed)
* Convert `debian/copyright' to dep5 format
[ Clint Adams ]
* New upstream release
2015-12-03 - Clint Adams <clint@debian.org>
haskell-postgresql-libpq (0.9.1.1-3) unstable; urgency=medium
* Switch Vcs-Git/Vcs-Browser headers to new location.
2015-08-20 - Joachim Breitner <nomeata@debian.org>
haskell-postgresql-libpq (0.9.1.1-2) experimental; urgency=medium
* Bump standards-version to 3.9.6
* Depend on haskell-devscripts >= 0.10 to ensure that this package
builds against GHC in experimental
2015-08-12 - Joachim Breitner <nomeata@debian.org>
haskell-postgresql-libpq (0.9.1.1-1) unstable; urgency=medium
* New upstream release

See Also

Package Description
libghc-postgresql-libpq-doc_0.9.4.2-1_all.deb low-level binding to libpq; documentation
libghc-postgresql-libpq-prof_0.9.4.2-1_i386.deb low-level binding to libpq; profiling libraries
libghc-postgresql-simple-dev_0.6.2-1+b1_i386.deb mid-level PostgreSQL client library
libghc-postgresql-simple-doc_0.6.2-1_all.deb mid-level PostgreSQL client library; documentation
libghc-postgresql-simple-prof_0.6.2-1+b1_i386.deb mid-level PostgreSQL client library; profiling libraries
libghc-pqueue-dev_1.4.1.2-1_i386.deb reliable, persistent, fast priority queues
libghc-pqueue-doc_1.4.1.2-1_all.deb reliable, persistent, fast priority queues.; documentation
libghc-pqueue-prof_1.4.1.2-1_i386.deb reliable, persistent, fast priority queues.; profiling libraries
libghc-prelude-extras-dev_0.4.0.3-5+b3_i386.deb higher-order versions of Prelude classes
libghc-prelude-extras-doc_0.4.0.3-5_all.deb higher-order versions of Prelude classes; documentation
libghc-prelude-extras-prof_0.4.0.3-5+b3_i386.deb higher-order versions of Prelude classes; profiling libraries
libghc-presburger-dev_1.3.1-7_i386.deb decision procedure for quantifier-free linear arithmetic
libghc-presburger-doc_1.3.1-7_all.deb decision procedure for quantifier-free linear arithmetic; documentation
libghc-presburger-prof_1.3.1-7_i386.deb decision procedure for quantifier-free linear arithmetic; profiling libraries
libghc-pretty-show-dev_1.9.5-1_i386.deb A Haskell library for pretty printing data structures
Advertisement
Advertisement