libghc-exception-transformers-dev_0.4.0.7-4_i386.deb


Advertisement

Description

libghc-exception-transformers-dev - type classes and monads for unchecked extensible exceptions

Property Value
Distribution Debian Sid
Repository Debian Main i386
Package filename libghc-exception-transformers-dev_0.4.0.7-4_i386.deb
Package name libghc-exception-transformers-dev
Package version 0.4.0.7
Package release 4
Package architecture i386
Package type deb
Category haskell
Homepage http://hackage.haskell.org/package/exception-transformers
License -
Maintainer Debian Haskell Group <pkg-haskell-maintainers@lists.alioth.debian.org>
Download size 63.47 KB
Installed size 649.00 KB

Alternatives

Package Version Architecture Repository
libghc-exception-transformers-dev_0.4.0.7-4_amd64.deb 0.4.0.7 amd64 Debian Main
libghc-exception-transformers-dev - - -

Requires

Name Value
libatomic1 >= 4.8
libc6 >= 2.1.3
libghc-base-dev-4.12.0.0-701e2 -
libghc-stm-dev-2.5.0.0-d9be2 -
libghc-transformers-compat-dev-0.6.5-efb98 -
libghc-transformers-dev-0.5.6.2-df3b4 -
libgmp10 -

Provides

Name Value
libghc-exception-transformers-dev-0.4.0.7-fd351 -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libghc-exception-transformers-dev_0.4.0.7-4_i386.deb
Source Package haskell-exception-transformers

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libghc-exception-transformers-dev deb package:
    # sudo apt-get install libghc-exception-transformers-dev

Files

Path
/usr/lib/haskell-packages/ghc/lib/i386-linux-ghc-8.6.5/libHSexception-transformers-0.4.0.7-9m8vTdIofDZ8QKSvR63BcT-ghc8.6.5.so
/usr/lib/haskell-packages/ghc/lib/i386-linux-ghc-8.6.5/exception-transformers-0.4.0.7-9m8vTdIofDZ8QKSvR63BcT/libHSexception-transformers-0.4.0.7-9m8vTdIofDZ8QKSvR63BcT.a
/usr/lib/haskell-packages/ghc/lib/i386-linux-ghc-8.6.5/exception-transformers-0.4.0.7-9m8vTdIofDZ8QKSvR63BcT/Control/Monad/Exception.dyn_hi
/usr/lib/haskell-packages/ghc/lib/i386-linux-ghc-8.6.5/exception-transformers-0.4.0.7-9m8vTdIofDZ8QKSvR63BcT/Control/Monad/Exception.hi
/usr/share/doc/libghc-exception-transformers-dev/buildinfo_i386.gz
/usr/share/doc/libghc-exception-transformers-dev/changelog.Debian.gz
/usr/share/doc/libghc-exception-transformers-dev/copyright
/usr/share/lintian/overrides/libghc-exception-transformers-dev
/var/lib/ghc/package.conf.d/exception-transformers-0.4.0.7.conf

Changelog

2019-08-25 - Gianfranco Costamagna <locutusofborg@debian.org>
haskell-exception-transformers (0.4.0.7-4) unstable; urgency=medium
* Bump dependencies versions
2018-10-01 - Ilias Tsitsimpis <iliastsi@debian.org>
haskell-exception-transformers (0.4.0.7-3) unstable; urgency=medium
* Remove build dependency on libghc-stm-dev (provided by ghc-8.4.3)
2018-09-30 - Ilias Tsitsimpis <iliastsi@debian.org>
haskell-exception-transformers (0.4.0.7-2) unstable; urgency=medium
* Bump debhelper compat level to 10
2018-06-10 - Clint Adams <clint@debian.org>
haskell-exception-transformers (0.4.0.7-1) unstable; urgency=medium
* Set Rules-Requires-Root to no.
* New upstream release
2018-04-09 - Clint Adams <clint@debian.org>
haskell-exception-transformers (0.4.0.6-1) unstable; urgency=medium
[ Ilias Tsitsimpis ]
* Change Priority to optional. Since Debian Policy version 4.0.1,
priority extra has been deprecated.
* Use the HTTPS form of the copyright-format URL
* Modify d/watch and Source field in d/copyright to use HTTPS
* Declare compliance with Debian policy 4.1.1
* Use salsa.debian.org URLs in Vcs-{Browser,Git} fields
[ Clint Adams ]
* Bump to Standards-Version 4.1.4.
* New upstream release
2017-07-09 - Clint Adams <clint@debian.org>
haskell-exception-transformers (0.4.0.5-2) unstable; urgency=medium
* Fix Build-Depends.  closes: #867833.
2017-06-17 - Clint Adams <clint@debian.org>
haskell-exception-transformers (0.4.0.5-1) unstable; urgency=medium
* New upstream release
2016-10-27 - Clint Adams <clint@debian.org>
haskell-exception-transformers (0.4.0.4-3) unstable; urgency=medium
* Upload to unstable as part of GHC 8 transition.
2016-10-16 - Clint Adams <clint@debian.org>
haskell-exception-transformers (0.4.0.4-2) experimental; urgency=medium
* Temporarily build-depend on ghc 8.
2016-05-29 - Joachim Breitner <nomeata@debian.org>
haskell-exception-transformers (0.4.0.4-1) unstable; urgency=medium
[ Dmitry Bogatov ]
* Use secure (https) uri in Vcs-Git field in 'debian/control'
* Bump standards version to 3.9.8 (no changes needed)
* Convert `debian/copyright' to dep5 format
[ Joachim Breitner ]
* New upstream release

See Also

Package Description
libghc-exception-transformers-doc_0.4.0.7-4_all.deb type classes and monads for unchecked extensible exceptions; documentation
libghc-exception-transformers-prof_0.4.0.7-4_i386.deb type classes and monads for unchecked extensible exceptions; profiling libs
libghc-exceptions-dev_0.10.2-1_i386.deb extensible optionally-pure exceptions
libghc-exceptions-doc_0.10.2-1_all.deb extensible optionally-pure exceptions; documentation
libghc-exceptions-prof_0.10.2-1_i386.deb extensible optionally-pure exceptions; profiling libraries
libghc-executable-path-dev_0.0.3.1-3+b3_i386.deb determine full path of executable
libghc-executable-path-doc_0.0.3.1-3_all.deb determine full path of executable; documentation
libghc-executable-path-prof_0.0.3.1-3+b3_i386.deb determine full path of executable; profiling libraries
libghc-expiring-cache-map-dev_0.0.6.1-5+b3_i386.deb general-purpose simple caching
libghc-expiring-cache-map-doc_0.0.6.1-5_all.deb general-purpose simple caching; documentation
libghc-expiring-cache-map-prof_0.0.6.1-5+b3_i386.deb general-purpose simple caching; profiling libraries
libghc-extensible-exceptions-dev_0.1.1.4-10+b3_i386.deb Compatibility layer for exceptions
libghc-extensible-exceptions-doc_0.1.1.4-10_all.deb Compatibility layer for exceptions; documentation
libghc-extensible-exceptions-prof_0.1.1.4-10+b3_i386.deb Compatibility layer for exceptions; profiling libraries
libghc-extra-dev_1.6.17-1_i386.deb extra functions for base library
Advertisement
Advertisement