libghc-cipher-des-dev_0.0.6-9+b3_i386.deb


Advertisement

Description

libghc-cipher-des-dev - DES and 3DES ciphers

Property Value
Distribution Debian Sid
Repository Debian Main i386
Package filename libghc-cipher-des-dev_0.0.6-9+b3_i386.deb
Package name libghc-cipher-des-dev
Package version 0.0.6
Package release 9+b3
Package architecture i386
Package type deb
Category haskell
Homepage http://github.com/vincenthz/hs-crypto-cipher
License -
Maintainer Debian Haskell Group <pkg-haskell-maintainers@lists.alioth.debian.org>
Download size 83.71 KB
Installed size 729.00 KB

Alternatives

Package Version Architecture Repository
libghc-cipher-des-dev_0.0.6-9+b3_amd64.deb 0.0.6 amd64 Debian Main
libghc-cipher-des-dev - - -

Requires

Name Value
libatomic1 >= 4.8
libc6 >= 2.1.3
libghc-base-dev-4.12.0.0-701e2 -
libghc-byteable-dev-0.1.1-89eff -
libghc-bytestring-dev-0.10.8.2-ab20c -
libghc-crypto-cipher-types-dev-0.0.9-16006 -
libghc-securemem-dev-0.1.10-987d2 -
libgmp10 -

Provides

Name Value
libghc-cipher-des-dev-0.0.6-c092e -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libghc-cipher-des-dev_0.0.6-9+b3_i386.deb
Source Package haskell-cipher-des

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libghc-cipher-des-dev deb package:
    # sudo apt-get install libghc-cipher-des-dev

Files

Path
/usr/lib/haskell-packages/ghc/lib/i386-linux-ghc-8.6.5/libHScipher-des-0.0.6-DTF77naIdLn7IVeeQLYsQ-ghc8.6.5.so
/usr/lib/haskell-packages/ghc/lib/i386-linux-ghc-8.6.5/cipher-des-0.0.6-DTF77naIdLn7IVeeQLYsQ/libHScipher-des-0.0.6-DTF77naIdLn7IVeeQLYsQ.a
/usr/lib/haskell-packages/ghc/lib/i386-linux-ghc-8.6.5/cipher-des-0.0.6-DTF77naIdLn7IVeeQLYsQ/Crypto/Cipher/DES.dyn_hi
/usr/lib/haskell-packages/ghc/lib/i386-linux-ghc-8.6.5/cipher-des-0.0.6-DTF77naIdLn7IVeeQLYsQ/Crypto/Cipher/DES.hi
/usr/lib/haskell-packages/ghc/lib/i386-linux-ghc-8.6.5/cipher-des-0.0.6-DTF77naIdLn7IVeeQLYsQ/Crypto/Cipher/TripleDES.dyn_hi
/usr/lib/haskell-packages/ghc/lib/i386-linux-ghc-8.6.5/cipher-des-0.0.6-DTF77naIdLn7IVeeQLYsQ/Crypto/Cipher/TripleDES.hi
/usr/lib/haskell-packages/ghc/lib/i386-linux-ghc-8.6.5/cipher-des-0.0.6-DTF77naIdLn7IVeeQLYsQ/Crypto/Cipher/DES/Primitive.dyn_hi
/usr/lib/haskell-packages/ghc/lib/i386-linux-ghc-8.6.5/cipher-des-0.0.6-DTF77naIdLn7IVeeQLYsQ/Crypto/Cipher/DES/Primitive.hi
/usr/lib/haskell-packages/ghc/lib/i386-linux-ghc-8.6.5/cipher-des-0.0.6-DTF77naIdLn7IVeeQLYsQ/Crypto/Cipher/DES/Serialization.dyn_hi
/usr/lib/haskell-packages/ghc/lib/i386-linux-ghc-8.6.5/cipher-des-0.0.6-DTF77naIdLn7IVeeQLYsQ/Crypto/Cipher/DES/Serialization.hi
/usr/share/doc/libghc-cipher-des-dev/buildinfo_i386.gz
/usr/share/doc/libghc-cipher-des-dev/changelog.Debian.gz
/usr/share/doc/libghc-cipher-des-dev/changelog.Debian.i386.gz
/usr/share/doc/libghc-cipher-des-dev/copyright
/usr/share/lintian/overrides/libghc-cipher-des-dev
/var/lib/ghc/package.conf.d/cipher-des-0.0.6.conf

Changelog

2018-09-30 - Ilias Tsitsimpis <iliastsi@debian.org>
haskell-cipher-des (0.0.6-9) unstable; urgency=medium
[ Clint Adams ]
* Set Rules-Requires-Root to no.
[ Ilias Tsitsimpis ]
* Bump debhelper compat level to 10
2018-04-09 - Clint Adams <clint@debian.org>
haskell-cipher-des (0.0.6-8) unstable; urgency=medium
[ Ilias Tsitsimpis ]
* Change Priority to optional. Since Debian Policy version 4.0.1,
priority extra has been deprecated.
* Use the HTTPS form of the copyright-format URL
* Modify d/watch and Source field in d/copyright to use HTTPS
* Declare compliance with Debian policy 4.1.1
* Use salsa.debian.org URLs in Vcs-{Browser,Git} fields
[ Clint Adams ]
* Bump to Standards-Version 4.1.4.
2016-10-27 - Clint Adams <clint@debian.org>
haskell-cipher-des (0.0.6-7) unstable; urgency=medium
* Upload to unstable as part of GHC 8 transition.
2016-10-17 - Clint Adams <clint@debian.org>
haskell-cipher-des (0.0.6-6) experimental; urgency=medium
[ Dmitry Bogatov ]
* Use secure (https) uri in Vcs-Git field in 'debian/control'
* Bump standards version to 3.9.8 (no changes needed)
[ Clint Adams ]
* Temporarily build-depend on ghc 8.
2015-12-03 - Clint Adams <clint@debian.org>
haskell-cipher-des (0.0.6-5) unstable; urgency=medium
* Switch Vcs-Git/Vcs-Browser headers to new location.
2015-08-20 - Joachim Breitner <nomeata@debian.org>
haskell-cipher-des (0.0.6-4) experimental; urgency=medium
* Bump standards-version to 3.9.6
* Depend on haskell-devscripts >= 0.10 to ensure that this package
builds against GHC in experimental
2015-04-27 - Joachim Breitner <nomeata@debian.org>
haskell-cipher-des (0.0.6-3) unstable; urgency=medium
* Upload to unstable
2014-12-20 - Joachim Breitner <nomeata@debian.org>
haskell-cipher-des (0.0.6-2) experimental; urgency=medium
* Depend on haskell-devscripts 0.9, found in experimental
2013-12-07 - Clint Adams <clint@debian.org>
haskell-cipher-des (0.0.6-1) unstable; urgency=low
* New upstream version.
* Enable test suite.
2013-10-05 - Joachim Breitner <nomeata@debian.org>
haskell-cipher-des (0.0.4-2) unstable; urgency=low
* Adjust watch file to new hackage layout

See Also

Package Description
libghc-cipher-des-doc_0.0.6-9_all.deb DES and 3DES ciphers; documentation
libghc-cipher-des-prof_0.0.6-9+b3_i386.deb DES and 3DES ciphers; profiling libraries
libghc-cipher-rc4-dev_0.1.4-9+b3_i386.deb Fast RC4 cipher implementation
libghc-cipher-rc4-doc_0.1.4-9_all.deb Fast RC4 cipher implementation; documentation
libghc-cipher-rc4-prof_0.1.4-9+b3_i386.deb Fast RC4 cipher implementation; profiling libraries
libghc-classy-prelude-conduit-dev_1.5.0-1_i386.deb conduit instances for classy-prelude
libghc-classy-prelude-conduit-doc_1.5.0-1_all.deb conduit instances for classy-prelude; documentation
libghc-classy-prelude-conduit-prof_1.5.0-1_i386.deb conduit instances for classy-prelude; profiling libraries
libghc-classy-prelude-dev_1.5.0-1_i386.deb typeclass-based prelude
libghc-classy-prelude-doc_1.5.0-1_all.deb typeclass-based prelude; documentation
libghc-classy-prelude-prof_1.5.0-1_i386.deb typeclass-based prelude; profiling libraries
libghc-classy-prelude-yesod-dev_1.5.0-1_i386.deb Provide a classy prelude including common Yesod functionality
libghc-classy-prelude-yesod-prof_1.5.0-1_i386.deb Provide a classy prelude including common Yesod functionality.; profiling libraries
libghc-clientsession-dev_0.9.1.2-5+b2_i386.deb library for web session data in cookies
libghc-clientsession-doc_0.9.1.2-5_all.deb library for web session data in cookies; documentation
Advertisement
Advertisement