libgarcon-1-0-dev_0.6.4-1_i386.deb


Advertisement

Description

libgarcon-1-0-dev - transitional package for libgarcon-1-dev

Property Value
Distribution Debian Sid
Repository Debian Main i386
Package filename libgarcon-1-0-dev_0.6.4-1_i386.deb
Package name libgarcon-1-0-dev
Package version 0.6.4
Package release 1
Package architecture i386
Package type deb
Category devel::library libdevel role::devel-lib suite::xfce uitoolkit::gtk
Homepage http://www.xfce.org/
License -
Maintainer Debian Xfce Maintainers <debian-xfce@lists.debian.org>
Download size 74.58 KB
Installed size 82.00 KB

Alternatives

Package Version Architecture Repository
libgarcon-1-0-dev_0.6.4-1_amd64.deb 0.6.4 amd64 Debian Main
libgarcon-1-0-dev - - -

Requires

Name Value
libgarcon-1-dev -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libgarcon-1-0-dev_0.6.4-1_i386.deb
Source Package garcon

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libgarcon-1-0-dev deb package:
    # sudo apt-get install libgarcon-1-0-dev

Files

Path
/usr/share/doc/libgarcon-1-0-dev/changelog.Debian.gz
/usr/share/doc/libgarcon-1-0-dev/changelog.gz
/usr/share/doc/libgarcon-1-0-dev/copyright

Changelog

2019-08-15 - Yves-Alexis Perez <corsac@debian.org>
garcon (0.6.4-1) unstable; urgency=medium
[ Unit 193 ]
* New upstream version 0.6.4
* d/rules:
- Pass '--enable-gtk-doc' during configure to fix consecutive builds.
2019-07-13 - Yves-Alexis Perez <corsac@debian.org>
garcon (0.6.3-1) unstable; urgency=medium
[ Unit 193 ]
* New upstream version 0.6.3
* d/compat, d/control:
- Drop d/compat in favor of debhelper-compat, bump to 11.
* d/control: Build-depend on gtk-doc-tools and xfce4-dev-tools.
* d/rules:
- Drop the now-default options '--parallel' and '--disable-silent-rules'.
- Drop dbgsym migration, it is complete.
- Use dh_missing instead of dh_install --fail-missing.
* Bump Standards-Version to 4.4.0.
[ Helmut Grohne ]
* Fix cross build issues:                                     closes: #890223
+ Switch transitional package libgarcon-1-0-dev to Architecture: any to
allow satisfying dependencies from non-native architectures. It cannot
be Multi-Arch: foreign due to its dependency on libgarcon-1-dev.
+ Mark libgarcon-common Multi-Arch: foreign to allow satisfying
dependencies from non-native architectures.
+ Mark all other packages Multi-Arch: same to allow coinstallation.
2018-12-27 - Yves-Alexis Perez <corsac@debian.org>
garcon (0.6.2-1) unstable; urgency=medium
* Moved the package to git on salsa.debian.org
* Updated the maintainer address to debian-xfce@lists.debian.org
closes: #899857
* d/gbp.conf added, following DEP-14
* d/watch: use HTTPS protocol
* New upstream version 0.6.2
* d/control: drop Lionel from uploaders, thanks!
* d/control: update standards version to 4.3.0
* d/libgarcon-1-0.symbols updated for new release
* d/control: drop priority for libgarcon-1-0-dev
2017-09-03 - Yves-Alexis Perez <corsac@debian.org>
garcon (0.6.1-2) unstable; urgency=medium
[ Unit 193 ]
* d/control:
- Add versioned breaks/replaces on libgarcon-1-0-dev.       closes: #868626
2017-06-21 - Yves-Alexis Perez <corsac@debian.org>
garcon (0.6.1-1) unstable; urgency=medium
[ Yves-Alexis Perez ]
* New upstream release.
* debian/control:
- add build-dep on libgtk-3-dev and libxfce4ui-2 for the GTK3 variant
- run wrap-and-sort
- update standards version to 3.9.8.
* debian/copyright: run wrap-and-sort.
* debian/libgarcon-common.install: run wrap-and-sort.
* debian/control:
- introduce libgarcon-gtk3 and -dev packages.
- rename libgarcon-1-0-dev to libgarcon-1-dev for consistency.
- update standards version to 4.0.0. 
[ Unit 193 ]
* d/control, d/rules: Migrate to dbgsym packages.
2015-05-06 - Yves-Alexis Perez <corsac@debian.org>
garcon (0.4.0-2) unstable; urgency=medium
* Upload to unstable.
2015-03-08 - Yves-Alexis Perez <corsac@debian.org>
garcon (0.4.0-1) experimental; urgency=medium
[ Mateusz Łukasik ]
* New upstream release.
* Bump standards version to 3.9.6
2014-02-23 - Yves-Alexis Perez <corsac@debian.org>
garcon (0.3.0-1) experimental; urgency=low
[ Evgeni Golov ]
* Correct Vcs-* URLs to point to anonscm.debian.org
[ Jackson Doak ]
* Bump standards version to 3.9.5
* debian/rules: Use disable-silent-rules
* New upstream release
* Update symbols
[ Yves-Alexis Perez ]
* debian/control:
- add build-dep on libxfce4ui-1-dev.
2014-08-31 - Yves-Alexis Perez <corsac@debian.org>
garcon (0.2.1-2) unstable; urgency=medium
[ Evgeni Golov ]
* Correct Vcs-* URLs to point to anonscm.debian.org
[ Jackson Doak ]
* Bump standards version to 3.9.5
* debian/rules: Use disable-silent-rules
[ Yves-Alexis Perez ]
* debian/rules:
- call dh-autoreconf to regenerate config.{guess,sub} and fix FTBFS on
ppc64el.                                                  closes: #757334
- call xdt-autogen before configure
* debian/control:
- add build-dep on xfce4-dev-tools, dh-autoreconf, gtk-doc-tools and
intltool for all the above.

See Also

Package Description
libgarcon-1-0_0.6.4-1_i386.deb freedesktop.org compliant menu implementation for Xfce
libgarcon-1-dev_0.6.4-1_i386.deb Development files for garcon-1
libgarcon-common_0.6.4-1_all.deb common files for libgarcon menu implementation
libgarcon-gtk3-1-0_0.6.4-1_i386.deb menu library for Xfce (GTK3 library)
libgarcon-gtk3-1-dev_0.6.4-1_i386.deb Development files for garcon-gtk3
libgarmin-dev_0~svn320-6_i386.deb Garmin image format library (development files)
libgarmin0_0~svn320-6_i386.deb Garmin image format library (runtime version)
libgatbcore-dev_1.4.1+git20190813.a73b6dd+dfsg-1_i386.deb development library of the Genome Analysis Toolbox
libgatbcore2_1.4.1+git20190813.a73b6dd+dfsg-1_i386.deb dynamic library of the Genome Analysis Toolbox
libgatk-native-bindings-java_1.0.0-2_all.deb library for gatk and picard-tools
libgatos-dev_0.0.5-19+b1_i386.deb The General ATI TV and Overlay Software(GATOS): Dev Lib and Headers
libgatos0_0.0.5-19+b1_i386.deb The General ATI TV and Overlay Software(GATOS): Runtime Libraries
libgauche-0.9-0_0.9.6-10_i386.deb Gauche runtime shared library
libgaviotatb-dev_0.4-2_i386.deb Gaviota chess endgame tablebase probing library
libgaviotatb1_0.4-2_i386.deb Gaviota chess endgame tablebase probing library (development package)
Advertisement
Advertisement