liberror-perl_0.17028-1_all.deb


Advertisement

Description

liberror-perl - Perl module for error/exception handling in an OO-ish way

Property Value
Distribution Debian Sid
Repository Debian Main i386
Package filename liberror-perl_0.17028-1_all.deb
Package name liberror-perl
Package version 0.17028
Package release 1
Package architecture all
Package type deb
Category devel::debugger devel::lang:perl devel::library implemented-in::perl perl
Homepage https://metacpan.org/release/Error
License -
Maintainer Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
Download size 30.27 KB
Installed size 76.00 KB

Alternatives

Package Version Architecture Repository
liberror-perl_0.17028-1_all.deb 0.17028 all Debian Main
liberror-perl - - -

Requires

Name Value
perl -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package liberror-perl_0.17028-1_all.deb
Source Package liberror-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install liberror-perl deb package:
    # sudo apt-get install liberror-perl

Files

Path
/usr/share/doc/liberror-perl/changelog.Debian.gz
/usr/share/doc/liberror-perl/changelog.gz
/usr/share/doc/liberror-perl/copyright
/usr/share/doc/liberror-perl/examples/example.pl
/usr/share/doc/liberror-perl/examples/warndie.pl
/usr/share/doc/liberror-perl/examples/next-in-loop/Error.pm-eval.pl
/usr/share/doc/liberror-perl/examples/next-in-loop/Error.pm-next-label.pl
/usr/share/doc/liberror-perl/examples/next-in-loop/Error.pm-next-out-of-catch.pl
/usr/share/doc/liberror-perl/examples/next-in-loop/Error.pm-next.pl
/usr/share/doc/liberror-perl/examples/next-in-loop/README
/usr/share/man/man3/Error.3pm.gz
/usr/share/man/man3/Error::Simple.3pm.gz
/usr/share/perl5/Error.pm
/usr/share/perl5/Error/Simple.pm

Changelog

2019-08-24 - gregor herrmann <gregoa@debian.org>
liberror-perl (0.17028-1) unstable; urgency=medium
* Import upstream version 0.17028.
* Add debian/upstream/metadata.
* Update years of upstream copyright.
* Update pod-whatis.patch.
* Declare compliance with Debian Policy 4.4.0.
* Bump debhelper-compat to 12.
* debian/watch: use uscan version 4.
2019-02-10 - gregor herrmann <gregoa@debian.org>
liberror-perl (0.17027-2) unstable; urgency=medium
* Declare as 'Multi-Arch: foreign'. (Closes: #785643)
* Update years of packaging copyright.
* Declare compliance with Debian Policy 4.3.0.
* Bump debhelper compatibility level to 11.
2018-11-17 - gregor herrmann <gregoa@debian.org>
liberror-perl (0.17027-1) unstable; urgency=medium
* New upstream release.
* Declare compliance with Debian Policy 4.2.1.
* Remove trailing whitespace from debian/*.
* Add patch to fix POD irregularities.
2018-06-19 - gregor herrmann <gregoa@debian.org>
liberror-perl (0.17026-1) unstable; urgency=medium
[ Damyan Ivanov ]
* declare conformance with Policy 4.1.3 (no changes needed)
[ Salvatore Bonaccorso ]
* Update Vcs-* headers for switch to salsa.debian.org
[ gregor herrmann ]
* New upstream release.
* Update years of upstream and packaging copyright.
* Declare compliance with Debian Policy 4.1.4.
* Bump debhelper compatibility level to 10.
2017-10-05 - Damyan Ivanov <dmn@debian.org>
liberror-perl (0.17025-1) unstable; urgency=medium
* Team upload
* New upstream version 0.17025
* Declare conformance with Policy 4.1.1 (no changes needed)
2016-07-17 - gregor herrmann <gregoa@debian.org>
liberror-perl (0.17024-1) unstable; urgency=medium
* Take over for the Debian Perl Group after talking to the security team
which has talked to the MIA team before.
* debian/control: Added: Vcs-Git field (source stanza); Vcs-Browser field
(source stanza); Homepage field (source stanza); ${misc:Depends} to
Depends: field. Changed: Maintainer set to Debian Perl Group
<pkg-perl-maintainers@lists.alioth.debian.org> (was: Clint Burfoot
<clint@burfoot.info>). Removed: Section/Priority from binary package
stanza. Added: /me to Uploaders.
* debian/watch: use metacpan-based URL.
* Mark package as autopkgtest-able.
* Declare compliance with Debian Policy 3.9.8.
* Switch to source format "3.0 (quilt)".
* Add explicit build dependency on libmodule-build-perl.
* debian/rules: switch to dh(1).
* debian/copyright: switch formatting to Copyright-Format 1.0.
* Don't install README anymore. Just a text version of the POD/manpage.
* Revert direct changes to the code.
Both set of changes are not required anymore:
- The problem from #180784 doesn't appear if the line is removed. Probably
as a fix for CPAN RT#20643 in 0.17009.
- The changes to the POD (minus in manpages) seem unncessary, at least
nothing complains.
* Import upstream version 0.17024.
* Install new examples.
* Update long description.
2016-07-05 - gregor herrmann <gregoa@debian.org>
liberror-perl (0.17-1.3) unstable; urgency=medium
* Non-maintainer upload.
* Fix "Removal of debhelper compat 4": switch to debhelper compat level 9.
(Closes: #817530)
2015-08-26 - gregor herrmann <gregoa@debian.org>
liberror-perl (0.17-1.2) unstable; urgency=medium
* Non-maintainer upload.
* Fix "FTBFS with perl 5.22 in experimental (MakeMaker changes)":
use DESTDIR in debian/rules.
(Closes: #793529)
2013-09-07 - CSILLAG Tamas <cstamas@cstamas.hu>
liberror-perl (0.17-1.1) unstable; urgency=low
* Non-maintainer upload.
* apply fix for tests from upstream (closes: #711441)
2007-12-02 - Clint Burfoot <clint@burfoot.info>
liberror-perl (0.17-1) unstable; urgency=low
* New upstream version (closes: #383606)
* debian/rules: use CURDIR instead of PWD (closes: #390482)
* debian/copyright: update copy of author's copyright
* debian/control: new standards version, debhelper dependency
* lib/Error/Simple.pm: manpage fix to POD

See Also

Package Description
libesd-java_0.0.7-4_all.deb Implementation of EsounD in pure Java
libesedb-dev_20181229-3_i386.deb Extensible Storage Engine DB access library -- development files
libesedb-utils_20181229-3_i386.deb Extensible Storage Engine DB access library -- Utilities
libesedb1_20181229-3_i386.deb Extensible Storage Engine DB access library
libesmtp-dev_1.0.6-4.3_i386.deb LibESMTP SMTP client library (development files)
libesmtp6_1.0.6-4.3_i386.deb LibESMTP SMTP client library
libesnacc-dev_1.8.1-1_i386.deb ASN.1 to C or C++ or IDL compiler, development files
libesnacc180_1.8.1-1_i386.deb ASN.1 to C or C++ or IDL compiler, shared libraries
libespeak-dev_1.48.04+dfsg-7_i386.deb Multi-lingual software speech synthesizer: development files
libespeak-ng-dev_1.49.2+dfsg-8_i386.deb Multi-lingual software speech synthesizer: development files
libespeak-ng-libespeak-dev_1.49.2+dfsg-8_i386.deb Multi-lingual software speech synthesizer: development files
libespeak-ng-libespeak1_1.49.2+dfsg-8_i386.deb Multi-lingual software speech synthesizer: shared library
libespeak-ng1_1.49.2+dfsg-8_i386.deb Multi-lingual software speech synthesizer: shared library
libespeak1_1.48.04+dfsg-7_i386.deb Multi-lingual software speech synthesizer: shared library
libestools-dev_2.5.0-6_i386.deb Edinburgh Speech Tools Library - developer's libraries
Advertisement
Advertisement