libdaemon0_0.14-7+b1_i386.deb


Advertisement

Description

libdaemon0 - lightweight C library for daemons - runtime library

Property Value
Distribution Debian Sid
Repository Debian Main i386
Package filename libdaemon0_0.14-7+b1_i386.deb
Package name libdaemon0
Package version 0.14
Package release 7+b1
Package architecture i386
Package type deb
Category libs role::shared-lib
Homepage http://0pointer.de/lennart/projects/libdaemon/
License -
Maintainer Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>
Download size 15.62 KB
Installed size 50.00 KB

Alternatives

Package Version Architecture Repository
libdaemon0_0.14-7+b1_amd64.deb 0.14 amd64 Debian Main
libdaemon0 - - -

Requires

Name Value
libc6 >= 2.28

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libdaemon0_0.14-7+b1_i386.deb
Source Package libdaemon

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libdaemon0 deb package:
    # sudo apt-get install libdaemon0

Files

Path
/usr/lib/i386-linux-gnu/libdaemon.so.0
/usr/lib/i386-linux-gnu/libdaemon.so.0.5.0
/usr/share/doc/libdaemon0/changelog.Debian.gz
/usr/share/doc/libdaemon0/changelog.Debian.i386.gz
/usr/share/doc/libdaemon0/copyright

Changelog

2018-04-27 - Simon McVittie <smcv@debian.org>
libdaemon (0.14-7) unstable; urgency=medium
* Team upload
* Add a trivial build/run autopkgtest
* debian/gbp.conf: Configure for DEP-14 branch names
* Upgrade to debhelper 11 compat level
- Stop running dh-autoreconf explicitly, it is now the default
- libdaemon-doc Breaks older libdaemon-dev because developer
documentation is now in /usr/share/doc/libdaemon-dev
* Replace libdaemon0-dbg with automatic dbgsym package
* Use dh_missing instead of deprecated dh_install --list-missing
* Switch Vcs-* to salsa.debian.org
* Stop using deprecated Priority: extra
* Only install README in libdaemon-doc
* Only run doxygen and lynx if building libdaemon-doc (Closes: #870765)
* Use default dpkg build flags
* Bump Standards-Version to 4.1.4. No further changes.
* Mark documentation as Multi-Arch: foreign
2014-04-25 - Michael Biebl <biebl@debian.org>
libdaemon (0.14-6) unstable; urgency=medium
* Use dh-autoreconf to update the autotools generated files in order to
build on new ports like ppc64el. (Closes: #745787)
2014-04-04 - Michael Biebl <biebl@debian.org>
libdaemon (0.14-5) unstable; urgency=medium
* Move the man pages into libdaemon-doc as well. (Closes: #743590)
2014-04-03 - Michael Biebl <biebl@debian.org>
libdaemon (0.14-4) unstable; urgency=medium
* Move the API documentation out of libdaemon-dev into a separate arch-all
package libdaemon-doc and make libdaemon-dev suggest that package.
Doxygen embeds timestamps into the documentation which makes those files
architecture-dependent. (Closes: #742984)
2014-03-28 - Michael Biebl <biebl@debian.org>
libdaemon (0.14-3) unstable; urgency=low
* Switch to source format 3.0 (quilt)
- Add debian/source/format.
- Drop Build-Depends on quilt.
- Remove /usr/share/cdbs/1/rules/patchsys-quilt.mk include.
- Remove debian/README.source.
* Move from cdbs to dh
- Drop Build-Depends on cdbs.
- Convert debian/rules to use dh.
* Bump Standards-Version to 3.9.5. No further changes.
* Bump debhelper compatibility level to 9. Update Build-Depends accordingly.
* Convert to multi-arch. Mark libdaemon0 and libdaemon-dev as
Multi-Arch: same. (Closes: #742839)
* Tighten list of installed man pages to work around a bug in doxygen which
now generates an oddly named Directory Reference man page.
2010-01-17 - Michael Biebl <biebl@debian.org>
libdaemon (0.14-2) unstable; urgency=low
* debian/control
- Add ${misc:Depends} to all binary packages.
- Add Build-Depends on cdbs.
- Add Build-Depends on quilt.
* debian/rules
- Switch to cdbs.
* debian/patches/01-man-page-typo-fix.patch
- Fix a typo in the man page detected by lintian.
* debian/README.source
- Add a reference to the quilt patch management system documentation.
2009-10-26 - Michael Biebl <biebl@debian.org>
libdaemon (0.14-1) unstable; urgency=low
* New upstream release.
* debian/control
- Set the Utopia Maintenance Team as new maintainer. (Closes: #551883)
- Add myself to Uploaders.
- Update Vcs-* fields. Package is now managed using Git on git.debian.org.
- Bump Standards-Version to 3.8.3. No further changes.
- Bump Build-Depends on debhelper to (>= 7).
* debian/libdaemon0.{shlibs,symbols}
- Update symbols file for new API additions.
- Bump shlibs file accordingly.
* debian/rules
- No longer mangle the man pages using sed. The generated man pages are
properly formatted now.
- Use dh_prep instead of deprecated dh_clean -k.
* debian/compat
- Bump debhelper compat level to 7.
* debian/copyright
- Update copyright notice.
2009-03-18 - Y Giridhar Appaji Nag <appaji@debian.org>
libdaemon (0.13-3) unstable; urgency=low
* Update Maintainer to official Debian ID
* Remove DM-Upload-Allowed: yes
* Change libdaemon0-dbg section to debug from libdevel
* Update Standards-Version to 3.8.1 (no changes required)
* Added a libdaemon0.symbols file for dpkg-gensymbols

See Also

Package Description
libdancer-logger-psgi-perl_1.0.1-2_all.deb PSGI Log handler for Dancer
libdancer-logger-syslog-perl_0.6-1_all.deb Dancer logger engine for Sys::Syslog
libdancer-perl_1.3500+dfsg-1_all.deb effortless web application framework
libdancer-plugin-auth-extensible-perl_1.00-1_all.deb module providing extensible authentication framework for Dancer apps
libdancer-plugin-database-core-perl_0.20-1_all.deb shared core library for Dancer and Dancer2 database plugins
libdancer-plugin-database-perl_2.13-1_all.deb Dancer plugin providing easy database connections
libdancer-plugin-dbic-perl_0.2104-1_all.deb DBIx::Class interface for Dancer applications
libdancer-plugin-email-perl_1.0400-1_all.deb Simple email sending plugin for Dancer applications
libdancer-plugin-flashmessage-perl_0.314-2_all.deb Dancer plugin to display temporary, so called "flash messages"
libdancer-plugin-rest-perl_0.11-3_all.deb REST plugin for Dancer
libdancer-session-cookie-perl_0.30-2_all.deb encrypted cookie-based session backend for Dancer
libdancer-session-memcached-perl_0.2020-2_all.deb Memcached-based session backend for Dancer
libdancer2-perl_0.208001+dfsg-1_all.deb lightweight yet powerful web application framework
libdancer2-plugin-ajax-perl_0.400000-1_all.deb Dancer2 plugin for adding Ajax route handlers
libdancer2-plugin-database-perl_2.17-1_all.deb module for easy database connections for Dancer2 applications
Advertisement
Advertisement