libcanberra-gtk-common-dev_0.30-6_all.deb


Advertisement

Description

libcanberra-gtk-common-dev - simple interface for playing event sounds (GTK+ shared development files)

Property Value
Distribution Debian Sid
Repository Debian Main i386
Package name libcanberra-gtk-common-dev
Package version 0.30
Package release 6
Package architecture all
Package type deb
Installed size 19 B
Download size 7.00 KB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
libcanberra-gtk-common-dev_0.30-6_all.deb 0.30 all Debian Main
libcanberra-gtk-common-dev - - -

Replaces

Name Value
libcanberra-gtk-dev << 0.26

Download

Type URL
Binary Package libcanberra-gtk-common-dev_0.30-6_all.deb
Source Package libcanberra

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libcanberra-gtk-common-dev deb package:
    # sudo apt-get install libcanberra-gtk-common-dev

Files

Path
/usr/include/canberra-gtk.h
/usr/share/doc/libcanberra-gtk-common-dev/changelog.Debian.gz
/usr/share/doc/libcanberra-gtk-common-dev/copyright
/usr/share/vala/vapi/libcanberra-gtk.vapi

Changelog

2017-12-17 - Jeremy Bicha <jbicha@debian.org>
libcanberra (0.30-6) unstable; urgency=medium
* Update Vcs fields for conversion to git
* Add debian/gbp.conf
* Bump Standards-Version to 4.1.2
* Bump debhelper compat to 11
* Mark libcanberra-doc as Multi-Arch: foreign
2017-12-03 - Jeremy Bicha <jbicha@debian.org>
libcanberra (0.30-5) unstable; urgency=medium
* gnome-session-canberra: Drop wrong manual dependency on libcanbera-gtk0
It already depends on the correct libcanberra-gtk3-0
* debian/control.in:
- Drop obsolete Build-Depends on dpkg-dev >= 1.14.13 satisfied in Wheezy
- Also drop obsolete Pre-Depends added for multiarch support
- Have libcanberra0 depend on sound-theme-freedesktop since it is required
by the freedesktop.org draft Sound Theme specification (LP: #790608)
* Install GTK+ 3 module for unity-settings-daemon too
* Add 03_onlyshowin_unity.patch: Play login sound in Unity too (if enabled)
2017-10-30 - Simon McVittie <smcv@debian.org>
libcanberra (0.30-4) unstable; urgency=medium
* Team upload
[ Jeremy Bicha ]
* d/watch: Use format version 4
* d/watch: Use @PACKAGE@ and @ANY_VERSION@ tokens
[ Simon McVittie ]
* Run gtkdocize to update build system (Closes: #876596)
* Set Rules-Requires-Root: no
* Switch from cdbs to dh
* Move to debhelper compat level 10
- Don't use dh-autoreconf explicitly, it is now the default
* Standards-Version: 4.1.1 (no further changes required)
* Give all packages distinct short descriptions
* Enable PIE hardening
2016-04-13 - Simon McVittie <smcv@debian.org>
libcanberra (0.30-3) unstable; urgency=medium
* Team upload.
[ Emilio Pozuelo Monfort ]
* debian/libcanberra0.symbols,
debian/libcanberra0.symbols.hurd-i386:
+ Drop hurd-i386 symbols file, instead use arch tags to mark a couple of
symbols as not available on hurd.
[ Laurent Bigonville ]
* debian/patches/gtk_dont_assume_x11.patch: Don't assume all GdkDisplays are
GdkX11Displays, fixing crashes when running Wayland. (Closes: #820944)
* debian/control, debian/compat: Bump debhelper compatibility to 9
* debian/control: Bump Standards-Version to 3.9.7 (no furter changes)
* Drop -dbg package and rely on automatically built -dbgsym ones
* debian/rules: Pass --as-needed to the linked and to dh_autoreconf to
reduce the number of runtime dependencies
2014-08-31 - Samuel Thibault <sthibault@debian.org>
libcanberra (0.30-2.1) unstable; urgency=medium
[ Samuel Thibault ]
* Non-maintainer upload.
[ Jelmer Vernooij ]
* Remove build-dependency on libtdb-dev on the Hurd, as tdb depends on
byte range locking which is not available on the Hurd. Closes: #190367.
2013-05-30 - Laurent Bigonville <bigon@debian.org>
libcanberra (0.30-2) unstable; urgency=low
* debian/rules: Properly exclude dh_makeshlibs from generating shlibs files
for 0.30 canberra modules
* debian/control.in:
- Bump Standards-Version to 3.9.4 (no further changes)
- Use canonical VCS URL
2013-03-24 - Sjoerd Simons <sjoerd@debian.org>
libcanberra (0.30-1) experimental; urgency=low
* New upstream release
* Gconf usage is dropped (remove b-d and schema install)
* Ported to gstreamer 1.0
2012-11-26 - Josselin Mouette <joss@debian.org>
libcanberra (0.28-6) unstable; urgency=low
* libcanberra-gtk-common-dev breaks/replaces libcanberra-gtk-dev <<
0.26. Closes: #694283.

See Also

Package Description
libcanberra-gtk-dev_0.30-6_i386.deb simple interface for playing event sounds (GTK+ 2 development files)
libcanberra-gtk-module_0.30-6_i386.deb translates GTK+ widgets signals to event sounds
libcanberra-gtk0_0.30-6_i386.deb GTK+ helper for playing widget event sounds with libcanberra
libcanberra-gtk3-0_0.30-6_i386.deb GTK+ 3.0 helper for playing widget event sounds with libcanberra
libcanberra-gtk3-dev_0.30-6_i386.deb simple interface for playing event sounds (GTK+ 3 development files)
libcanberra-gtk3-module_0.30-6_i386.deb translates GTK3 widgets signals to event sounds
libcanberra-pulse_0.30-6_i386.deb PulseAudio backend for libcanberra
libcanberra0_0.30-6_i386.deb simple abstract interface for playing event sounds
libcangjie2-data_1.3-3_all.deb Cangjie input method library (common database)
libcangjie2-dev-tools_1.3-3_i386.deb Cangjie input method library development tools
libcangjie2-dev_1.3-3_i386.deb Cangjie input method library (development)
libcangjie2_1.3-3_i386.deb Cangjie input method library
libcanl-c-dev_3.0.0-3_i386.deb Development files for EMI caNl
libcanl-c-doc_3.0.0-3_all.deb Documentation files for EMI caNl
libcanl-c-examples_3.0.0-3_i386.deb Example programs of EMI caNl
Advertisement
Advertisement