libalog0.5.2.1_0.5.2-3_i386.deb


Advertisement

Description

libalog0.5.2.1 - Logging framework for Ada

Property Value
Distribution Debian Sid
Repository Debian Main i386
Package name libalog0.5.2.1
Package version 0.5.2
Package release 3
Package architecture i386
Package type deb
Installed size 539 B
Download size 127.73 KB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
libalog0.5.2.1_0.5.2-3_amd64.deb 0.5.2 amd64 Debian Main
libalog0.5.2.1 - - -

Requires

Name Value
libc6 >= 2.4
libgcc1 >= 1:3.0
libgnat-7 >= 7.2.0-5

Download

Type URL
Binary Package libalog0.5.2.1_0.5.2-3_i386.deb
Source Package libalog

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libalog0.5.2.1 deb package:
    # sudo apt-get install libalog0.5.2.1

Files

Path
/usr/lib/i386-linux-gnu/libalog.so.0.5.2.1
/usr/share/doc/libalog0.5.2.1/changelog.Debian.gz
/usr/share/doc/libalog0.5.2.1/changelog.gz
/usr/share/doc/libalog0.5.2.1/copyright

Changelog

2017-09-10 - Adrian-Ken Rueegsegger <ken@codelabs.ch>
libalog (0.5.2-3) unstable; urgency=medium
[ Nicolas Boulenguez ]
* Debhelper 10.
* Tests: remove unused variable, log executed commands.
* Allow -doc package to satisfy Multi-Arch: same dependencies.
* HTTPS copyright format URL.
* Handle DEB_BUILD_OPTIONS=nodoc.
* Select debian_packaging.mk snippet, there may be many.
* Replace --fail-missing deprecated debhelper option.
* Split -arch and -indep targets and Build-Depends.
* Replace many wildcards with explicit variable expansions.
* Install GNAT project to /usr/share/gpr.
* Make the runtime library package Multi-Arch: same.
* Allow DEB_BUILD_OPTIONS=nocheck.
* Build with gnat-7 and libahven6-dev (Closes: #872290).
[ Adrian-Ken Rueegsegger ]
* Update to Standards-Version 4.1.0
* Unset LDFLAGS when building static library
2016-12-29 - Adrian-Ken Rueegsegger <ken@codelabs.ch>
libalog (0.5.2-2) unstable; urgency=medium
[ Adrian Bunk <bunk@stusta.de> ]
* Enable PIE build option (Closes: #844886)
2016-08-17 - Adrian-Ken Rueegsegger <ken@codelabs.ch>
libalog (0.5.2-1) unstable; urgency=medium
* Imported upstream version 0.5.2 (Closes: #782182)
* Transition to gnat-6 compiler (Closes: #777934, #833764)
* Update ahven Build-Depends to libahven5-dev
* Adjust gprbuild Build-Depends
* Switch Homepage and Vcs-* URLs to HTTPS
* Update to Standards-Version 3.9.8
* Update binary package names
* Use short-names for lib install & lintian-overrides
* Drop explicit libalog-dbg package
* Simplify build by using debian_packaging-*.mk
* Drop explicit XS-Testsuite
* Use gprbuild in autopkgtest
* Add upstream signing key
* Update watch file to version 4
* Avoid quilt for arch-dependent patching
2014-10-16 - Adrian-Ken Rueegsegger <ken@codelabs.ch>
libalog (0.5.0-1) unstable; urgency=medium
* Imported upstream version 0.5.0
* Remove obsolete DM-Upload-Allowed from debian/control
* Drop 'full' packages as upstream has removed that functionality
* Update patches
* Update binary package names
* Update package descriptions in debian/control
* Update to Standards-Version 3.9.6
* Update Build-Depends in debian/control
* Enable dpkg-buildflags hardening options
* Make -dbg package compliant to Debian Ada Policy
* Transition to gnat-4.9 compiler (Closes: #746082, #755077, #764444)
* Update ahven Build-Depends to libahven4-dev
* Update copyright information
* Update to debhelper 9
* Simplify debian/rules file
* Declare NUM_CPUS variable in debian/rules
* Override dh_compress and dh_auto_test targets
* Update debian/*.install files
* Add debian/watch file
* Add libalog-doc package
* Add minimal run time test for installed package
* Decouple the aliversion from the soversion
2012-03-30 - Reto Buerki <reet@codelabs.ch>
libalog (0.4.1-2) unstable; urgency=low
* Add project specific git-buildpackage configuration
* Build dynamic/static libs in separate Obj/Lib dirs (Closes: #663673)
* Disable tracebacks in Exception occurrences.
See Debian bug #666106; tracebacks are only disabled on kfreebsd-i386.
Quilt's guards tool is used to apply this architecture specific patch.
2012-03-07 - Adrian-Ken Rueegsegger <ken@codelabs.ch>
libalog (0.4.1-1) unstable; urgency=low
* Imported upstream version 0.4.1
* Update to Standards-Version 3.9.3 (no changes)
* Update to debhelper 8
* Update Vcs-Git, Vcs-Browser and Homepage URLs
* Update copyright information
* Drop unneeded patches
* Set package names to new library version 0.4.1
* Migrate to gnat-4.6 (Closes: #642639, #647795)
* Update GNAT project files
* Switch to 3.0 (quilt) source package format
* Install html doc in dev packages
* Update rules to minimal debhelper syntax
* Allow Debian Maintainer upload
* Fix binary-control-field-duplicates-source warning
2010-02-20 - Adrian-Ken Rueegsegger <ken@codelabs.ch>
libalog (0.3-2) unstable; urgency=low
* Disable stack checks (Closes: #506681).
* Use $(QUILT_STAMPFN) instead of patch target.

See Also

Package Description
libalog3-dev_0.5.2-3_i386.deb Logging framework for Ada (development)
libalsa-ocaml-dev_0.2.3-1+b1_i386.deb OCaml bindings for the ALSA library
libalsa-ocaml_0.2.3-1+b1_i386.deb OCaml bindings for the ALSA library
libalsaplayer-dev_0.99.81-2_i386.deb alsaplayer plugin library (development files)
libalsaplayer0_0.99.81-2_i386.deb alsaplayer plugin library
libalt-alien-ffi-system-perl_0.21-1_all.deb simplified alternative to Alien::FFI that uses system libffi
libalt-base-perl_0.2-3_all.deb base class for alternate modules
libalt-perl_0.19-1_all.deb namespace for alternate module implementations
libalure-dev_1.2-6+b1_i386.deb AL Utilities REtooled (development files)
libalure1_1.2-6+b1_i386.deb AL Utilities REtooled (shared library)
libalut-dev_1.1.0-5+b2_i386.deb OpenAL Utility Toolkit development files
libalut0_1.1.0-5+b2_i386.deb OpenAL Utility Toolkit
libalzabo-perl_0.92-4_all.deb Data modelling tool and RDBMS-OO mapper
libam7xxx-dev_0.1.7-1+b1_i386.deb library for accessing am7xxx devices - development files
libam7xxx0.1-bin_0.1.7-1+b1_i386.deb library for accessing am7xxx devices - utilities
Advertisement
Advertisement