libadacgi2_1.6-22_i386.deb


Advertisement

Description

libadacgi2 - Ada CGI interface: shared library

Property Value
Distribution Debian Sid
Repository Debian Main i386
Package filename libadacgi2_1.6-22_i386.deb
Package name libadacgi2
Package version 1.6
Package release 22
Package architecture i386
Package type deb
Category libs role::shared-lib
Homepage http://www.dwheeler.com/adacgi
License -
Maintainer Phil Brooke <pjb@debian.org>
Download size 28.76 KB
Installed size 85.00 KB

Alternatives

Package Version Architecture Repository
libadacgi2_1.6-22_amd64.deb 1.6 amd64 Debian Main
libadacgi2 - - -

Requires

Name Value
libc6 >= 2.4
libgcc1 >= 1:3.0
libgnat-8 >= 8.2.0-8

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libadacgi2_1.6-22_i386.deb
Source Package adacgi

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libadacgi2 deb package:
    # sudo apt-get install libadacgi2

Files

Path
/usr/lib/i386-linux-gnu/libadacgi.so.2
/usr/share/doc/libadacgi2/changelog.Debian.gz
/usr/share/doc/libadacgi2/changelog.gz
/usr/share/doc/libadacgi2/copyright

Changelog

2018-10-21 - Phil Brooke <pjb@debian.org>
adacgi (1.6-22) unstable; urgency=medium
* Re-upload to carry changes from experimental to unstable (for
GNAT-8 transition).  Closes: #903843.
2018-07-21 - Phil Brooke <pjb@debian.org>
adacgi (1.6-21) experimental; urgency=medium
* Apply the following changes from Nicolas Boulenguez.  Thank you!
- Rebuild with gcc-8, rename -dev and lib packages accordingly.
- Update dependencies: debhelper.
- Standards-Version: 4.1.5. Rules-Requires-Root: no.
- Make test more verbose to help investigation in case of failure.
- Delete trailing spaces in changelog.
- Drop obsolete version requirement on dpkg-dev.
- Simplify parsing of debian/control.
2017-09-05 - Phil Brooke <pjb@debian.org>
adacgi (1.6-20) unstable; urgency=medium
* Ack NMUs 1.6-19.1 and 1.6-19.2.  Thank you, Nicolas.
* Upload for unstable (previous was experimental).
2017-07-29 - Nicolas Boulenguez <nicolas@debian.org>
adacgi (1.6-19.2) experimental; urgency=medium
* Non-maintainer upload.
* Make the library compliant with Debian Ada policy:
- split runtime (soversion) and -dev (aliversion) packages
- provide let -dev also provide a static library.
* Build with gnat-7 and gprbuild.
* Switch to source format 3.0 (quilt).
* Switch to dh-ada-library, debhelper 10 and dh driver.
* Switch copyright file to machine readable 1.0 format.
* Install shared library into multiarch paths.
* Enable hardening dpkg-buildflags.
* Install forgotten screen.html, linked from cgi.html.
* Standards-Version: 4.0.0.
* Add watch file, minimal runtime test, doc-base registration.
2016-07-11 - Nicolas Boulenguez <nicolas@debian.org>
adacgi (1.6-19.1) unstable; urgency=medium
* Non-maintainer upload.
* Rebuild with gnat-6 and bump ALI version. Closes: #830349.
2014-10-18 - Phil Brooke <pjb@debian.org>
adacgi (1.6-19) unstable; urgency=medium
* Add notice to debian/copyright re: adacgi.spec.  (Closes: 756383.)
* Bump to standards version 3.9.6.
2014-07-22 - Phil Brooke <pjb@debian.org>
adacgi (1.6-18) unstable; urgency=medium
* Update GNAT version to 4.9.  Also rename to adacgi2 and bump
ALIVERSION in debian/rules.  (Closes: 755007, 753955.)
* Bump to standards version 3.9.5.
2012-07-02 - Phil Brooke <pjb@debian.org>
adacgi (1.6-17) unstable; urgency=low
* Fix GNAT project file that was missing Externally_Built attribute
(closes: 679638).
2011-12-07 - Phil Brooke <pjb@debian.org>
adacgi (1.6-16) unstable; urgency=low
* Rename adacgi0 to adacgi1; should have been done at the same time
as changing gnat version.
2011-12-07 - Phil Brooke <pjb@debian.org>
adacgi (1.6-15) unstable; urgency=low
* Bump gnat version to 4.6 (closes: 642610).
* Bump to standards version 3.9.2.
* Fix build targets in debian/rules.

See Also

Package Description
libadasockets8-dev_1.11.1-2_i386.deb bindings for socket services in Ada: development files
libadasockets8_1.11.1-2_i386.deb bindings for socket services in Ada: shared library
libaddresses-dev_0.4.8-3+b1_i386.deb Database API backend framework for GNUstep (development files)
libaddresses0_0.4.8-3+b1_i386.deb Database API backend framework for GNUstep (library files)
libaddressview-dev_0.4.8-3+b1_i386.deb Address display/edit framework for GNUstep (development files)
libaddressview0_0.4.8-3+b1_i386.deb Address display/edit framework for GNUstep (library files)
libadios-bin_1.13.1-16_i386.deb ADIOS Adaptable IO system for simulations - binaries
libadios-dev_1.13.1-16_i386.deb ADIOS Adaptable IO system for simulations
libadios-examples_1.13.1-16_all.deb Examples for the ADIOS Adaptable IO system
libadios-mpich-dev_1.13.1-16_i386.deb ADIOS Adaptable IO system (MPICH development files)
libadios-openmpi-dev_1.13.1-16_i386.deb ADIOS Adaptable IO system (OpenMPI development files)
libadmesh-dev_0.98.3-4_i386.deb Tool for processing triangulated solid meshes. Development files
libadmesh1_0.98.3-4_i386.deb Tool for processing triangulated solid meshes. Shared library
libadms0_2.3.6-2_i386.deb Shared library for automatic device model synthesizer
libadns1-dev_1.5.0~rc1-1.1_i386.deb Asynchronous-capable DNS client library (development)
Advertisement
Advertisement