gdebi_0.9.5.7+nmu2_all.deb


Advertisement

Description

gdebi - simple tool to view and install deb files - GNOME GUI

Property Value
Distribution Debian Sid
Repository Debian Main i386
Package name gdebi
Package version 0.9.5.7+nmu2
Package release
Package architecture all
Package type deb
Installed size 169 B
Download size 39.95 KB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
gdebi_0.9.5.7+nmu2_all.deb 0.9.5.7+nmu2 all Debian Main
gdebi - - -

Requires

Name Value
gdebi-core = 0.9.5.7+nmu2
gir1.2-gtk-3.0 -
gir1.2-vte-2.91 -
gnome-icon-theme -
policykit-1 -
python3-gi -
python3:any >= 3.3.2-2~

Download

Type URL
Binary Package gdebi_0.9.5.7+nmu2_all.deb
Source Package gdebi

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install gdebi deb package:
    # sudo apt-get install gdebi

Files

Path
/usr/bin/gdebi-gtk
/usr/share/application-registry/gdebi.applications
/usr/share/applications/gdebi.desktop
/usr/share/doc/gdebi/README
/usr/share/doc/gdebi/changelog.gz
/usr/share/doc/gdebi/copyright
/usr/share/gdebi/gdebi-gtk
/usr/share/gdebi/gdebi.png
/usr/share/gdebi/gdebi.ui
/usr/share/gdebi/GDebi/GDebiGtk.py
/usr/share/gdebi/GDebi/SimpleGtkbuilderApp.py
/usr/share/man/man1/gdebi-gtk.1.gz
/usr/share/polkit-1/actions/com.ubuntu.pkexec.gdebi-gtk.policy
/usr/share/python3/runtime.d/gdebi.rtupdate

Changelog

2017-12-31 - Jeremy Bicha <jbicha@debian.org>
gdebi (0.9.5.7+nmu2) unstable; urgency=medium
[ Julien Lavergne ]
* Add a gdebi-gtk-pkexec executable to launch without gksu (LP: #189617).
* debian/control:
- Make gdebi depends on policykit-1 | gksu.
[ Simon Quigley ]
* Finish the policykit port:
- gdebi-gtk-pkexec isn't needed, root access is only needed for the
package installation and removal.
- Install the policykit file (create debian/gdebi-gtk.install).
- Modify the gksu commands in GDebi/GDebiGtk.py to call pksu instead.
- Drop the dependency on gksu and only depend on policykit-1.
- Thanks for the initial work, Julien!
[ Jeremy Bicha ]
* Upload to unstable (LP: #1719746)
* Stop building gdebi-kde since gdebi-kde is the last package in Testing
depending on the unmaintained pykde4 (Closes: #864963)
2016-11-11 - Jonathan Wiltshire <jmw@debian.org>
gdebi (0.9.5.7+nmu1) unstable; urgency=medium
[ Petter Reinholdtsen ]
* Non-maintainer upload.
* Fix build dependencies, add pyflakes3 needed after package split
(Closes: #820693).
2015-07-08 - Michael Vogt <mvo@debian.org>
gdebi (0.9.5.7) unstable; urgency=medium
[ Michael Vogt ]
* GDebi/GDebiGtk.py:
- fix child_exited() change for vte 2.91 (LP: #1472618)
[ Dimitri John Ledkov ]
* Fix exceptions going out of scope. (LP: #1304274)
2015-07-02 - Michael Vogt <mvo@debian.org>
gdebi (0.9.5.6) unstable; urgency=medium
[ Iain Lane ]
* Use vte 2.91
[ Alex Henrie ]
* Use standard MIME type vnd.debian.binary-package so that xdg-open
foo.deb will use gdebi
2014-11-11 - Ivo De Decker <ivodd@debian.org>
gdebi (0.9.5.5+nmu1) unstable; urgency=medium
* Non-maintainer upload.
* Make sure the watcher for the lintian exit code is added only once. It was
added twice by mistake (with both IO watchers), causing a race condition
when checking the exit code. This fixes the lintian test during the build.
(Closes: #765151).
2014-09-29 - Luca Falavigna <dktrkranz@debian.org>
gdebi (0.9.5.5) unstable; urgency=medium
* Team upload.
[ Michael Vogt ]
* mention ability to resolve build-dependencies from a debian/control
file, thanks to Axel Beckert
* improve description for gdebi-gtk to include information about
lintian and the ability to inspect deb packages
[ Luca Falavigna ]
* debian/control:
- Add lintian to gdebi's Recommends field (Closes: #755812).
- Bump Standards-Version to 3.9.6.
* tests/test_gdebi_cli.py:
- Fix FTBFS with non en_US locales (Closes: #757078).
2014-04-22 - Luca Falavigna <dktrkranz@debian.org>
gdebi (0.9.5.4) unstable; urgency=low
[ Michael Vogt ]
* fix installing of dependency packages when called with sudo
(LP: #1309387)
[ Michael Werle ]
* gdebi-kde, GDebi/GDebiKDE.py:
- Fix python3 internatlization bugs (Closes: #743756) (LP: #1304143).
[ Luca Falavigna ]
* Fix tests at build time (Closes: #743091).
2014-04-07 - Michael Vogt <michael.vogt@ubuntu.com>
gdebi (0.9.5.3) unstable; urgency=low
* convert only full lines from dpkg-statusfd into utf8 (LP: #1301857)
2014-04-04 - Barry Warsaw <barry@ubuntu.com>
gdebi (0.9.5.2) unstable; urgency=medium
* Add a universal_newlines=True to Popen command to get a proper unicode
object.  (LP: #1301422)
* Whitespace normalization.
2014-04-02 - Dimitri John Ledkov <xnox@ubuntu.com>
gdebi (0.9.5.1) unstable; urgency=medium
* Lower required python3 version to 3.3. As 3.4 is not needed, and
Debian's default is still 3.3.

See Also

Package Description
gdf-tools_0.1.2-2.1+b1_i386.deb IO library for the GDF -- helper tools
gdigi_0.4.0-1+b2_i386.deb utility to control DigiTech effect pedals
gdis-data_0.90-5_all.deb molecular and crystal model viewer (data files)
gdis_0.90-5+b1_i386.deb molecular and crystal model viewer
gdisk_1.0.3-1+b1_i386.deb GPT fdisk text-mode partitioning tool
gdl-astrolib_2018.05.21+dfsg-1_all.deb Low-level astronomy software for GDL
gdl-coyote_2016.11.13-2_all.deb GDL library from D. Fannings IDL courses
gdl-mpfit_1.85+2017.01.03-2_all.deb Robust non-linear least squares curve fitting for GDL
gdm3_3.28.2-3_i386.deb GNOME Display Manager
gdmap_0.8.1-5_i386.deb Tool to visualize diskspace
gdnsd-dev_2.4.0-1_all.deb authoritative domain name server (development files)
gdnsd_2.4.0-1_i386.deb authoritative domain name server
gdpc-examples_2.2.5-8_all.deb example files for the gdpc program
gdpc_2.2.5-8_i386.deb visualiser of molecular dynamic simulations
geant321-data_3.21.14.dfsg-11_all.deb [Physics] Data for GEANT 3.21 detector simulator
Advertisement
Advertisement