coccinelle_1.0.4.deb-3+b3_i386.deb


Advertisement

Description

coccinelle - semantic patching tool for C

Distribution: Debian Sid
Repository: Debian Main i386
Package name: coccinelle
Package version: 1.0.4.deb
Package release: 3+b3
Package architecture: i386
Package type: deb
Installed size: 8.69 KB
Download size: 1.94 MB
Official Mirror: ftp.br.debian.org
Description: unavailable.

Alternatives

    Download

    Source package: coccinelle

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install coccinelle deb package:
      # sudo apt-get install coccinelle

    Changelog

    2016-05-16 - Євгеній Мещеряков <eugen@debian.org> coccinelle (1.0.4.deb-3) unstable; urgency=medium * Fix package name spelling in the package description, thanks to Thomas Vincent for reporting (closes: #824224)

    2015-12-24 - Євгеній Мещеряков <eugen@debian.org> coccinelle (1.0.4.deb-2) unstable; urgency=medium * Run tests only when building architecture-dependant packages (closes: #806611)

    2015-11-05 - Євгеній Мещеряков <eugen@debian.org> coccinelle (1.0.4.deb-1) unstable; urgency=medium * New upstream release * Remove disable-spgen.diff - fixed upstream

    2015-10-28 - Євгеній Мещеряков <eugen@debian.org> coccinelle (1.0.3.deb-2) unstable; urgency=medium * Upload to unstable * Re-enable checks * Executel "make all" in ocaml subdirectory so tests don't fail anymore

    2015-10-27 - Євгеній Мещеряков <eugen@debian.org> coccinelle (1.0.3.deb-1) experimental; urgency=medium * New upstream release * Updated patches: - notparallel-main-makefile.diff * Build-depend on hevea * Build-depend on latexmk * New patches: - disable-spgen.diff - disable installation of spgen because it is not built

    2015-10-12 - Євгеній Мещеряков <eugen@debian.org> coccinelle (1.0.2.deb-1) experimental; urgency=medium [ Stéphane Glondu ] * Add camlp4 to Build-Depends (closes: #801459) [ Євгеній Мещеряков ] * New upstream release * Depend on libparmap-ocaml (closes: #798263) * Disable testing for now * debian/rules adjust the binary renaming code * Adjust path to the python directory in /usr/bin/spatch * Pass expanded libdir to configure, the build system does not handle variables well * Upload to experimental because ocaml scripts don't work yet

    2015-05-26 - Євгеній Мещеряков <eugen@debian.org> coccinelle (1.0.0.deb-1) unstable; urgency=medium * New upstream release * Remove patches: - no-parmap-subdir.diff * Fix the Vcs-Git control field * New patch: - bash-completion-dir.diff - install bash completion files into the new location * debian/coccinelle.maintscript - remove the obsolete bash completion file * Build-depend on dh-python * Pre-depend on dpkg (>= 1.17.14)

    2015-05-14 - Євгеній Мещеряков <eugen@debian.org> coccinelle (1.0.0~rc24.deb-4) unstable; urgency=medium * Build-depend on libparmap-ocaml-dev (>= 1.0~rc4-5~) to get building on bytecode architectures fixed * Update debian/gbp.conf

    2015-05-13 - Євгеній Мещеряков <eugen@debian.org> coccinelle (1.0.0~rc24.deb-3) unstable; urgency=medium * Fix typo in "ocamlfind" invocation * Upload to unstable

    2015-03-12 - Євгеній Мещеряков <eugen@debian.org> coccinelle (1.0.0~rc24.deb-2) experimental; urgency=medium * Use ocamlfind to search for parmap

    Advertisement
    Advertisement