blockattack_2.3.0-1+b1_i386.deb


Advertisement

Description

blockattack - puzzle game inspired by Tetris

Property Value
Distribution Debian Sid
Repository Debian Main i386
Package name blockattack
Package version 2.3.0
Package release 1+b1
Package architecture i386
Package type deb
Installed size 6.52 KB
Download size 5.86 MB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
blockattack_2.3.0-1+b1_amd64.deb 2.3.0 amd64 Debian Main
blockattack - - -

Requires

Name Value
libboost-program-options1.67.0 -
libc6 >= 2.4
libgcc1 >= 1:3.0
libphysfs1 -
libsdl2-2.0-0 >= 2.0.8
libsdl2-image-2.0-0 >= 2.0.2
libsdl2-mixer-2.0-0 >= 2.0.2
libsdl2-ttf-2.0-0 >= 2.0.14
libstdc++6 >= 5.2

Download

Type URL
Binary Package blockattack_2.3.0-1+b1_i386.deb
Source Package blockattack

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install blockattack deb package:
    # sudo apt-get install blockattack

Files

Path
/usr/games/blockattack
/usr/share/applications/blockattack.desktop
/usr/share/doc/blockattack/AUTHORS
/usr/share/doc/blockattack/changelog.Debian.gz
/usr/share/doc/blockattack/changelog.Debian.i386.gz
/usr/share/doc/blockattack/copyright
/usr/share/games/blockattack/blockattack.data
/usr/share/icons/hicolor/128x128/apps/blockattack.xpm
/usr/share/icons/hicolor/16x16/apps/blockattack.xpm
/usr/share/icons/hicolor/256x256/apps/blockattack.xpm
/usr/share/icons/hicolor/32x32/apps/blockattack.xpm
/usr/share/icons/hicolor/48x48/apps/blockattack.xpm
/usr/share/icons/hicolor/64x64/apps/blockattack.xpm
/usr/share/locale/da/LC_MESSAGES/blockattack_roftb.mo
/usr/share/man/man6/blockattack.6.gz

Changelog

2018-07-29 - Markus Koschany <apo@debian.org>
blockattack (2.3.0-1) unstable; urgency=medium
* Team upload.
* New upstream version 2.3.0.
* Declare compliance with Debian Policy 4.1.5.
2018-06-04 - Markus Koschany <apo@debian.org>
blockattack (2.2.0-1) unstable; urgency=medium
* Team upload.
* New upstream version 2.2.0.
* Switch to compat level 11.
* Declare compliance with Debian Policy 4.1.4.
2017-08-20 - Markus Koschany <apo@debian.org>
blockattack (2.1.2-1) unstable; urgency=medium
* Team upload.
* New upstream version 2.1.2.
* Declare compliance with Debian Policy 4.0.1.
2017-06-26 - Markus Koschany <apo@debian.org>
blockattack (2.1.1-1) unstable; urgency=medium
* Team upload.
* New upstream version 2.1.1.
* Declare compliance with Debian Policy 4.0.0.
* Drop deprecated menu file.
* Use https for Format field.
* Drop bad-whatis-entry.patch. Merged upstream.
* Refresh install-path.patch.
* Drop libjsoncpp-dev from Build-Depends.
* Update debian/copyright for new release.
2016-10-04 - Markus Koschany <apo@debian.org>
blockattack (2.0.1-1) unstable; urgency=medium
* Team upload.
* New upstream version 2.0.1.
* Install ReleaseNotes-2.0.1.txt as upstream changelog.
* Switch to compat level 10.
2016-06-05 - Markus Koschany <apo@debian.org>
blockattack (2.0.0-1) unstable; urgency=medium
* Team upload.
* The project moved to Github. Update debian/watch.
* Imported Upstream version 2.0.0.
* Declare compliance with Debian Policy 3.9.8.
* Vcs-Git: Use https.
* Switch from SDL1 to SDL2.
* Remove libenet-dev from Build-Depends. Network mode is gone.
* Switch from scons to cmake.
* Add libboost-dev, libutfcpp-dev, libboost-program-options-dev,
libjsoncpp-dev and SDL2 to Build-Depends.
* Update debian/rules for new build system.
* The manual has been removed. Drop latex build-dependencies.
* Do not install the manual because it is gone.
* Add install-path.patch and install locales into /usr/share but the game
data into /usr/share/games.
* Drop useless doc-base file.
* Export DEB_BUILD_MAINT_OPTIONS = hardening=+all
* debian/menu: Fix icon path.
* Remove icons directory and use upstream's icons.
* Update debian/copyright for new release.
* Add bad-whatis-entry.patch and fix the Lintian warning of the same name.
2016-01-07 - Markus Koschany <apo@debian.org>
blockattack (1.4.2-2) unstable; urgency=medium
* Team upload.
* Move the package to Git. Update Vcs-* fields accordingly.
2016-01-06 - Markus Koschany <apo@debian.org>
blockattack (1.4.2-1) unstable; urgency=medium
* Team upload.
[ Markus Koschany ]
* Acknowledge NMU by Jonathan Wiltshire. Thanks.
* New upstream release. The upstream tarball is pristine now.
* Rebuild against GCC-5. (Closes: #793219)
* Remove README.source.
* Use compat level 9 and require debhelper >= 9.
* wrap-and-sort -sa.
* Declare compliance with Debian Policy 3.9.6.
* Vcs-Browser: Use https.
* debian/watch: Make the extension regex more flexible to detect the latest
releases.
* Update debian/copyright to copyright format 1.0.
* Simplify get-orig-source.
* Use old blockattack*.xpm icons from version 1.4.1 because the new icon
Game/gfx/icon.png has a poorer resolution.
* Remove debian/block_attack_manual.tex and use upstream's file instead.
* debian/docs: Don't install README and adjust the path to AUTHORS file.
* Update debian/blockattack.desktop. Add keywords and a comment in German.
Use blockattack64.xpm because of the better resolution.
* Drop all patches. Fixed upstream.
* debian/menu: Use the absolute icon path to display the menu icon.
(Closes: #726212)
* Remove override for dh_installchangelogs because there is no changelog to
install.
* Update debian/clean file and ensure that the game can be built twice in a
row.
[ Evgeni Golov ]
* Correct Vcs-* URLs to point to anonscm.debian.org
[ Cyril Brulebois ]
* Remove myself from Uploaders.
[ Paul Wise ]
* Drop gcc47.diff. Fixed upstream.

See Also

Package Description
blockfinder_3.14159-2_all.deb enumerates network information for countries
blockout2_2.4+dfsg1-8_i386.deb Tetris like game (3D-tetris)
blocks-of-the-undead-data_1.0-7_all.deb Tetris Attack clone with spooky undertones - data files
blocks-of-the-undead_1.0-7_i386.deb Tetris Attack clone with spooky undertones
blogilo_17.08.3-2_i386.deb graphical blogging client
blogliterately_0.8.6.2-1+b2_i386.deb Tool for posting Haskelly articles to blogs
blogofile-converters_0.8b1-1_all.deb blog converter collection for Blogofile
blogofile_0.8b1-1_all.deb static website compiler and blog engine
blop_0.2.8-6.1_i386.deb Bandlimited wavetable-based oscillator plugins for LADSPA hosts
bloscpack_0.15.0-4_all.deb CLI utility for the Blosc metacompressor
blosxom_2.1.2-2_all.deb light, feature-packed weblog app with plugin extensibility
bls-standalone_0.20151231_i386.deb standalone build log scanner
blt-demo_2.5.3+dfsg-4_all.deb graphics extension library for Tcl/Tk - demos and examples
blt-dev_2.5.3+dfsg-4_i386.deb graphics extension library for Tcl/Tk - development files
blt_2.5.3+dfsg-4_i386.deb graphics extension library for Tcl/Tk - run-time
Advertisement
Advertisement