7kaa_2.15.1+dfsg-1_i386.deb


Advertisement

Description

7kaa - Seven Kingdoms Ancient Adversaries: real-time strategy game

Property Value
Distribution Debian Sid
Repository Debian Main i386
Package filename 7kaa_2.15.1+dfsg-1_i386.deb
Package name 7kaa
Package version 2.15.1+dfsg
Package release 1
Package architecture i386
Package type deb
Category game::strategy games interface::graphical interface::x11 role::program uitoolkit::sdl use::gameplaying x11::application
Homepage http://www.7kfans.com/
License -
Maintainer Debian Games Team <pkg-games-devel@lists.alioth.debian.org>
Download size 726.25 KB
Installed size 1.89 MB

Alternatives

Package Version Architecture Repository
7kaa_2.15.1+dfsg-1_amd64.deb 2.15.1+dfsg amd64 Debian Main
7kaa - - -

Requires

Name Value
7kaa-data = 2.15.1+dfsg-1
libc6 >= 2.27
libcurl3-gnutls >= 7.16.2
libenet7 -
libgcc1 >= 1:3.0
libopenal1 >= 1.14
libsdl2-2.0-0 >= 2.0.8
libstdc++6 >= 5.2
libuuid1 >= 2.16

Download

Type URL
Mirror ftp.br.debian.org
Binary Package 7kaa_2.15.1+dfsg-1_i386.deb
Source Package 7kaa

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install 7kaa deb package:
    # sudo apt-get install 7kaa

Files

Path
/usr/games/7kaa
/usr/share/applications/7kaa.desktop
/usr/share/doc/7kaa/README
/usr/share/doc/7kaa/changelog.Debian.gz
/usr/share/doc/7kaa/copyright
/usr/share/man/man6/7kaa.6.gz
/usr/share/pixmaps/7kaa.png
/usr/share/pixmaps/7kaa.xpm

Changelog

2019-01-01 - Bertrand Marc <bmarc@debian.org>
7kaa (2.15.1+dfsg-1) unstable; urgency=medium
* New upstream version 2.15.1+dfsg.
* Remove debian/patches/abs_dir, not necessary anymore.
* Refresh use_system_libuuid.patch.
* Standards-version: 4.3.0, no changes needed.
* debian/control: 
+ Make 7kaa depend on the data from the same version.
+ Make 7kaa suggest 7kaa-music (in case it would be packaged in non-free).
* Allow 7kaa to be built on any architecture (Closes: #726450).
2018-11-18 - Bertrand Marc <bmarc@debian.org>
7kaa (2.15.0+dfsg-1) unstable; urgency=medium
* Update debian/watch to version 4, add a rule deal with pre and rc versions
and the repacksuffix option.
* Remove custom compression settings in debian/source/options.
* Update Vcs-* in debian/control: the package was moved to salsa.
* New upstream version 2.15.0+dfsg.
* Update build-dependency on libsdl2-dev (>= 2.0.8) according to README.
* Update years in debian/copyright.
* Standards-version: 4.2.1, no changes needed.
* Refresh patches.
2017-07-26 - Bertrand Marc <bmarc@debian.org>
7kaa (2.14.7+dfsg-1) unstable; urgency=medium
* debian/rules:
+ remove override_dh_builddeb, xz is the default compression.
+ enable all hardening build flags, including bindnow.
* debian/copyright:
+ update the exclude list according to upstream changes.
+ update years and Format: url.
* New upstream version 2.14.7+dfsg.
* Refresh patches.
* Build-depend on libcurl4-gnutls-dev.
* Standards-Version: 4.0.0.
2016-09-20 - Bertrand Marc <bmarc@debian.org>
7kaa (2.14.6+dfsg-1) unstable; urgency=medium
* Use my @debian.org address in the uploaders field and in debian/copyright.
* Moved the package to Git.
* Remove the fix_format_security patch, included upstream.
* Migrate from a manual "-dbg" package to an automatic generated debug symbol
package:
+ debian/control: remove 7kaa-dbg and remove it from 7kaa Suggests.
+ debian/rules: use --dbgsym-migration in override_dh_strip.
* Use system libuiid:
+ Add a patch to replace every occurrence of guuid and misc.uuid.
+ Exclude src/common/misc_uuid.cpp,include/misc_uuid.h and COPYING.uuid in
debian/copyright.
+ Build-depends on uuid-dev.
+ Add dversionmangle to debian/watch.
* Update years and license text in debian/copyright.
* New upstream version 2.14.6.
* Remove debian/7kaa.menu, deprecated.
* Standards-version 3.9.8.
2015-07-29 - Bertrand Marc <beberking@gmail.com>
7kaa (2.14.5-1) unstable; urgency=medium
* Update debian/watch.
* New upstream release.
* debian/control: update build dependencies according to README.
+ use libsdl2-dev instead of libsdl1.2-dev.
+ use libenet-dev instead of libsdl-net1.2-dev.
* Refresh the only patch.
* Add a patch picked upstream to fix build with -Werror=format-security.
* Update debian/copyright.
* Standards-version 3.9.6: no changes needed.
* debian/rules: pass dpkg-buildflags to configure.
2013-06-16 - Barry deFreese <bdefreese@debian.org>
7kaa (2.14.4-1) unstable; urgency=low
* New upstream release.
* Add myself to uploaders.
* Remove quilt build-dep as package is format 3.0 (quilt).
* Add build-arch and build-indep targets in rules.
* Manually add relro to LDLFAGS in rules for now.
* Create data packages since data is in single tarball now.
* Fix watch file.
* Bump Standards Version to 3.9.4.
[ Markus Koschany ]
* Bump compat level to 9 and require debhelper >= 9.
* 7kaa.desktop: Add keywords.
* 7kaa.menu: Use an absolute icon path.
* debian/control:
- Remove dh-buildinfo from build-dep, not needed.
- Add dh-autoreconf to Build-Depends.
- Remove superfluous ${shlibs:Depends} substvar from 7kaa-dbg.
* debian/rules:
- Simplify debian/rules by using dh sequencer.
- Build with --parallel and --autoreconf.
- Use xz compression.
* Update debian/copyright top copyright format 1.0.

See Also

Package Description
9base_6-7+b1_i386.deb Plan 9 userland tools
9menu_1.9-2_i386.deb Creates X menus from the shell
9mount_1.3+hg20170412-1_i386.deb Plan 9 filesystem (v9fs) user mount utilities
9wm_1.4.1-1_i386.deb X11 window manager inspired by Plan 9's rio
a2jmidid_8~dfsg0-3_i386.deb Daemon for exposing legacy ALSA MIDI in JACK MIDI systems
a2ps_4.14-4_i386.deb GNU a2ps - 'Anything to PostScript' converter and pretty-printer
a56_1.3+dfsg-9_i386.deb Motorola DSP56001 assembler
a7xpg-data_0.11.dfsg1-10_all.deb chase action game - game data
a7xpg_0.11.dfsg1-10_i386.deb chase action game
aa3d_1.0-8+b2_i386.deb ASCII art stereogram generator
aajm_0.4-9+b2_i386.deb ASCII art version of jugglemaster
aaphoto_0.45-1_i386.deb Auto Adjust Photo, automatic color correction of photos
aapt_8.1.0+r23-3_i386.deb Android Asset Packaging Tool
abacas_1.3.1-5_all.deb close gaps in genomic alignments from short reads
abcde_2.9.3-1_all.deb A Better CD Encoder
Advertisement
Advertisement