yabasic_2.78.2-2_amd64.deb


Advertisement

Description

yabasic - Yet Another BASIC interpreter

Distribution: Debian Sid
Repository: Debian Main amd64
Package name: yabasic
Package version: 2.78.2
Package release: 2
Package architecture: amd64
Package type: deb
Installed size: 805 B
Download size: 225.19 KB
Official Mirror: ftp.br.debian.org
Description: unavailable.

Alternatives

    Download

    Source package: yabasic

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install yabasic deb package:
      # sudo apt-get install yabasic

    Changelog

    2017-09-20 - Graham Inggs <ginggs@debian.org> yabasic (1:2.78.2-2) unstable; urgency=medium * Run dh_autoreconf before dh_auto_configure in autopkgtest

    2017-09-13 - Graham Inggs <ginggs@debian.org> yabasic (1:2.78.2-1) unstable; urgency=medium * New upstream release - The ran()-function is now guaranteed to return 2**30 different values * Refresh flex_and_bison.patch * Enable autopkgtests

    2017-09-05 - Graham Inggs <ginggs@debian.org> yabasic (1:2.78.1-1) unstable; urgency=medium * New upstream release - No more dump when using color without window open - Processing of yabasic.xml finds hellip-entity * Bump Standards-Version to 4.1.0, no changes needed

    2017-01-23 - Graham Inggs <ginggs@debian.org> yabasic (1:2.78.0-1) unstable; urgency=medium * New upstream release - Allowed for numeric argument after break - Fixed format of manpage (unix) - Reworked the switch-statement, added tests * Drop patches included upstream and refresh remaining * Update debian/copyright

    2017-01-04 - Graham Inggs <ginggs@debian.org> yabasic (1:2.77.3-1) unstable; urgency=medium * New upstream release - Fixed insecure usage of strcpy (LP: #424602) - Better logging for windows installer - Spelling corrections * Drop patches included upstream and refresh remaining * Update debian/copyright, drop comment about old licensing * Fix strncpy() issue when regenerating flex parser

    2016-12-21 - Graham Inggs <ginggs@debian.org> yabasic (1:2.77.2-1) unstable; urgency=medium * New maintainer (Closes: #465659) * New upstream release * Switch to debhelper 10, source format 3.0 (quilt) * Update debian/watch * Update debian/control with Homepage and Vcs-* fields * Build with hardening flags and link with --as-needed * Regenerate flex and bison parsers * Machine-readable debian/copyright * Bump Standards-Version to 3.9.8, no further changes * Use SOURCE_DATE_EPOCH for reproducible timestamp * Clarify licensing

    2009-01-30 - Ralf Treinen <treinen@debian.org> yabasic (2.763-5) unstable; urgency=low * QA upload * Patch graphic.diff: fix a bug that made yabasic crash on executing "open window". Thanks to John Bazik for having sent in the patch. Closes: #496962. * Doc-base: change section to Programming/Basic * Add ${misc:Depends} to package Dependency * Standards-Version 3.8.0 (no change)

    2008-02-13 - Matej Vela <vela@debian.org> yabasic (2.763-4) unstable; urgency=low * Orphaning. * yabasic.1: Fix unintended macro invocations. * debian/menu: Menu transition (to Applications/Programming). * Conforms to Standards version 3.7.3.

    2006-08-13 - Matej Vela <vela@debian.org> yabasic (2.763-3) unstable; urgency=low * Switch to cdbs. * Conforms to Standards version 3.7.2.

    2006-03-19 - Matej Vela <vela@debian.org> yabasic (2.763-2) unstable; urgency=low * yabasic.1: Apply corrections from A Costa. Closes: #351017. * Switch to debhelper 5.

    Advertisement
    Advertisement