xfce4-appmenu-plugin_0.7.3+dfsg1-1+b1_amd64.deb


Advertisement

Description

xfce4-appmenu-plugin - Application Menu plugin for xfce4-panel

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package filename xfce4-appmenu-plugin_0.7.3+dfsg1-1+b1_amd64.deb
Package name xfce4-appmenu-plugin
Package version 0.7.3+dfsg1
Package release 1+b1
Package architecture amd64
Package type deb
Category uitoolkit::gtk xfce
Homepage https://gitlab.com/vala-panel-project/vala-panel-appmenu
License -
Maintainer Ayatana Packagers <pkg-ayatana-devel@lists.alioth.debian.org>
Download size 60.97 KB
Installed size 225.00 KB

Alternatives

Package Version Architecture Repository
xfce4-appmenu-plugin_0.7.3+dfsg1-1+b1_i386.deb 0.7.3+dfsg1 i386 Debian Main
xfce4-appmenu-plugin - - -

Requires

Name Value
appmenu-registrar >= 0.7.1
bamfdaemon -
libbamf3-2 >= 0.5.0
libc6 >= 2.7
libglib2.0-0 >= 2.47.1
libgtk-3-0 >= 3.22.0
libwnck-3-0 >= 3.4.8
libxfce4panel-2.0-4 >= 4.11.0
libxfconf-0-3 >= 4.6.0
vala-panel-appmenu-common = 0.7.3+dfsg1-1

Download

Type URL
Mirror ftp.br.debian.org
Binary Package xfce4-appmenu-plugin_0.7.3+dfsg1-1+b1_amd64.deb
Source Package vala-panel-appmenu

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install xfce4-appmenu-plugin deb package:
    # sudo apt-get install xfce4-appmenu-plugin

Files

Path
/usr/lib/x86_64-linux-gnu/xfce4/panel/plugins/libappmenu-xfce.so
/usr/share/doc/xfce4-appmenu-plugin/changelog.Debian.amd64.gz
/usr/share/doc/xfce4-appmenu-plugin/changelog.Debian.gz
/usr/share/doc/xfce4-appmenu-plugin/copyright
/usr/share/xfce4/panel/plugins/appmenu.desktop

Changelog

2019-08-07 - Mike Gabriel <sunweaver@debian.org>
vala-panel-appmenu (0.7.3+dfsg1-1) unstable; urgency=medium
* New upstream release.
* debian/{control,compat}:
+ Switch to debhelper-compat notation, bump to DH compat level version 12.
* debian/control:
+ Update B-Ds for this upstream release. Switch from cmake to meson.
+ Bump Standards-Version: to 4.4.0. No changes needed.
* debian/rules:
+ Switch to 'meson' as build-system.
* debian/patches:
+ Drop all patches, they were cmake related.
2018-09-03 - Mike Gabriel <sunweaver@debian.org>
vala-panel-appmenu (0.7.1+dfsg1-1) unstable; urgency=medium
* New upstream release. (Closes: #907708).
* debian/control (et al.):
+ Drop bin:pkg vala-panel-appmenu-registrar and use bin:pkg
appmenu-registrar instead.
* debian/control:
+ Update B-Ds; add cmake-vala, bump versioned B-D libvalapanel-dev
to (>= 0.4).
+ Bump Standards-Version: to 4.2.1. No changes needed.
* debian/patches:
+ Drop 2001_subprojects-not-shipped-with-the-source-tree.patch.
+ Add 2001_no-subprojects.patch: in Debian, we ship the subprojects as
separate src:pkgs.
+ Add 2002_no-FallbackVersion-update.patch: don't generate
FallbackVersion.cmake at build time.
* debian/rules:
+ Add dh_auto_clean override to get rid of some build cruft.
* debian/vala-panel-appmenu.install:
+ Plugins have been moved to DATADIR, add usr/share/vala-panel/*.
* debian/mate-applet-appmenu.install:
+ The org.mate.panel.applet.AppmenuAppletFactory.service file has been
dropped by upstream.
* debian/copyright:
+ Update copyright attributions.
+ Update auto-generated copyright.in file.
* debian/watch:
+ Adapt to new upstream release scheme.
2018-07-22 - Mike Gabriel <sunweaver@debian.org>
vala-panel-appmenu (0.6.94+repack1-2) unstable; urgency=medium
[ Martin Wimpress ]
* debian/patches:
+ 10_budgie_appmenu_applet.gschema.override. Do not blacklist glade or
anjuta, both now work.
+ 10_mate_applet_appmenu.gschema.override. Do not blacklist glade or anjuta,
both now work.
[ Mike Gabriel ]
* debian/control:
+ Update Vcs-*: fields. Packaging Git has been migrated to salsa.debian.org.
+ Fix MATE team's mail address in Uploaders: field.
* debian/{control,copyright,watch}: New upstream home (GitLab.com).
2018-03-29 - Mike Gabriel <sunweaver@debian.org>
vala-panel-appmenu (0.6.94+repack1-1) unstable; urgency=medium
[ Martin Wimpress ]
* New upstream release (0.6.93).
* debian/patches:
+ Drop 0001_fix_menu_bar_height.patch. Applied upstream.
+ Drop 0002_make_separator_transparent.patch. Applied upstream.
+ Drop 0010_send_opened_before_actual_load.patch. Applied upstream.
+ Drop 0011_check_and_ignore_firefox_stubs.patch. Applied upstream.
+ Drop 0012_use_opened_before_abouttoshow.patch. Applied upstream.
+ Drop 0020_handle_non_standard_border.patch. Applied upstream.
+ Rebased 2001_subprojects-not-shipped-with-the-source-tree.patch.
+ Add 0001_nullify_GVariants.patch. nullify GVariants to prevent Qt5
applications from crashing the XFCE panel.
* debian/rules:
+ Add -DENABLE_REGISTRAR=ON to ensure appmenu-registrar is built.
[ Mike Gabriel ]
* New upstream release (0.6.94).
* debian/patches:
+ Drop 0001_nullify_GVariants.patch. Applied upstream in 0.6.94.
* debian/copyright:
+ Update copyright attributions.
+ Update auto-generated copyright.in file.
+ Add Comment: field that explains why the orig tarball has been repacked.

See Also

Package Description
xfce4-battery-plugin_1.1.3-1_amd64.deb battery monitor plugin for the Xfce4 panel
xfce4-clipman-plugin_1.4.3-2_amd64.deb clipboard history plugin for Xfce panel
xfce4-clipman_1.4.3-2_amd64.deb clipboard history utility
xfce4-cpufreq-plugin_1.2.1-1_amd64.deb cpufreq information plugin for the Xfce4 panel
xfce4-cpugraph-plugin_1.1.0-1_amd64.deb CPU load graph plugin for the Xfce4 panel
xfce4-datetime-plugin_0.8.0-1_amd64.deb date and time plugin for the Xfce4 panel
xfce4-dev-tools_4.14.0-1_amd64.deb Script to help building Xfce from git
xfce4-dict_0.8.3-1_amd64.deb Dictionary plugin for Xfce4 panel
xfce4-diskperf-plugin_2.6.2-1_amd64.deb disk performance display plugin for the Xfce4 panel
xfce4-equake-plugin_1.3.8.1-2+b2_amd64.deb Xfce panel plugin which monitors earthquakes
xfce4-eyes-plugin_4.5.0-2_amd64.deb eyes that follow your mouse for the Xfce4 panel
xfce4-fsguard-plugin_1.1.1-1_amd64.deb filesystem monitor plugin for the Xfce4 panel
xfce4-genmon-plugin_4.0.2-1_amd64.deb Generic Monitor for the Xfce4 panel
xfce4-goodies_4.12.6_amd64.deb enhancements for the Xfce4 Desktop Environment
xfce4-indicator-plugin_2.3.4-2+b1_amd64.deb plugin to display information from applications in the Xfce4 panel
Advertisement
Advertisement