spyder_3.3.6+dfsg1-2_all.deb


Advertisement

Description

spyder - Python IDE for scientists (Python 2)

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package filename spyder_3.3.6+dfsg1-2_all.deb
Package name spyder
Package version 3.3.6+dfsg1
Package release 2
Package architecture all
Package type deb
Category devel devel::ide devel::lang:python implemented-in::python role::program
Homepage https://github.com/spyder-ide/spyder
License -
Maintainer Debian Science Maintainers <debian-science-maintainers@lists.alioth.debian.org>
Download size 127.49 KB
Installed size 215.00 KB

Alternatives

Package Version Architecture Repository
spyder_3.3.6+dfsg1-2_all.deb 3.3.6+dfsg1 all Debian Main
spyder_2.2.5+dfsg-1~nd+1_all.deb 2.2.5+dfsg all NeuroDebian Main
spyder_2.2.5+dfsg-1~nd+1_all.deb 2.2.5+dfsg all NeuroDebian Main
spyder - - -

Requires

Name Value
python-spyder = 3.3.6+dfsg1-2
python2.7:any -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package spyder_3.3.6+dfsg1-2_all.deb
Source Package spyder

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install spyder deb package:
    # sudo apt-get install spyder

Files

Path
/usr/bin/spyder
/usr/share/applications/spyder.desktop
/usr/share/bug/spyder/control
/usr/share/doc/spyder/README.md.gz
/usr/share/doc/spyder/changelog.Debian.gz
/usr/share/doc/spyder/changelog.gz
/usr/share/doc/spyder/copyright
/usr/share/icons/spyder.png
/usr/share/man/man1/spyder.1.gz

Changelog

2019-09-01 - Picca Frédéric-Emmanuel <picca@debian.org>
spyder (3.3.6+dfsg1-2) unstable; urgency=medium
* Fixed by upstream in a previous release (Closes: #932987)
* d/copyright: MIT -> Expat (the real variant used)
* d/control: removed pylint3 build depends.
* d/patches: Added 0004-Removed-pylint-dependency.patch
2019-07-21 - Drew Parsons <dparsons@debian.org>
spyder (3.3.6+dfsg1-1) unstable; urgency=medium
* Team upload.
* New upstream release. Closes: #932110.
2019-04-30 - Drew Parsons <dparsons@debian.org>
spyder (3.3.5+dfsg1-1) unstable; urgency=medium
* Team upload.
* New upstream release. Closes: #926635.
* Standards-Version: 4.4.0
* remove /usr/share/doc/spyder/html links (spyder-doc is no longer
provided). Closes: #924217.
* include README.md in /usr/share/doc/spyder3
2019-02-24 - Drew Parsons <dparsons@debian.org>
spyder (3.3.3+dfsg1-1) unstable; urgency=medium
* Team upload.
* New upstream release.
* update to Build-Depends: debhelper-compat (= 12),
remove debian/compat
* debian/copyright: clarify main licence as MIT
2019-01-15 - Drew Parsons <dparsons@debian.org>
spyder (3.3.2+dfsg1-2) unstable; urgency=medium
* Team upload.
* set debian/watch to upstream github repo rather than pypi
* python3-spyder Depends: python3-keyring (required for python3 but
not automatically detected by dh_python3).
Also Build-Depends: python3-keyring.
Closes: #919000.
* Standards-Version: 4.3.0
* debhelper compatibility level 12
2018-12-04 - Drew Parsons <dparsons@debian.org>
spyder (3.3.2+dfsg1-1) unstable; urgency=medium
* Team upload.
* New upstream version 3.3.2+dfsg1. Closes: #900246, #893615.
- update debian/copyright
- no longer provides doc subdir:
* drop spyder-doc. Closes: #911629.
* drop sphinx build support
* setup.py --no-doc no longer supported
* use rst2man to generate man page from debian/manpage.rst
(replaces debian/patches/Add-manpage-for-Spyder.patch )
* Build-Depends: python{,3}-spyder-kernels
* Standards-Version: 4.2.1
* debian/control: remove ancient-python-version-fields
X-Python-Version, X-Python3-Version
2018-03-04 - Ghislain Antony Vaillant <ghisvail@gmail.com>
spyder (3.2.6+dfsg1-2) unstable; urgency=medium
* New patch Remove-pyopengl-from-install-requires.patch (Closes: #891617)
* New patch Remove-pyqt5-from-install-requires.patch (Closes: #891618)
2018-02-21 - Ghislain Antony Vaillant <ghisvail@gmail.com>
spyder (3.2.6+dfsg1-1) unstable; urgency=medium
* New upstream version 3.2.6+dfsg1
* Refresh the patch queue
* Update the copyright years
* Add new dependency on cloudpickle
* Drop the get-orig-source target
* Move extend-diff-ignore to d/s/options
* Point the VCS URIs to salsa.debian.org
* Update the location of the documentation
* Remove all instances of priority extra
* Bump the debhelper version to 11
* Bump the standards version to 4.1.3
2017-10-31 - Ghislain Antony Vaillant <ghisvail@gmail.com>
spyder (3.2.4+dfsg1-1) unstable; urgency=medium
* New upstream version 3.2.4+dfsg1
* Refresh the patch queue
* Fix and simplify the watch file
- Fix the dversionmangle regex
- Use the PACKAGE placeholder
2017-10-12 - Ghislain Antony Vaillant <ghisvail@gmail.com>
spyder (3.2.3+dfsg1-2) unstable; urgency=medium
* Restore patch Always-use-setuptools.patch (Closes: #878056)
* Ensure install of setuptools gui_scripts
* Bump the standards version to 4.1.1

See Also

Package Description
sqitch_0.9999-2_all.deb sane database change management
sql-ledger_3.2.6-1_all.deb Web based double-entry accounting program
sqlacodegen_1.1.6-2_all.deb Automatic model code generator for SQLAlchemy
sqlcipher_3.4.1-1+b13_amd64.deb Command line interface for SQLCipher
sqlformat_0.2.4-1_all.deb SQL formatting utility
sqlgrey_1.8.0-1_all.deb Postfix Greylisting Policy Server
sqlite-doc_2.8.17-15_all.deb SQLite 2 documentation
sqlite3-doc_3.30.1-1_all.deb SQLite 3 documentation
sqlite3-pcre_0~git20070120091816+4229ecc-1+b1_amd64.deb Perl-compatible regular expression support for SQLite
sqlite3_3.30.1-1_amd64.deb Command line interface for SQLite 3
sqlite_2.8.17-15+b1_amd64.deb command line interface for SQLite 2
sqlitebrowser_3.11.2-1_amd64.deb GUI editor for SQLite databases
sqlline_1.0.2-8_all.deb JDBC command-line utility for issuing SQL
sqlmap_1.3.10-1_all.deb automatic SQL injection tool
sqlobject-admin_3.7.0+dfsg-2_all.deb Helper applications for SQLObject, a Python ORM for databases
Advertisement
Advertisement