rubygems-integration_1.12_all.deb


Advertisement

Description

rubygems-integration - integration of Debian Ruby packages with Rubygems

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package filename rubygems-integration_1.12_all.deb
Package name rubygems-integration
Package version 1.12
Package release -
Package architecture all
Package type deb
Category ruby
Homepage -
License -
Maintainer Debian Ruby Extras Maintainers <pkg-ruby-extras-maintainers@lists.alioth.debian.org>
Download size 5.04 KB
Installed size 20.00 KB

Alternatives

Package Version Architecture Repository
rubygems-integration_1.12_all.deb 1.12 all Debian Main
rubygems-integration - - -

Requires

Name Value
ca-certificates -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package rubygems-integration_1.12_all.deb
Source Package rubygems-integration

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install rubygems-integration deb package:
    # sudo apt-get install rubygems-integration

Files

Path
/usr/lib/ruby/vendor_ruby/rubygems/defaults/operating_system.rb
/usr/share/doc/rubygems-integration/README.markdown
/usr/share/doc/rubygems-integration/changelog.gz
/usr/share/doc/rubygems-integration/copyright

Changelog

2019-08-26 - Antonio Terceiro <terceiro@debian.org>
rubygems-integration (1.12) unstable; urgency=medium
[ Utkarsh Gupta ]
* Add salsa-ci.yml
[ Antonio Terceiro ]
* debian/tests/control: run wrap-and-sort
* debian/control: packaging updates
* Bump debhelper compatibility level to 12
* Bump Standards-Version to 4.4.0
* Point Vcs-* to salsa.debian.org
* add Rules-Requires-Root: no
* Drop support for ruby 2.1 and 2.2
* Downgrade priority of architecture-specific gems
* Drop debian/compat (replaced with Depends: debhelper-compat)
2016-12-18 - Christian Hofstaedtler <zeha@debian.org>
rubygems-integration (1.11) unstable; urgency=medium
[ C├ędric Boutillier ]
* Use https:// in Vcs-* fields
* Run wrap-and-sort on packaging files
[ Christian Hofstaedtler ]
* Bump Standards-Version to 3.9.8 (no changes needed)
* Bump debhelper compat level to 10
2015-12-19 - Christian Hofstaedtler <zeha@debian.org>
rubygems-integration (1.10) unstable; urgency=medium
* Fix overlay incompatibility starting with Ruby 2.1.
Thanks to Gustavo Machado Campagnani Gama <nsn.igenesis@gmail.com>
(Closes: #783972)
* Stop installing compatibility symlink for ruby2.0
2015-06-17 - Antonio Terceiro <terceiro@debian.org>
rubygems-integration (1.9) unstable; urgency=medium
* Include /usr/lib/$(triplet)/rubygems-integration/$(api_version) in the
Rubygems path. This might be used in the future to make Ruby packages
support multiarch.
* debian/tests/control: run specs against installed package.
* Add workaround for Ruby 2.2 because gem2deb < 0.18.2 installed
gemspecs to directories named after the short Ruby version (2.2) instead
of the API_VERSION (2.2.0). There was already a similar workaround for
Ruby 2.1, so this should have been fixed a long time ago.
2014-09-05 - Christian Hofstaedtler <zeha@debian.org>
rubygems-integration (1.8) unstable; urgency=medium
[ Antonio Terceiro ]
* Improve smoke tests in debian/tests/package-list.
.
Test a gem that comes together with the interpreter, one arch:all and one
arch:any
[ Christian Hofstaedtler ]
* Add myself to Uploaders
* Advise rubygems to load SSL certificates from the ca-certificates
provided list. (Closes: #689074)
2014-04-30 - Antonio Terceiro <terceiro@debian.org>
rubygems-integration (1.7) unstable; urgency=medium
* Drop dependency on Ruby, since the interpreters now actually depend on
this package.
* Add workaround for loading ruby2.1-specific gemspecs from wrong path used
by gem2deb (Closes: #746470)
.
The definitive fix belongs in gem2deb and is making it install the
gemspecs to the correct place so that rubygems-integration does not have
to be changed again when the next version comes.
2014-04-10 - Antonio Terceiro <terceiro@debian.org>
rubygems-integration (1.6) unstable; urgency=medium
* debian/tests/package-list: make output easier to read. First output the
list of gems to a file, then grep that file.
* Drop rdoc workaround for Ruby 1.9
* Add support for disabling rubygems-integration by setting an environment
variable DEBIAN_DISABLE_RUBYGEMS_INTEGRATION.
2014-02-10 - Antonio Terceiro <terceiro@debian.org>
rubygems-integration (1.5) unstable; urgency=medium
* Add /usr/share/rubygems-integration/all to the gem path.
This will allow installing a single gemspec for `Architecture: all`
packages that will work with every interpreter, and won't require a new
upload when a new interpreter comes along.
2014-01-16 - Antonio Terceiro <terceiro@debian.org>
rubygems-integration (1.4) unstable; urgency=medium
[ Christian Hofstaedtler ]
* Support Ruby 2.0+ "default gems" directory
[ Antonio Terceiro ]
* Mark as Multi-Arch: foreign
* Workaround problem with install path of ruby2.0
* add autopkgtests

See Also

Package Description
rumor_1.0.5-2.1+b1_amd64.deb Realtime MIDI keyboard to Lilypond converter
rumur_2019.02.04-1_amd64.deb model checker for the Murphi language
runawk_1.6.0-2+b1_amd64.deb wrapper for AWK interpreter implementing modules
runc_1.0.0~rc9+dfsg1-1_amd64.deb Open Container Project - runtime
runcircos-gui_0.0+git20180828.97703b9-1_amd64.deb GUI tool to run circos
rungetty_1.2-16+b1_amd64.deb minimal console getty that can run any process
runit-helper_2.8.14_all.deb dh-runit implementation detail
runit-init_2.1.2-35_all.deb system-wide service supervision (as init system)
runit-systemd_2.1.2-35_all.deb system-wide service supervision (systemd integration)
runit-sysv_2.1.2-35_all.deb system-wide service supervision (sysv integration)
runit_2.1.2-35_amd64.deb system-wide service supervision
runlim_1.10-5_amd64.deb tool for sampling time and memory usage
runoverssh_3.0-1_all.deb Run commands over ssh in one or more hosts
runsnakerun_2.0.4-2_all.deb GUI utility for (Python) cProfile or Profile profiler dumps
rurple-ng_0.5+16-2_all.deb learn programming in Python with a robot
Advertisement
Advertisement