ruby-puppet-forge_2.2.9-2_all.deb


Advertisement

Description

ruby-puppet-forge - Access the Puppet Forge API from Ruby

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package name ruby-puppet-forge
Package version 2.2.9
Package release 2
Package architecture all
Package type deb
Installed size 88 B
Download size 20.99 KB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
ruby-puppet-forge_2.2.9-2_all.deb 2.2.9 all Debian Main
ruby-puppet-forge - - -

Requires

Name Value
ruby -
ruby-faraday >= 0.9.0
ruby-faraday-middleware >= 0.9.0
ruby-gettext-setup -
ruby-interpreter -
ruby-minitar -
ruby-semantic-puppet >= 0.1.0

Download

Type URL
Binary Package ruby-puppet-forge_2.2.9-2_all.deb
Source Package ruby-puppet-forge

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-puppet-forge deb package:
    # sudo apt-get install ruby-puppet-forge

Files

Path
/usr/lib/ruby/vendor_ruby/puppet_forge.rb
/usr/lib/ruby/vendor_ruby/puppet_forge/connection.rb
/usr/lib/ruby/vendor_ruby/puppet_forge/error.rb
/usr/lib/ruby/vendor_ruby/puppet_forge/lazy_accessors.rb
/usr/lib/ruby/vendor_ruby/puppet_forge/lazy_relations.rb
/usr/lib/ruby/vendor_ruby/puppet_forge/tar.rb
/usr/lib/ruby/vendor_ruby/puppet_forge/unpacker.rb
/usr/lib/ruby/vendor_ruby/puppet_forge/util.rb
/usr/lib/ruby/vendor_ruby/puppet_forge/v3.rb
/usr/lib/ruby/vendor_ruby/puppet_forge/version.rb
/usr/lib/ruby/vendor_ruby/puppet_forge/connection/connection_failure.rb
/usr/lib/ruby/vendor_ruby/puppet_forge/locales/config.yaml
/usr/lib/ruby/vendor_ruby/puppet_forge/middleware/symbolify_json.rb
/usr/lib/ruby/vendor_ruby/puppet_forge/tar/mini.rb
/usr/lib/ruby/vendor_ruby/puppet_forge/v3/base.rb
/usr/lib/ruby/vendor_ruby/puppet_forge/v3/metadata.rb
/usr/lib/ruby/vendor_ruby/puppet_forge/v3/module.rb
/usr/lib/ruby/vendor_ruby/puppet_forge/v3/release.rb
/usr/lib/ruby/vendor_ruby/puppet_forge/v3/user.rb
/usr/lib/ruby/vendor_ruby/puppet_forge/v3/base/paginated_collection.rb
/usr/share/doc/ruby-puppet-forge/README.md.gz
/usr/share/doc/ruby-puppet-forge/changelog.Debian.gz
/usr/share/doc/ruby-puppet-forge/changelog.gz
/usr/share/doc/ruby-puppet-forge/copyright
/usr/share/rubygems-integration/all/specifications/puppet_forge-2.2.9.gemspec

Changelog

2018-03-13 - Sebastien Badia <sbadia@debian.org>
ruby-puppet-forge (2.2.9-2) unstable; urgency=medium
* d/upstream: Added Upstream metadata
* d/compat: Bump compat version to 11
* d/control:
+ Bump to Standards-Version 4.1.3 (no changes needed)
+ Use salsa.debian.org in Vcs-* fields
* d/copyright: Update copyritght years and use HTTPS for URI
2017-12-14 - Sebastien Badia <sbadia@debian.org>
ruby-puppet-forge (2.2.9-1) unstable; urgency=medium
* New upstream version 2.2.9
* d/control: Bump to Standards-Version 4.1.2 (no changes needed)
* d/patches: Refresh 002_loosen_deps.patch (partially applied upstream)
* d/watch: Use a secure URI for watchfile
2017-08-19 - Sebastien Badia <sbadia@debian.org>
ruby-puppet-forge (2.2.7-2) unstable; urgency=medium
* d/patches: Refresh loosen_deps patch, relax faraday (Closes: #869908)
2017-07-13 - Sebastien Badia <sbadia@debian.org>
ruby-puppet-forge (2.2.7-1) unstable; urgency=medium
* New upstream version 2.2.7
* d/patches: Refresh patches according new upstream
* d/control: Bump Standard-Version to 4.0.0 (no changes needed)
2017-06-09 - Sebastien Badia <sbadia@debian.org>
ruby-puppet-forge (2.2.4-1) unstable; urgency=medium
* New upstream version 2.2.4
* d/control:
+ Bump debhelper compat. to 10
+ Use my Debian email
* d/patches:
+ Refresh patchs
+ Build puppet-forge with the new semantic and gettext-setup gems
(Closes: #864566)
2016-07-28 - Markus Frosch <lazyfrosch@debian.org>
ruby-puppet-forge (2.2.2-2) unstable; urgency=high
* [d7b1876] Fix locale loading for vendor_ruby installation (Closes: #832118)
2016-07-18 - Sebastien Badia <seb@sebian.fr>
ruby-puppet-forge (2.2.2-1) unstable; urgency=medium
[ Sebastien Badia ]
* Imported Upstream version 2.2.2
* d/control: Bump Standards version to 3.9.8 (no changes)
* d/control: Added ruby-gettext-setup (new build/run dependency)
[ Markus Frosch ]
2016-04-19 - Markus Frosch <lazyfrosch@debian.org>
ruby-puppet-forge (2.1.5-1) unstable; urgency=medium
[ Sebastien Badia ]
* [8e13d1c] d/control: Bump Standards-Version to 3.9.7 (no changes)
[ Markus Frosch ]
* [c8ec513] Imported Upstream version 2.1.5
2016-02-07 - Markus Frosch <lazyfrosch@debian.org>
ruby-puppet-forge (2.1.3-1) unstable; urgency=medium
* [41f65eb] Imported Upstream version 2.1.3
* [cbdd0b5] Update VCS URL
* [e6258dc] Cleanup depends
2016-01-15 - Markus Frosch <lazyfrosch@debian.org>
ruby-puppet-forge (2.1.2-1) unstable; urgency=medium
* [698d738] Imported Upstream version 2.1.2
* [7513a27] Remove patch allow_newer_faraday

See Also

Package Description
ruby-puppet-syntax_2.4.1-2_all.deb Syntax checks for Puppet manifests, templates, and Hiera YAML
ruby-puppetlabs-spec-helper_2.6.2-1_all.deb rake tasks and spec helper for spec tests on puppet modules
ruby-pygments.rb_1.2.0-2_all.deb pygments wrapper for Ruby
ruby-qdbm_1.8.78-9+b1_amd64.deb QDBM Database Libraries for Ruby
ruby-rabl-rails_0.4.1-1_all.deb fast Rails 3+ templating system with JSON and XML support
ruby-rabl_0.13.1-1_all.deb Ruby templating library with JSON, BSON, XML and MessagePack support
ruby-rack-accept_0.4.5-3_all.deb suite of tools for interpreting HTTP Accept family for Ruby/Rack
ruby-rack-attack_4.4.1-1_all.deb Block & throttle abusive requests
ruby-rack-cache_1.2-4_all.deb HTTP Caching for Rack
ruby-rack-contrib_1.3.0-3_all.deb contributed Rack Middleware and Utilities
ruby-rack-cors_1.0.2-1_all.deb enable Cross-Origin Resource Sharing in Rack apps
ruby-rack-flash3_1.0.5-2_all.deb Flash hash for Ruby Rack applications
ruby-rack-google-analytics_1.2.0-2_all.deb Simple Rack middleware to inject the Google Analytics tracking code
ruby-rack-mobile-detect_0.4.0-4_all.deb rack middleware for ruby webapps to detect mobile devices
ruby-rack-mount_0.8.3-3_all.deb Stackable dynamic tree based Rack router
Advertisement
Advertisement