ruby-psych_3.0.3~pre1-2_amd64.deb


Advertisement

Description

ruby-psych - libyaml wrapper for Ruby

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package name ruby-psych
Package version 3.0.3~pre1
Package release 2
Package architecture amd64
Package type deb
Installed size 191 B
Download size 42.91 KB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
ruby-psych_3.0.3~pre1-2_i386.deb 3.0.3~pre1 i386 Debian Main
ruby-psych - - -

Requires

Name Value
libc6 >= 2.14
libgmp10 -
libruby2.5 >= 2.5.0~preview1
libyaml-0-2 -
ruby << 1:2.6~
ruby >= 1:2.5~0

Download

Type URL
Binary Package ruby-psych_3.0.3~pre1-2_amd64.deb
Source Package ruby-psych

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-psych deb package:
    # sudo apt-get install ruby-psych

Files

Path
/usr/lib/ruby/vendor_ruby/psych.jar
/usr/lib/ruby/vendor_ruby/psych.rb
/usr/lib/ruby/vendor_ruby/psych_jars.rb
/usr/lib/ruby/vendor_ruby/psych/class_loader.rb
/usr/lib/ruby/vendor_ruby/psych/coder.rb
/usr/lib/ruby/vendor_ruby/psych/core_ext.rb
/usr/lib/ruby/vendor_ruby/psych/exception.rb
/usr/lib/ruby/vendor_ruby/psych/handler.rb
/usr/lib/ruby/vendor_ruby/psych/nodes.rb
/usr/lib/ruby/vendor_ruby/psych/omap.rb
/usr/lib/ruby/vendor_ruby/psych/parser.rb
/usr/lib/ruby/vendor_ruby/psych/scalar_scanner.rb
/usr/lib/ruby/vendor_ruby/psych/set.rb
/usr/lib/ruby/vendor_ruby/psych/stream.rb
/usr/lib/ruby/vendor_ruby/psych/streaming.rb
/usr/lib/ruby/vendor_ruby/psych/syntax_error.rb
/usr/lib/ruby/vendor_ruby/psych/tree_builder.rb
/usr/lib/ruby/vendor_ruby/psych/versions.rb
/usr/lib/ruby/vendor_ruby/psych/visitors.rb
/usr/lib/ruby/vendor_ruby/psych/y.rb
/usr/lib/ruby/vendor_ruby/psych/handlers/document_stream.rb
/usr/lib/ruby/vendor_ruby/psych/handlers/recorder.rb
/usr/lib/ruby/vendor_ruby/psych/json/ruby_events.rb
/usr/lib/ruby/vendor_ruby/psych/json/stream.rb
/usr/lib/ruby/vendor_ruby/psych/json/tree_builder.rb
/usr/lib/ruby/vendor_ruby/psych/json/yaml_events.rb
/usr/lib/ruby/vendor_ruby/psych/nodes/alias.rb
/usr/lib/ruby/vendor_ruby/psych/nodes/document.rb
/usr/lib/ruby/vendor_ruby/psych/nodes/mapping.rb
/usr/lib/ruby/vendor_ruby/psych/nodes/node.rb
/usr/lib/ruby/vendor_ruby/psych/nodes/scalar.rb
/usr/lib/ruby/vendor_ruby/psych/nodes/sequence.rb
/usr/lib/ruby/vendor_ruby/psych/nodes/stream.rb
/usr/lib/ruby/vendor_ruby/psych/visitors/depth_first.rb
/usr/lib/ruby/vendor_ruby/psych/visitors/emitter.rb
/usr/lib/ruby/vendor_ruby/psych/visitors/json_tree.rb
/usr/lib/ruby/vendor_ruby/psych/visitors/to_ruby.rb
/usr/lib/ruby/vendor_ruby/psych/visitors/visitor.rb
/usr/lib/ruby/vendor_ruby/psych/visitors/yaml_tree.rb
/usr/lib/x86_64-linux-gnu/ruby/vendor_ruby/2.5.0/psych.so
/usr/share/doc/ruby-psych/README.md
/usr/share/doc/ruby-psych/changelog.Debian.gz
/usr/share/doc/ruby-psych/changelog.gz
/usr/share/doc/ruby-psych/copyright
/usr/share/rubygems-integration/2.5.0/specifications/psych-3.0.3.pre1.gemspec

Changelog

2018-06-06 - Miguel Landaeta <nomadium@debian.org>
ruby-psych (3.0.3~pre1-2) unstable; urgency=medium
* No changes rebuild.
Since ruby-psych was totally broken in sid, a source-only upload was
not enough to fix the bugs because ruby-psych B-D on itself indirectly
through jruby.
Since 3.0.3~pre1-1 binary upload fixed the issues, I'm doing a
source-only upload with no changes because I consider a best practice
to build all binary packages from buildd.d.o.
2018-06-05 - Miguel Landaeta <nomadium@debian.org>
ruby-psych (3.0.3~pre1-1) unstable; urgency=medium
* New upstream release. (Closes: #892508, #900516).
* Refresh patches.
* Bump DH compat level to 11.
* Add versioned B-D on libyaml-snake-java (>= 1.21~).
* Bump Standards-Version to 4.1.4. No changes were required.
* Migrate Vcs-* URLs to salsa.d.o.
* Update copyright info.
* Update d/watch.
2017-09-17 - Miguel Landaeta <nomadium@debian.org>
ruby-psych (2.2.4-6) unstable; urgency=medium
* Update libpsych-java dependency on jruby to a Suggests since it's more
correct than a strong dependency.
2017-09-15 - Miguel Landaeta <nomadium@debian.org>
ruby-psych (2.2.4-5) unstable; urgency=medium
* Separate arch specific build steps from arch-indep ones.
* Add classpath for libpsych-java package.
2017-09-09 - Miguel Landaeta <nomadium@debian.org>
ruby-psych (2.2.4-4) unstable; urgency=medium
* Introduce libpsych-java binary package.
2017-07-29 - Miguel Landaeta <nomadium@debian.org>
ruby-psych (2.2.4-3) unstable; urgency=medium
* Fix FTBFS introduced by the dependency loop caused by the dependency on
jruby (psych is a default stdlib gem).
* Bump Standards-Version to 4.0.0. No changes were required.
2017-07-21 - Miguel Landaeta <nomadium@debian.org>
ruby-psych (2.2.4-2) unstable; urgency=medium
* Upload to unstable.
2017-03-17 - Miguel Landaeta <nomadium@debian.org>
ruby-psych (2.2.4-1) experimental; urgency=medium
* Initial release. (Closes: #809469)

See Also

Package Description
ruby-public-suffix_3.0.3+ds-1_all.deb Domain name parser based on the Public Suffix List
ruby-pundit_2.0.0-1_all.deb object oriented authorization for rails
ruby-puppet-forge_2.2.9-2_all.deb Access the Puppet Forge API from Ruby
ruby-puppet-syntax_2.4.1-2_all.deb Syntax checks for Puppet manifests, templates, and Hiera YAML
ruby-puppetlabs-spec-helper_2.6.2-1_all.deb rake tasks and spec helper for spec tests on puppet modules
ruby-pygments.rb_1.2.0-2_all.deb pygments wrapper for Ruby
ruby-qdbm_1.8.78-9+b1_amd64.deb QDBM Database Libraries for Ruby
ruby-rabl-rails_0.4.1-1_all.deb fast Rails 3+ templating system with JSON and XML support
ruby-rabl_0.13.1-1_all.deb Ruby templating library with JSON, BSON, XML and MessagePack support
ruby-rack-accept_0.4.5-3_all.deb suite of tools for interpreting HTTP Accept family for Ruby/Rack
ruby-rack-attack_4.4.1-1_all.deb Block & throttle abusive requests
ruby-rack-cache_1.2-4_all.deb HTTP Caching for Rack
ruby-rack-contrib_1.3.0-3_all.deb contributed Rack Middleware and Utilities
ruby-rack-cors_1.0.2-1_all.deb enable Cross-Origin Resource Sharing in Rack apps
ruby-rack-flash3_1.0.5-2_all.deb Flash hash for Ruby Rack applications
Advertisement
Advertisement