ruby-oily-png_1.2.1~dfsg-1+b2_amd64.deb


Advertisement

Description

ruby-oily-png - native mixin to speed up ChunkyPNG

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package name ruby-oily-png
Package version 1.2.1~dfsg
Package release 1+b2
Package architecture amd64
Package type deb
Installed size 81 B
Download size 22.88 KB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
ruby-oily-png_1.2.1~dfsg-1+b2_i386.deb 1.2.1~dfsg i386 Debian Main
ruby-oily-png - - -

Requires

Name Value
libc6 >= 2.14
libgmp10 -
libruby2.5 >= 2.5.0~preview1
ruby << 1:2.6~
ruby >= 1:2.5~0
ruby-chunky-png >= 1.2.7

Download

Type URL
Binary Package ruby-oily-png_1.2.1~dfsg-1+b2_amd64.deb
Source Package ruby-oily-png

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-oily-png deb package:
    # sudo apt-get install ruby-oily-png

Files

Path
/usr/lib/ruby/vendor_ruby/oily_png.rb
/usr/lib/ruby/vendor_ruby/oily_png/canvas.rb
/usr/lib/ruby/vendor_ruby/oily_png/version.rb
/usr/lib/x86_64-linux-gnu/ruby/vendor_ruby/2.5.0/oily_png/oily_png.so
/usr/share/doc/ruby-oily-png/README.rdoc
/usr/share/doc/ruby-oily-png/buildinfo_amd64.gz
/usr/share/doc/ruby-oily-png/changelog.Debian.amd64.gz
/usr/share/doc/ruby-oily-png/changelog.Debian.gz
/usr/share/doc/ruby-oily-png/copyright
/usr/share/rubygems-integration/2.5.0/specifications/oily_png-1.2.1.gemspec

Changelog

2016-12-14 - Jonas Smedegaard <dr@jones.dk>
ruby-oily-png (1.2.1~dfsg-1) unstable; urgency=medium
* Update copyright info:
+ Extend coverage of main author.
+ Use License-Grant and License-Reference fields.
Thanks to Ben Finney.
+ Extend coverage for Debian packaging.
+ Fix repackage upstream tarball, excluding images with non-free
ICC profile.
* Update watch file:
+ Bump to file format 4.
+ Add usage comment.
+ Handle ~dfsg suffix.
* Modernize git-buildpackage config:
+ Avoid git- prefix.
+ Filter any .git* file.
* Add lintian overrides regarding license in License-Reference field.
See bug#786450.
* Declare compliance with Debian Policy 3.9.8.
* Bump debhelper compatibility level to 9.
* Modernize Vcs-Git field to use https URL.
* Modernize Vcs-Browser field to use https cgit URL.
* Modernize CDBS use:
+ Extract metadata from (not skip) png file for copyright check.
+ Tighten build-dependency on cdbs.
+ Build-depend on libregexp-assemble-perl libimage-exiftool-perl
libfont-ttf-perl.
+ Build-depend on licensecheck (not devscripts).
+ Drop get-orig-source target: Use gbp import-orig --uscan instead.
2014-05-01 - Jonas Smedegaard <dr@jones.dk>
ruby-oily-png (1.1.0-5) unstable; urgency=medium
* Update Maintainer, Uploaders and Vcs-* fields: Packaging git moved
to pkg-sass area of Alioth.
* Extend coverage for myself.
2014-04-24 - Jonas Smedegaard <dr@jones.dk>
ruby-oily-png (1.1.0-4) unstable; urgency=medium
* Fix depend on either (not all) supported Ruby: call
dh_ruby_fixdepends.
* Bump standards-version to 3.9.5.
2013-05-06 - Jonas Smedegaard <dr@jones.dk>
ruby-oily-png (1.1.0-3) unstable; urgency=low
* Add README.source emphasizing control.in file as *not* a
show-stopper for contributions, referring to wiki page for details.
* Stop track md5sum of upstream tarball.
* Use github as direct source (not via
pkg-ruby-extras.alioth.debian.org redirector).
* Bump packaging license to GPL-3+, and extend coverage to include
current year.
* Use anonscm.debian.org URL for Vcs-Git.
2013-02-17 - Jonas Smedegaard <dr@jones.dk>
ruby-oily-png (1.1.0-2) experimental; urgency=low
* Fix cover PngSuite files in copyright file.
2013-02-17 - Jonas Smedegaard <dr@jones.dk>
ruby-oily-png (1.1.0-1) experimental; urgency=low
[ upstream ]
* New release.
[ Jonas Smedegaard ]
* Update package relations:
+ Relax to build-depend unversioned on cdbs and gem2deb: Needed
versions satisfied in stable, and oldstable no longer supported.
+ Tighten dependency on ruby-chunky-png: Needed since 1.1.0.
* Have git-import-orig suppress .gitignore files.
* Fix execute build targets once, by using single-colon stamp targets.
* Bump dephelper compatibility level to 8.
* Update copyright file:
+ Fix use pseudo-license and pseudo-comment sections to obey silly
restrictions of copyright format 1.0.
* Bump standards-version to 3.9.4.
* Skip copyright-checking PNGs, and stop have dpkg-source treat
copyright_hints file as binary.
2012-06-26 - Jonas Smedegaard <dr@jones.dk>
ruby-oily-png (1.0.2-2) unstable; urgency=low
* Extend copyright coverage of packaging.
* Bump standards-version to 3.9.3.
* Bump copyright file format to 1.0.
2011-11-30 - Jonas Smedegaard <dr@jones.dk>
ruby-oily-png (1.0.2-1) unstable; urgency=low
* New upstream release.
* Drop dpkg local-options hints from packaging source: now defaults.
* Update package relations:
+ Tighten dependency on ruby-chunky-png.
+ Relax build-dependency on cdbs (needlessly tight).
+ Relax build-depend unversioned on debhelper and devscripts (needed
versions satisfied even in oldstable).
2011-07-04 - Jonas Smedegaard <dr@jones.dk>
ruby-oily-png (1.0.1-1) unstable; urgency=low
* Initial release.
Closes: bug#632612.

See Also

Package Description
ruby-oj_3.6.6-1_amd64.deb fast JSON parser and serializer for Ruby
ruby-ole_1.2.11.8-1_all.deb Ruby library for read/write access for OLE compound documents
ruby-omniauth-auth0_2.0.0-1_all.deb Omniauth OAuth2 strategy for the Auth0 platform
ruby-omniauth-authentiq_0.3.3-1_all.deb Authentiq strategy for OmniAuth
ruby-omniauth-azure-oauth2_0.0.9-2_all.deb Windows Azure Active Directory OAuth2 strategy for OmniAuth
ruby-omniauth-bitbucket_0.0.2-1_all.deb Oauth2 bitbucket strategy for OmniAuth
ruby-omniauth-cas3_1.1.4-2_all.deb CAS 3.0 Strategy for OmniAuth
ruby-omniauth-crowd_2.4.0-1_all.deb OmniAuth provider for Atlassian Crowd REST API
ruby-omniauth-facebook_4.0.0-2_all.deb Oauth2 facebook strategy for OmniAuth
ruby-omniauth-github_1.3.0-1_all.deb GitHub strategy for the Ruby OmniAuth library
ruby-omniauth-gitlab_1.0.2-1_all.deb OAuth2 strategy for authenticating to GitLab service
ruby-omniauth-google-oauth2_0.5.3-1_all.deb Google OAuth2 strategy for OmniAuth 1.x
ruby-omniauth-jwt_0.0.2-1_all.deb JSON Web Token (JWT) is a simple way to send verified information
ruby-omniauth-kerberos_0.3.0-3_all.deb OmniAuth strategy for Kerberos
ruby-omniauth-ldap_2.0.4-2_all.deb LDAP strategy for Ruby OmniAuth library
Advertisement
Advertisement