ruby-nokogiri_1.10.4+dfsg1-1_amd64.deb


Advertisement

Description

ruby-nokogiri - HTML, XML, SAX, and Reader parser for Ruby

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package filename ruby-nokogiri_1.10.4+dfsg1-1_amd64.deb
Package name ruby-nokogiri
Package version 1.10.4+dfsg1
Package release 1
Package architecture amd64
Package type deb
Category ruby
Homepage http://nokogiri.org
License -
Maintainer Debian Ruby Extras Maintainers <pkg-ruby-extras-maintainers@lists.alioth.debian.org>
Download size 111.50 KB
Installed size 436.00 KB

Alternatives

Package Version Architecture Repository
ruby-nokogiri_1.10.4+dfsg1-1_i386.deb 1.10.4+dfsg1 i386 Debian Main
ruby-nokogiri - - -

Requires

Name Value
libc6 >= 2.14
libruby2.5 >= 2.5.0~preview1
libxml2 >= 2.7.4
libxslt1.1 >= 1.1.25
ruby >= 1:2.5~0
ruby << 1:2.6~
ruby-pkg-config >= 1.1.7

Download

Type URL
Mirror ftp.br.debian.org
Binary Package ruby-nokogiri_1.10.4+dfsg1-1_amd64.deb
Source Package ruby-nokogiri

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-nokogiri deb package:
    # sudo apt-get install ruby-nokogiri

Files

Path
/usr/bin/nokogiri
/usr/lib/ruby/vendor_ruby/nokogiri.rb
/usr/lib/ruby/vendor_ruby/nokogiri/css.rb
/usr/lib/ruby/vendor_ruby/nokogiri/html.rb
/usr/lib/ruby/vendor_ruby/nokogiri/syntax_error.rb
/usr/lib/ruby/vendor_ruby/nokogiri/version.rb
/usr/lib/ruby/vendor_ruby/nokogiri/xml.rb
/usr/lib/ruby/vendor_ruby/nokogiri/xslt.rb
/usr/lib/ruby/vendor_ruby/nokogiri/css/node.rb
/usr/lib/ruby/vendor_ruby/nokogiri/css/parser.rb
/usr/lib/ruby/vendor_ruby/nokogiri/css/parser.y
/usr/lib/ruby/vendor_ruby/nokogiri/css/parser_extras.rb
/usr/lib/ruby/vendor_ruby/nokogiri/css/syntax_error.rb
/usr/lib/ruby/vendor_ruby/nokogiri/css/tokenizer.rb
/usr/lib/ruby/vendor_ruby/nokogiri/css/tokenizer.rex
/usr/lib/ruby/vendor_ruby/nokogiri/css/xpath_visitor.rb
/usr/lib/ruby/vendor_ruby/nokogiri/decorators/slop.rb
/usr/lib/ruby/vendor_ruby/nokogiri/html/builder.rb
/usr/lib/ruby/vendor_ruby/nokogiri/html/document.rb
/usr/lib/ruby/vendor_ruby/nokogiri/html/document_fragment.rb
/usr/lib/ruby/vendor_ruby/nokogiri/html/element_description.rb
/usr/lib/ruby/vendor_ruby/nokogiri/html/element_description_defaults.rb
/usr/lib/ruby/vendor_ruby/nokogiri/html/entity_lookup.rb
/usr/lib/ruby/vendor_ruby/nokogiri/html/sax/parser.rb
/usr/lib/ruby/vendor_ruby/nokogiri/html/sax/parser_context.rb
/usr/lib/ruby/vendor_ruby/nokogiri/html/sax/push_parser.rb
/usr/lib/ruby/vendor_ruby/nokogiri/xml/attr.rb
/usr/lib/ruby/vendor_ruby/nokogiri/xml/attribute_decl.rb
/usr/lib/ruby/vendor_ruby/nokogiri/xml/builder.rb
/usr/lib/ruby/vendor_ruby/nokogiri/xml/cdata.rb
/usr/lib/ruby/vendor_ruby/nokogiri/xml/character_data.rb
/usr/lib/ruby/vendor_ruby/nokogiri/xml/document.rb
/usr/lib/ruby/vendor_ruby/nokogiri/xml/document_fragment.rb
/usr/lib/ruby/vendor_ruby/nokogiri/xml/dtd.rb
/usr/lib/ruby/vendor_ruby/nokogiri/xml/element_content.rb
/usr/lib/ruby/vendor_ruby/nokogiri/xml/element_decl.rb
/usr/lib/ruby/vendor_ruby/nokogiri/xml/entity_decl.rb
/usr/lib/ruby/vendor_ruby/nokogiri/xml/entity_reference.rb
/usr/lib/ruby/vendor_ruby/nokogiri/xml/namespace.rb
/usr/lib/ruby/vendor_ruby/nokogiri/xml/node.rb
/usr/lib/ruby/vendor_ruby/nokogiri/xml/node_set.rb
/usr/lib/ruby/vendor_ruby/nokogiri/xml/notation.rb
/usr/lib/ruby/vendor_ruby/nokogiri/xml/parse_options.rb
/usr/lib/ruby/vendor_ruby/nokogiri/xml/pp.rb
/usr/lib/ruby/vendor_ruby/nokogiri/xml/processing_instruction.rb
/usr/lib/ruby/vendor_ruby/nokogiri/xml/reader.rb
/usr/lib/ruby/vendor_ruby/nokogiri/xml/relax_ng.rb
/usr/lib/ruby/vendor_ruby/nokogiri/xml/sax.rb
/usr/lib/ruby/vendor_ruby/nokogiri/xml/schema.rb
/usr/lib/ruby/vendor_ruby/nokogiri/xml/searchable.rb
/usr/lib/ruby/vendor_ruby/nokogiri/xml/syntax_error.rb
/usr/lib/ruby/vendor_ruby/nokogiri/xml/text.rb
/usr/lib/ruby/vendor_ruby/nokogiri/xml/xpath.rb
/usr/lib/ruby/vendor_ruby/nokogiri/xml/xpath_context.rb
/usr/lib/ruby/vendor_ruby/nokogiri/xml/node/save_options.rb
/usr/lib/ruby/vendor_ruby/nokogiri/xml/pp/character_data.rb
/usr/lib/ruby/vendor_ruby/nokogiri/xml/pp/node.rb
/usr/lib/ruby/vendor_ruby/nokogiri/xml/sax/document.rb
/usr/lib/ruby/vendor_ruby/nokogiri/xml/sax/parser.rb
/usr/lib/ruby/vendor_ruby/nokogiri/xml/sax/parser_context.rb
/usr/lib/ruby/vendor_ruby/nokogiri/xml/sax/push_parser.rb
/usr/lib/ruby/vendor_ruby/nokogiri/xml/xpath/syntax_error.rb
/usr/lib/ruby/vendor_ruby/nokogiri/xslt/stylesheet.rb
/usr/lib/ruby/vendor_ruby/xsd/xmlparser/nokogiri.rb
/usr/lib/x86_64-linux-gnu/ruby/vendor_ruby/2.5.0/nokogiri/nokogiri.so
/usr/share/doc/ruby-nokogiri/README.md.gz
/usr/share/doc/ruby-nokogiri/changelog.Debian.gz
/usr/share/doc/ruby-nokogiri/changelog.gz
/usr/share/doc/ruby-nokogiri/copyright
/usr/share/man/man1/nokogiri.1.gz
/usr/share/rubygems-integration/2.5.0/specifications/nokogiri-1.10.4.gemspec

Changelog

2019-08-26 - Georg Faerber <georg@debian.org>
ruby-nokogiri (1.10.4+dfsg1-1) unstable; urgency=medium
* New upstream version. (Closes: #934802)
* Drop compat file, add Build-Dependency on debhelper-compat.
* Use my debian.org mail address.
* Update gemspec file to 1.10.4.
[ Utkarsh Gupta ]
* Add salsa-ci.yml
2019-08-03 - Pirate Praveen <praveen@debian.org>
ruby-nokogiri (1.10.3+dfsg1-2) unstable; urgency=medium
* Reupload to unstable
2019-08-03 - Pirate Praveen <praveen@debian.org>
ruby-nokogiri (1.10.3+dfsg1-1) experimental; urgency=medium
* New upstream version 1.10.3+dfsg1
* Bump Standards-Version to 4.4.0 (no changes needed)
* Refresh patches
* Add a check to verify debian/gemspec is updated
* Update gemspec file to 1.10.3
2019-03-04 - Pirate Praveen <praveen@debian.org>
ruby-nokogiri (1.10.1+dfsg1-1) experimental; urgency=medium
* New upstream version 1.10.1+dfsg1
* Update gemspec from rubygems.org
* Refresh patches
* Add ruby-simplecov as build dependency
2019-02-08 - Utkarsh Gupta <guptautkarsh2102@gmail.com>
ruby-nokogiri (1.10.0+dfsg1-2) unstable; urgency=medium
* Team upload
* Add Breaks for ruby-sanitize
2019-01-09 - Cédric Boutillier <boutil@debian.org>
ruby-nokogiri (1.10.0+dfsg1-1) unstable; urgency=medium
[ Cédric Boutillier ]
* New upstream version 1.10.0+dfsg1
* Use Github as source
* Update Files-Excluded paragraph in copyright file to exclude jar files
from source
* Remove ourdated Readme.source file
* Refresh 003-Remove-dependency-on-mini_portile2.patch
* Create rule to retrieve gemspec from corresponding .gem
[ Utkarsh Gupta ]
* Bump Standards-Version to 4.3.0 (no changes needed)
* Update watch and rules file
2019-01-08 - Utkarsh Gupta <guptautkarsh2102@gmail.com>
ruby-nokogiri (1.10.0-1) unstable; urgency=medium
* Team upload
* New upstream version 1.10.0
* Update patch file names with the serial number
* Refresh patches
2019-01-04 - Utkarsh Gupta <guptautkarsh2102@gmail.com>
ruby-nokogiri (1.9.1-1) unstable; urgency=medium
* Team upload
* New upstream version 1.9.1
* Bump Standards-Version to 4.3.0 (no changes needed)
* Move debian/watch to gemwatch.debian.net
* Refresh patches
* Update debian/rules
2018-07-31 - Cédric Boutillier <boutil@debian.org>
ruby-nokogiri (1.8.4-1) unstable; urgency=medium
* New upstream version 1.8.4
* Move debian/watch to gemwatch.debian.net
* Bump Standards-Version to 4.1.5 (no changes needed)
* Trivially refresh patches
2018-02-20 - Georg Faerber <georg@riseup.net>
ruby-nokogiri (1.8.2-1) unstable; urgency=medium
* New upstream release.
* debian/changelog: Remove trailing whitespaces.
* debian/compat: Bump debhelper version to 11.
* debian/control:
- Add myself to Uploaders.
- Bump required debhelper version to >= 11~.
- Bump Standards-Version to 4.1.3, no changes needed.
- Use salsa.debian.org in Vcs-{Git,Browser}: fields.
* debian/copyright: Use HTTPS in link to copyright format spec.
* debian/watch:
- Bump version to 4.
- Use HTTPS in link to gemwatch service.

See Also

Package Description
ruby-nokogumbo_1.4.2+ds-1+b5_amd64.deb Nokogiri interface to the Gumbo HTML5 parser
ruby-nori_2.6.0-1_all.deb XML to Hash translator
ruby-notiffany_0.1.3-1_all.deb Wrapper libray for most popular notification libraries
ruby-notifier_0.5.1-2_all.deb send system notifications on several platforms
ruby-notify_0.5.2-2_all.deb Desktop notification command on cross platform
ruby-notmuch_0.29.1-2_amd64.deb Ruby interface to the notmuch mail search and index library
ruby-ntlm_0.6.1-2_all.deb NTLM authentication client for Ruby
ruby-numerizer_0.1.1-1_all.deb parse numbers in natural language from strings (ex forty two)
ruby-numru-misc_0.1.2-2_all.deb Miscellaneous functions and classes to help Ruby programming
ruby-numru-units_1.9.0-1_all.deb Ruby class library to handle units of physical quantities
ruby-oauth2_1.4.1-2_all.deb ruby wrapper for the OAuth 2.0 protocol
ruby-oauth_0.5.4-1_all.deb Ruby library for OAuth core
ruby-obexftp_0.24-6+b1_amd64.deb ruby binding to the object exchange file transfer library
ruby-octokit_4.13.0+gh-1_all.deb Ruby toolkit for working with the GitHub API
ruby-odbc_0.99998-1+b1_amd64.deb ODBC Binding for Ruby
Advertisement
Advertisement