ruby-net-ldap_0.16.1-1_all.deb


Advertisement

Description

ruby-net-ldap - LDAP client library for Ruby

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package name ruby-net-ldap
Package version 0.16.1
Package release 1
Package architecture all
Package type deb
Installed size 228 B
Download size 57.38 KB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
ruby-net-ldap_0.16.1-1_all.deb 0.16.1 all Debian Main
ruby-net-ldap - - -

Requires

Name Value
ruby -
ruby-interpreter -

Download

Type URL
Binary Package ruby-net-ldap_0.16.1-1_all.deb
Source Package ruby-net-ldap

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-net-ldap deb package:
    # sudo apt-get install ruby-net-ldap

Files

Path
/usr/lib/ruby/vendor_ruby/net-ldap.rb
/usr/lib/ruby/vendor_ruby/net/ber.rb
/usr/lib/ruby/vendor_ruby/net/ldap.rb
/usr/lib/ruby/vendor_ruby/net/snmp.rb
/usr/lib/ruby/vendor_ruby/net/ber/ber_parser.rb
/usr/lib/ruby/vendor_ruby/net/ber/core_ext.rb
/usr/lib/ruby/vendor_ruby/net/ber/core_ext/array.rb
/usr/lib/ruby/vendor_ruby/net/ber/core_ext/false_class.rb
/usr/lib/ruby/vendor_ruby/net/ber/core_ext/integer.rb
/usr/lib/ruby/vendor_ruby/net/ber/core_ext/string.rb
/usr/lib/ruby/vendor_ruby/net/ber/core_ext/true_class.rb
/usr/lib/ruby/vendor_ruby/net/ldap/auth_adapter.rb
/usr/lib/ruby/vendor_ruby/net/ldap/connection.rb
/usr/lib/ruby/vendor_ruby/net/ldap/dataset.rb
/usr/lib/ruby/vendor_ruby/net/ldap/dn.rb
/usr/lib/ruby/vendor_ruby/net/ldap/entry.rb
/usr/lib/ruby/vendor_ruby/net/ldap/error.rb
/usr/lib/ruby/vendor_ruby/net/ldap/filter.rb
/usr/lib/ruby/vendor_ruby/net/ldap/instrumentation.rb
/usr/lib/ruby/vendor_ruby/net/ldap/password.rb
/usr/lib/ruby/vendor_ruby/net/ldap/pdu.rb
/usr/lib/ruby/vendor_ruby/net/ldap/version.rb
/usr/lib/ruby/vendor_ruby/net/ldap/auth_adapter/gss_spnego.rb
/usr/lib/ruby/vendor_ruby/net/ldap/auth_adapter/sasl.rb
/usr/lib/ruby/vendor_ruby/net/ldap/auth_adapter/simple.rb
/usr/share/doc/ruby-net-ldap/README.rdoc
/usr/share/doc/ruby-net-ldap/changelog.Debian.gz
/usr/share/doc/ruby-net-ldap/changelog.gz
/usr/share/doc/ruby-net-ldap/copyright
/usr/share/rubygems-integration/all/specifications/net-ldap-0.16.1.gemspec

Changelog

2018-03-13 - Balasankar C <balasankarc@debian.org>
ruby-net-ldap (0.16.1-1) unstable; urgency=medium
* Team upload.
* New upstream release.
* Bump debhelper compatibility to 11
* Bump Standards-Version to 4.1.3 (no changes needed)
2017-04-21 - Christian Hofstaedtler <zeha@debian.org>
ruby-net-ldap (0.12.1-2) unstable; urgency=medium
* Team upload.
* Apply patch to actually mock TCPSocket in the connection failure test
(Closes: #860602)
2016-03-15 - Pirate Praveen <praveen@debian.org>
ruby-net-ldap (0.12.1-1) unstable; urgency=medium
* Team upload.
* New upstream release
2016-03-04 - Christian Hofstaedtler <zeha@debian.org>
ruby-net-ldap (0.11-1) unstable; urgency=medium
* Team upload.
[ Cédric Boutillier ]
* Bump debhelper compatibility level to 9
* Remove version in the gem2deb build-dependency
* Use https:// in Vcs-* fields
* Bump Standards-Version to 3.9.7 (no changes needed)
* Run wrap-and-sort on packaging files
[ Christian Hofstaedtler ]
* Remove obsolete d/require-rubygems.overrides
* Upload to unstable.
2015-04-10 - Sebastien Badia <seb@sebian.fr>
ruby-net-ldap (0.11-1~exp1) experimental; urgency=medium
* Team upload.
* Remove unused fix_require_in_tests patch
* Add ruby-test-unit to Build-Depends for ruby2.2
* Add ruby-flexmock to Build-Depends (according new version)
* Bump Standards-Version to 3.9.6 (no further changes)
* Update Vcs-Browser to cgit URL and HTTPS
2014-09-11 - Cédric Boutillier <boutil@debian.org>
ruby-net-ldap (0.8.0-1) unstable; urgency=medium
* Team upload
* Imported Upstream version 0.8.0 (Closes: #760280)
* Bump Standards-Version to 3.9.5
* Drop fix-ruby2-tests patch, not needed anymore
2013-10-26 - David Suárez <david.sephirot@gmail.com>
ruby-net-ldap (0.3.1-3) unstable; urgency=low
* Team upload
[ David Suárez ]
* Fix failing tests on ruby2 (Closes: #720252)
* Bump standards version to 3.9.4; no changes needed
* Add 'copyright-should-refer-to-common-license-file-for-gpl'
lintian override
[ Cédric Boutillier ]
* debian/control:
+ remove obsolete DM-Upload-Allowed flag
+ use canonical URL for Vcs-Git field
* debian/rules: install History.rdoc as upstream changelog
[ Ondřej Surý ]
* Remove myself from Uploaders
2012-06-27 - Paul van Tilburg <paulvt@debian.org>
ruby-net-ldap (0.3.1-2) unstable; urgency=low
* Team upload.
* Bump build dependency on gem2deb to >= 0.3.0~.
2012-05-14 - Jérémy Lal <kapouer@melix.org>
ruby-net-ldap (0.3.1-1) unstable; urgency=low
* Upstream update.
* debian/watch: refer to latest net-ldap project.
* debian/copyright:
+ license changed to Expat, with permission from Ondřej Surý for the
debian/* part.
+ format 1.0
+ add a lintian-override because Comment mentions old GPL license.
* debian/control:
+ Standards-Version 3.9.3 (no changes required)
+ Use anonscm.d.o in Vcs-* fields.
+ Update Homepage url.
+ XS-Ruby-Versions: all, this module is fine with ruby 1.8 and 1.9.
* debian/patches:
+ Unapply unneeded patches
+ 0003-fix_require_in_tests.patch: tests are called from CURDIR.
* Update debian/ruby-test-files.yaml
2011-05-31 - Ondřej Surý <ondrej@debian.org>
ruby-net-ldap (0.0.4-1) unstable; urgency=low
* Initial release (Closes: #628700)
* Fix tests failures
+ Remove tests for removed filter operators
+ Remove tests which needed running LDAP server
+ Remove incomplete ldif test
* Disable ruby1.9.1 build altogher, the module is not prepared for
ruby1.9.1

See Also

Package Description
ruby-net-scp_1.2.1-5_all.deb pure ruby implementation of the SCP protocol
ruby-net-sftp_2.1.2-4_all.deb Ruby implementation of the SFTP protocol
ruby-net-ssh-gateway_2.0.0-1_all.deb Ruby library for tunneling connections to servers with ssh
ruby-net-ssh-krb_0.4.0-1_all.deb Kerberos support for ruby-net-ssh
ruby-net-ssh-multi_1.2.1-3_all.deb Ruby library for making multiple SSH connections to remote systems
ruby-net-ssh_5.0.2-2_all.deb Ruby implementation of the SSH protocol
ruby-net-telnet_0.1.1-2_all.deb telnet client library
ruby-netaddr_1.5.1-2_all.deb manipulating network addresses
ruby-netcdf_0.7.2-3_amd64.deb Ruby interface of netCDF library
ruby-netrc_0.11.0-1_all.deb Ruby library to read and write netrc files
ruby-nfc_3.1.1-1+b6_amd64.deb ruby wrapper for the libnfc
ruby-ngraph_6.07.06-1_amd64.deb Library for using ngraph-gtk Ruby programs
ruby-nio4r_1.2.1-1+b2_amd64.deb Ruby library providing a selector API for monitoring IO objects
ruby-nokogiri-diff_0.2.0-1_all.deb calculate the differences between two XML/HTML documents
ruby-nokogiri_1.8.4-1_amd64.deb HTML, XML, SAX, and Reader parser for Ruby
Advertisement
Advertisement