ruby-ncurses_1.4.9-1+b3_amd64.deb


Advertisement

Description

ruby-ncurses - ruby extension for the ncurses C library

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package name ruby-ncurses
Package version 1.4.9
Package release 1+b3
Package architecture amd64
Package type deb
Installed size 242 B
Download size 61.24 KB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
ruby-ncurses_1.4.9-1+b3_i386.deb 1.4.9 i386 Debian Main
ruby-ncurses - - -

Requires

Name Value
libc6 >= 2.17
libgmp10 -
libncurses6 >= 6
libncursesw6 >= 6
libruby2.5 >= 2.5.0~preview1
libtinfo6 >= 6
ruby >= 1:2.5~0
ruby << 1:2.6~

Download

Type URL
Binary Package ruby-ncurses_1.4.9-1+b3_amd64.deb
Source Package ruby-ncurses

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-ncurses deb package:
    # sudo apt-get install ruby-ncurses

Files

Path
/usr/lib/ruby/vendor_ruby/ncurses.rb
/usr/lib/ruby/vendor_ruby/ncurses_sugar.rb
/usr/lib/ruby/vendor_ruby/ncursesw.rb
/usr/lib/x86_64-linux-gnu/ruby/vendor_ruby/2.5.0/ncursesw_bin.so
/usr/share/doc/ruby-ncurses/NEWS.Debian.gz
/usr/share/doc/ruby-ncurses/README.md.gz
/usr/share/doc/ruby-ncurses/changelog.Debian.amd64.gz
/usr/share/doc/ruby-ncurses/changelog.Debian.gz
/usr/share/doc/ruby-ncurses/changelog.gz
/usr/share/doc/ruby-ncurses/copyright
/usr/share/doc/ruby-ncurses/examples/color_pairs.rb
/usr/share/doc/ruby-ncurses/examples/example.rb
/usr/share/doc/ruby-ncurses/examples/form.rb
/usr/share/doc/ruby-ncurses/examples/form2.rb
/usr/share/doc/ruby-ncurses/examples/form_get_wch.rb
/usr/share/doc/ruby-ncurses/examples/hello_ncurses.rb
/usr/share/doc/ruby-ncurses/examples/rain.rb
/usr/share/doc/ruby-ncurses/examples/read_line.rb
/usr/share/doc/ruby-ncurses/examples/tclock.rb
/usr/share/doc/ruby-ncurses/examples/test_scanw.rb
/usr/share/rubygems-integration/2.5.0/specifications/ncursesw-1.4.9.gemspec

Changelog

2016-03-06 - Per Andersson <avtobiff@debian.org>
ruby-ncurses (1.4.9-1) unstable; urgency=medium
* New upstream release.
+ Ship README.md instead of README
* d/copyright: Update maintainers' copyrights
2015-05-06 - Lucas Nussbaum <lucas@debian.org>
ruby-ncurses (1.4.8-2) unstable; urgency=medium
[ Sebastien Badia ]
* Team upload.
* d/watch: Fall-back to Github (githubredir webservice was discontinued)
[ Lucas Nussbaum ]
* Remove myself from Uploaders.
* Update packaging:
+ Bump Standards-Version
+ Add Testsuite field
+ Update Vcs-Browser
+ Change homepage to match gemspec
* Fix lintian warnings in copyright file
2014-09-30 - Per Andersson <avtobiff@debian.org>
ruby-ncurses (1.4.8-1) unstable; urgency=low
* New upstream release
* Changed to my debian address
* Include examples/form*.rb files, they are GFDL-1.2+ licensed
- Remove orig source repackaging
* Drop 0001-Use-ncursesw-includes.patch, resolved upstream
2014-03-20 - Per Andersson <avtobiff@gmail.com>
ruby-ncurses (1.4.7+dfsg-1) unstable; urgency=low
* New upstream release (Closes: #736571)
* Refresh patch Use ncursesw includes
* Add patch to use absolute path in shebang in examples/color_pairs.rb
2014-01-28 - Per Andersson <avtobiff@gmail.com>
ruby-ncurses (1.4.4+dfsg-1) unstable; urgency=low
* New upstream release
2014-01-21 - Per Andersson <avtobiff@gmail.com>
ruby-ncurses (1.4.3+dfsg-1) unstable; urgency=low
* New upstream release
+ Remove patches applied upstream
- Ruby >= 1.9 compatibilit
- Formatting error string
+ Add patch for using ncursesw headers
* Changed to new active upstream
+ Updated debian/{control,copyright,watch}
* Removed non-dfsg free upstream files
+ Added method to repackage non-dfsg free upstream tarball
* Don't ship LICENSE file from examples
2014-01-02 - Praveen Arimbrathodiyil <praveen@debian.org>
ruby-ncurses (1.3.1-3) unstable; urgency=low
* Team upload
* Update fro ruby1.8-removal
* Bump standards version to 3.9.5
* Remove transitional packages
[ C├ędric Boutillier ] 
* remove obsolete DM-Upload-Allowed flag
* use canonical URI in Vcs-* fields  
2012-06-07 - Per Andersson <avtobiff@gmail.com>
ruby-ncurses (1.3.1-2) unstable; urgency=low
* Fix FTBFS. Closes: #675951
- Add patch for formatting error string.
2012-05-31 - Per Andersson <avtobiff@gmail.com>
ruby-ncurses (1.3.1-1) unstable; urgency=low
* Changed upstream to ncursesw-ruby. Closes: #477366.
+ Build-Depend on libncursesw5-dev.
+ Symlink ncurses.rb -> ncursesw.rb.
+ Provide ruby-ncursesw and update long description.
+ Updated watch file.
* Build for all Ruby versions.
+ Add Ruby >= 1.9 compatibility patch.
+ Depend on ruby instead of ruby1.8.
* Set (correct) priority extra for transitional packages.
* Bump standards-version to 3.9.3, no changes needed.
* Update copyright file to DEP5.
* Add myself to uploaders.
* Set unapply-patches in debian/source/local-options.
* Use Breaks instead of Conflicts for transitional packages.
2011-04-17 - Lucas Nussbaum <lucas@lucas-nussbaum.net>
ruby-ncurses (1.2.4-4) unstable; urgency=low
* Add a transitional package for libncurses-ruby, too.

See Also

Package Description
ruby-nenv_0.3.0-2_all.deb convenient wrapper for Ruby's ENV
ruby-neovim_0.7.1-1_all.deb Ruby client for Neovim
ruby-nested-form_0.3.2-2_all.deb conveniently handle multiple models in a single form
ruby-net-dns_0.8.0-1_all.deb Pure Ruby DNS library
ruby-net-http-digest-auth_1.4-2_all.deb RFC 2617 Digest Access Authentication implementation
ruby-net-http-persistent_2.9.4-1_all.deb Manages persistent connections using Net::HTTP
ruby-net-irc_0.0.9-3_all.deb Ruby IRC library (Client, Server and many IRC gateways to webservice)
ruby-net-ldap_0.16.1-1_all.deb LDAP client library for Ruby
ruby-net-scp_1.2.1-5_all.deb pure ruby implementation of the SCP protocol
ruby-net-sftp_2.1.2-4_all.deb Ruby implementation of the SFTP protocol
ruby-net-ssh-gateway_2.0.0-1_all.deb Ruby library for tunneling connections to servers with ssh
ruby-net-ssh-krb_0.4.0-1_all.deb Kerberos support for ruby-net-ssh
ruby-net-ssh-multi_1.2.1-3_all.deb Ruby library for making multiple SSH connections to remote systems
ruby-net-ssh_5.0.2-2_all.deb Ruby implementation of the SSH protocol
ruby-net-telnet_0.1.1-2_all.deb telnet client library
Advertisement
Advertisement