ruby-metaclass_0.0.4-1_all.deb


Advertisement

Description

ruby-metaclass - Ruby library adding a metaclass method to all Ruby objects

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package name ruby-metaclass
Package version 0.0.4
Package release 1
Package architecture all
Package type deb
Installed size 56 B
Download size 3.68 KB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
ruby-metaclass_0.0.4-1_all.deb 0.0.4 all Debian Main
ruby-metaclass - - -

Requires

Name Value
ruby -
ruby-interpreter -

Download

Type URL
Binary Package ruby-metaclass_0.0.4-1_all.deb
Source Package ruby-metaclass

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-metaclass deb package:
    # sudo apt-get install ruby-metaclass

Files

Path
/usr/lib/ruby/vendor_ruby/metaclass.rb
/usr/lib/ruby/vendor_ruby/metaclass/object_methods.rb
/usr/lib/ruby/vendor_ruby/metaclass/version.rb
/usr/share/doc/ruby-metaclass/README.md
/usr/share/doc/ruby-metaclass/changelog.Debian.gz
/usr/share/doc/ruby-metaclass/copyright
/usr/share/rubygems-integration/all/specifications/metaclass-0.0.4.gemspec

Changelog

2014-02-19 - Cédric Boutillier <boutil@debian.org>
ruby-metaclass (0.0.4-1) unstable; urgency=medium
* Imported Upstream version 0.0.4
* debian/control:
+ remove obsolete DM-Upload-Allowed flag
+ use canonical URI in Vcs-* fields
+ bump Standards-Version to 3.9.5
* debian/copyright: use DEP5 copyright-format/1.0 URL for Format field
2012-06-26 - Cédric Boutillier <cedric.boutillier@gmail.com>
ruby-metaclass (0.0.1-2) unstable; urgency=low
* Bump build dependency on gem2deb to >= 0.3.0~
2011-12-29 - Cédric Boutillier <cedric.boutillier@gmail.com>
ruby-metaclass (0.0.1-1) unstable; urgency=low
* Initial release (Closes: #653599)
* 0100_remove_rubygems_bundler_stuff.patch: remove requirements on rubygems
and bundler
* 0200_fix_path_in_require.patch: fix path of test_helper in require
statement of tests.

See Also

Package Description
ruby-metaid_1.0-8_all.deb Some additional methods to make metaprogramming easier
ruby-method-source_0.9.2-1_all.deb Retrieve the sourcecode for a method as a Ruby string
ruby-metriks_0.9.9.6-1_all.deb experimental threadsafe, low-impact measurement library for Ruby
ruby-middleware_0.1.0-1_all.deb middleware abstraction for Ruby
ruby-mime-types-data_3.2015.1120-1_all.deb registry for information about MIME media type definitions
ruby-mime-types_3.2.2-1_all.deb guess MIME type of files
ruby-mime_0.4.4-1_all.deb MIME library for Ruby
ruby-mimemagic_0.3.2+dfsg-1_all.deb fast MIME detection by extension or content
ruby-mini-exiftool_2.9.0-1_all.deb wrapper for exiftool command-line
ruby-mini-magick_4.8.0-2_all.deb wrapper for ImageMagick with a small memory footprint
ruby-minimization_0.2.1-2_all.deb Ruby library providing minimization algorithms
ruby-minitar_0.6.1-1_all.deb Provides POSIX tarchive management for Ruby
ruby-minitest-around_0.4.1-1_all.deb Around block for minitest
ruby-minitest-excludes_2.0.0-1_all.deb Ruby unit tests helper library for MiniTest framework
ruby-minitest-focus_1.1.2-1_all.deb provides ability to focus on a few tests easily
Advertisement
Advertisement