ruby-lockfile_2.1.3-1_all.deb


Advertisement

Description

ruby-lockfile - create NFS-safe lockfiles

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package name ruby-lockfile
Package version 2.1.3
Package release 1
Package architecture all
Package type deb
Installed size 113 B
Download size 19.59 KB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
ruby-lockfile_2.1.3-1_all.deb 2.1.3 all Debian Main
ruby-lockfile - - -

Requires

Name Value
ruby -
ruby-interpreter -

Download

Type URL
Binary Package ruby-lockfile_2.1.3-1_all.deb
Source Package ruby-lockfile

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-lockfile deb package:
    # sudo apt-get install ruby-lockfile

Files

Path
/usr/bin/rlock
/usr/lib/ruby/vendor_ruby/lockfile.rb
/usr/share/doc/ruby-lockfile/README.gz
/usr/share/doc/ruby-lockfile/changelog.Debian.gz
/usr/share/doc/ruby-lockfile/copyright
/usr/share/doc/ruby-lockfile/readme.erb.gz
/usr/share/doc/ruby-lockfile/rlock.help
/usr/share/doc/ruby-lockfile/examples/a.rb
/usr/share/doc/ruby-lockfile/examples/lock.sh
/usr/share/doc/ruby-lockfile/examples/nfsstore.rb
/usr/share/man/man1/rlock.1.gz
/usr/share/rubygems-integration/all/specifications/lockfile-2.1.3.gemspec

Changelog

2014-07-27 - Cédric Boutillier <boutil@debian.org>
ruby-lockfile (2.1.3-1) unstable; urgency=medium
* Team upload
* Imported Upstream version 2.1.3
2014-01-24 - Jonas Genannt <jonas.genannt@capi2name.de>
ruby-lockfile (2.1.0-4) unstable; urgency=low
* Team upload.
[ Cédric Boutillier ]
* debian/control
- remove obsolete DM-Upload-Allowed flag
- use canonical URI in Vcs-* fields
[ Jonas Genannt ]
* d/control
- removed transitional packages
- bumped standards version to 3.9.5 (no changes needed)
* added basic ruby-tests.rb files for testing on build time
2013-03-25 - Jérémy Bobbio <lunar@debian.org>
ruby-lockfile (2.1.0-3) unstable; urgency=low
[ Jérémy Bobbio ]
* Team upload.
[ Per Andersson ]
* Build depend on gem2deb >= 0.3.0 for better integration with rubygems.
2012-06-20 - Per Andersson <avtobiff@gmail.com>
ruby-lockfile (2.1.0-2) unstable; urgency=low
* Correct binary ruby versions tag.
* Relax conflicts with transitional package to breaks.
* Escape hyphens used in rlock.1 man page.
* Change section to ruby.
* Add watch file.
* Made long description a paragraph longer.
2012-04-25 - Per Andersson <avtobiff@gmail.com>
ruby-lockfile (2.1.0-1) unstable; urgency=low
* New maintainer. (Closes: #660502)
* New upstream release.
* Bumped standards version to 3.9.3 (no changes needed).
* Changed to gem2deb packaging.
- Rename source and binary package to ruby-lockfile.
- Add liblockfile-ruby transitional package.
- Build for all ruby versions. (Closes: #611821)
* Remove unnecessary dirs file.
* Use source format 3.0 (quilt).
* Ship docs.
* Update copyright to DEP-5 format.
2009-11-14 - Stefano Zacchiroli <zack@debian.org>
liblockfile-ruby (1.4.3-2.1) unstable; urgency=low
* Non-maintainer upload.
* debian/rules: add mandatory target binary-arch (Closes: #552666)
2008-10-13 - Decklin Foster <decklin@red-bean.com>
liblockfile-ruby (1.4.3-2) unstable; urgency=low
* Add man page for rlock
2008-06-26 - Decklin Foster <decklin@red-bean.com>
liblockfile-ruby (1.4.3-1) unstable; urgency=low
* Initial release (Closes: #488872)

See Also

Package Description
ruby-log4r_1.1.10-4_all.deb Logging library for Ruby
ruby-logger-application_0.0.2-1_all.deb add logging support to Ruby application
ruby-logging-rails_0.5.0-2_all.deb Logging for rail applications
ruby-logging_2.2.2-1_all.deb flexible and extendable logging library for Ruby
ruby-logify_0.2.0-1_all.deb Lightweight logging library for Ruby
ruby-lograge_0.10.0-1_all.deb Tame Rails' multi-line logging into a single line per request
ruby-loofah_2.2.2-1_all.deb manipulation and transformation of HTML/XML documents and fragments
ruby-luabridge_0.8.0-1+b4_amd64.deb access Lua from Ruby
ruby-lumberjack_1.0.13-1_all.deb Lumberjack is a logging implementation in Ruby
ruby-mab_0.0.3-1_all.deb templating engine for writing HTML in pure Ruby
ruby-macaddr_1.7.1-2_all.deb library to read system mac address
ruby-magic_0.2.9-1_all.deb Ruby FFI bindings to libmagic
ruby-mail-gpg_0.4.0-1_all.deb GPG/MIME encryption plugin for the Ruby Mail Library
ruby-mail-room_0.9.1-2_all.deb Forward mail from gmail IMAP to a callback URL or job worker, simply
ruby-mail_2.6.4+dfsg1-1_all.deb Ruby library to handle email generation, parsing and sending
Advertisement
Advertisement