ruby-kgio_2.11.2-1+b1_amd64.deb


Advertisement

Description

ruby-kgio - Kinder, gentler I/O for Ruby

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package name ruby-kgio
Package version 2.11.2
Package release 1+b1
Package architecture amd64
Package type deb
Installed size 88 B
Download size 29.22 KB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
ruby-kgio_2.11.2-1+b1_i386.deb 2.11.2 i386 Debian Main
ruby-kgio - - -

Requires

Name Value
libc6 >= 2.14
libgmp10 -
libruby2.5 >= 2.5.0~preview1
ruby << 1:2.6~
ruby >= 1:2.5~0

Download

Type URL
Binary Package ruby-kgio_2.11.2-1+b1_amd64.deb
Source Package ruby-kgio

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-kgio deb package:
    # sudo apt-get install ruby-kgio

Files

Path
/usr/lib/ruby/vendor_ruby/kgio.rb
/usr/lib/x86_64-linux-gnu/ruby/vendor_ruby/2.5.0/kgio_ext.so
/usr/share/doc/ruby-kgio/HACKING
/usr/share/doc/ruby-kgio/ISSUES
/usr/share/doc/ruby-kgio/NEWS.gz
/usr/share/doc/ruby-kgio/README
/usr/share/doc/ruby-kgio/TODO
/usr/share/doc/ruby-kgio/changelog.Debian.amd64.gz
/usr/share/doc/ruby-kgio/changelog.Debian.gz
/usr/share/doc/ruby-kgio/copyright
/usr/share/rubygems-integration/2.5.0/specifications/kgio-2.11.0.gemspec

Changelog

2018-03-17 - Hleb Valoshka <375gnu@gmail.com>
ruby-kgio (2.11.2-1) unstable; urgency=medium
* New upstream version
* Point Vcs-* to salsa.d.o
* Bump Standards-Version to 4.1.3 (no changes)
* Use https in watch file
* Set dh compat level to 11
2017-08-18 - Hleb Valoshka <375gnu@gmail.com>
ruby-kgio (2.11.0-1) unstable; urgency=medium
[ C├ędric Boutillier ]
* Use https:// in Vcs-* fields
* Run wrap-and-sort on packaging files
[ Hleb Valoshka ]
* New upstream version (Closes: #830353)
* d/control: Bump standards version to 4.0.0 (no changes)
* d/copyright:
- Use https in format field
- Update LGPL-2.1 or LGPL-3 with LGPL-2.1+
* Add patch to remove olddoc in gemspec
2016-02-21 - Antonio Terceiro <terceiro@debian.org>
ruby-kgio (2.10.0-1) unstable; urgency=medium
* Team upload
* New upstream release
* Update packaging with a new dh-make-ruby run
* debian/patches/fix-tcp-fastopen-test.patch: don't try to read
/proc/sys/net/ipv4/tcp_fastopen before checking if it exists.
2015-07-01 - Christian Hofstaedtler <zeha@debian.org>
ruby-kgio (2.9.3-1) unstable; urgency=medium
* Team upload.
* Upload to unstable.
2015-04-09 - Christian Hofstaedtler <zeha@debian.org>
ruby-kgio (2.9.3-1~exp2) experimental; urgency=medium
* Team upload.
* Add ruby-test-unit to Build-Depends for ruby2.2
* Bump Standards-Version to 3.9.6 (no further changes)
* Update Vcs-Browser to cgit URL and HTTPS
2015-04-09 - Christian Hofstaedtler <zeha@debian.org>
ruby-kgio (2.9.3-1~exp1) experimental; urgency=medium
* Team upload.
* Imported Upstream version 2.9.3
* Target experimental and build with ruby 2.2.
2014-05-31 - Hleb Valoshka <375gnu@gmail.com>
ruby-kgio (2.9.2-2) unstable; urgency=medium
* Add patch from Ubuntu to fix test failure on ppc64el (Closes: #746390).
* Rebuild against newer gem2deb (adds gemspec for all interpreters, current
and future)
2014-04-09 - Christian Hofstaedtler <zeha@debian.org>
ruby-kgio (2.9.2-1) unstable; urgency=medium
* Team upload.
[ Hleb Valoshka ]
* New upstream release.
* Remove no more needed patch 0001-Disable-test_poll_EINTR_changed.patch.
* Bump Standards-Version to 3.9.5 (no changes required).
[ Christian Hofstaedtler ]
* Add patch from upstream to fix failing test
"test_trywritev_return_wait_writable(TesTcpServerReadClientWrite)".
Thanks to Eric Wong <normalperson@yhbt.net>.
2013-09-14 - Hleb Valoshka <375gnu@gmail.com>
ruby-kgio (2.8.1-1) unstable; urgency=low
* New upstream release.
* Drop patch 0001-Disabled-test-failing-under-fakeroot.patch, its better
version included by upstream.
* Introduce patch 0001-Disable-test_poll_EINTR_changed.patch to disable
test which may fail because of ruby's deferred signal delivery.
* Build only on linux and kfreebsd.
* Add missing tests to ruby-test-files.yaml.
* Build against gem2deb >= 0.5.0~ to add ruby2.0 and drop ruby1.8 support.
2013-08-17 - Hleb Valoshka <375gnu@gmail.com>
ruby-kgio (2.8.0-1) unstable; urgency=low
* New upstream release.
* Bump Standards-Version to 3.9.4 (no changes).
* Remove obsoleted DM-Upload-Allowed.
* Update copyright format.
* Update Vcs-* fields to use anonscm.debian.org.

See Also

Package Description
ruby-knife-acl_1.0.3-2_all.deb Knife plugin to manipulate Chef server access control lists
ruby-kpeg_1.0.0-1_all.deb KPeg is a simple PEG library for Ruby
ruby-kramdown-rfc2629_1.2.9-1_all.deb generate XML2RFC XML from Markdown
ruby-kramdown_1.17.0-1_all.deb Fast, pure-Ruby Markdown-superset converter
ruby-kubeclient_3.1.2-1_all.deb client for Kubernetes REST API
ruby-kyotocabinet_1.32-2+b5_amd64.deb Straightforward implementation of DBM - Ruby bindings
ruby-lapack_1.8.1-1+b1_amd64.deb Ruby wrapper of LAPACK
ruby-launchy-shim_2.3.0.1_all.deb helper class for launching a web browser
ruby-ldap_0.9.20-1_amd64.deb OpenLDAP library binding for Ruby
ruby-leaflet-rails_0.7.7-1_all.deb Use leaflet.js with Rails 4
ruby-letter-opener_1.4.1-1_all.deb Preview mail in the browser instead of sending
ruby-levenshtein_0.2.2-2+b9_amd64.deb calculates the Levenshtein distance between two sequences
ruby-libprelude_4.1.0-4.1+b1_amd64.deb Security Information and Events Management system [ Ruby bindings ]
ruby-librarian_0.6.4-1_all.deb framework for writing bundlers
ruby-librdf_1.0.17.1+dfsg-1.3+b6_amd64.deb Ruby language bindings for the Redland RDF library
Advertisement
Advertisement