ruby-json-spec_1.1.5-1_all.deb


Advertisement

Description

ruby-json-spec - Ruby library that provides JSON helpers for RSpec and Cucumber

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package name ruby-json-spec
Package version 1.1.5
Package release 1
Package architecture all
Package type deb
Installed size 47 B
Download size 9.80 KB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
ruby-json-spec_1.1.5-1_all.deb 1.1.5 all Debian Main
ruby-json-spec - - -

Requires

Name Value
ruby -
ruby-interpreter -
ruby-multi-json -
ruby-rspec -

Download

Type URL
Binary Package ruby-json-spec_1.1.5-1_all.deb
Source Package ruby-json-spec

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-json-spec deb package:
    # sudo apt-get install ruby-json-spec

Files

Path
/usr/lib/ruby/vendor_ruby/json_spec.rb
/usr/lib/ruby/vendor_ruby/json_spec/configuration.rb
/usr/lib/ruby/vendor_ruby/json_spec/cucumber.rb
/usr/lib/ruby/vendor_ruby/json_spec/errors.rb
/usr/lib/ruby/vendor_ruby/json_spec/exclusion.rb
/usr/lib/ruby/vendor_ruby/json_spec/helpers.rb
/usr/lib/ruby/vendor_ruby/json_spec/matchers.rb
/usr/lib/ruby/vendor_ruby/json_spec/memory.rb
/usr/lib/ruby/vendor_ruby/json_spec/messages.rb
/usr/lib/ruby/vendor_ruby/json_spec/matchers/be_json_eql.rb
/usr/lib/ruby/vendor_ruby/json_spec/matchers/have_json_path.rb
/usr/lib/ruby/vendor_ruby/json_spec/matchers/have_json_size.rb
/usr/lib/ruby/vendor_ruby/json_spec/matchers/have_json_type.rb
/usr/lib/ruby/vendor_ruby/json_spec/matchers/include_json.rb
/usr/share/doc/ruby-json-spec/README.md.gz
/usr/share/doc/ruby-json-spec/changelog.Debian.gz
/usr/share/doc/ruby-json-spec/changelog.gz
/usr/share/doc/ruby-json-spec/copyright
/usr/share/rubygems-integration/all/specifications/json_spec-1.1.5.gemspec

Changelog

2018-02-18 - Miguel Landaeta <nomadium@debian.org>
ruby-json-spec (1.1.5-1) unstable; urgency=medium
* New upstream release.
* Add support Ruby >= 2.4.1 (Closes: #888129):
- Add new patch: d/p/02_add_support_for_ruby_2.4.1.diff
* Bump DH compat level to 11.
* Bump Standards-Version to 4.1.3. No changes were required.
* Set Rules-Requires-Root to no.
* Migrate Vcs-* URLs to salsa.
* Update copyright info.
2014-07-31 - Miguel Landaeta <nomadium@debian.org>
ruby-json-spec (1.1.2-1) unstable; urgency=medium
* Initial release. (Closes: #756667)

See Also

Package Description
ruby-json_2.1.0+dfsg-2+b1_amd64.deb JSON library for Ruby
ruby-jsonapi-renderer_0.1.3-1_all.deb Render JSONAPI documents
ruby-jsonify_0.4.1-3_all.deb builder-style engine to turn Ruby objects into JSON
ruby-jwt_1.5.6-1_all.deb JSON Web Token implementation in Ruby
ruby-kakasi-ffi_1.0.2-2_amd64.deb KAKASI interface for Ruby with Fiddle/DL/FFI
ruby-kaminari-actionview_1.0.1-4_all.deb Kaminari Action View adapter
ruby-kaminari-activerecord_1.0.1-4_all.deb Kaminari Active Record adapter
ruby-kaminari-core_1.0.1-4_all.deb Kaminari's core pagination library
ruby-kaminari_1.0.1-4_all.deb pagination engine plugin for Rails 3+ and other modern frameworks
ruby-kgio_2.11.2-1+b1_amd64.deb Kinder, gentler I/O for Ruby
ruby-knife-acl_1.0.3-2_all.deb Knife plugin to manipulate Chef server access control lists
ruby-kpeg_1.0.0-1_all.deb KPeg is a simple PEG library for Ruby
ruby-kramdown-rfc2629_1.2.9-1_all.deb generate XML2RFC XML from Markdown
ruby-kramdown_1.17.0-1_all.deb Fast, pure-Ruby Markdown-superset converter
ruby-kubeclient_3.1.2-1_all.deb client for Kubernetes REST API
Advertisement
Advertisement