ruby-json-schema_2.8.0-1_all.deb


Advertisement

Description

ruby-json-schema - Ruby JSON Schema Validator

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package name ruby-json-schema
Package version 2.8.0
Package release 1
Package architecture all
Package type deb
Installed size 197 B
Download size 28.81 KB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
ruby-json-schema_2.8.0-1_all.deb 2.8.0 all Debian Main
ruby-json-schema - - -

Requires

Name Value
ruby -
ruby-addressable >= 2.4~
ruby-interpreter -
ruby-json -
ruby-multi-json -
ruby-uuidtools -
ruby-yajl -

Download

Type URL
Binary Package ruby-json-schema_2.8.0-1_all.deb
Source Package ruby-json-schema

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-json-schema deb package:
    # sudo apt-get install ruby-json-schema

Files

Path
/usr/share/doc/ruby-json-schema/README.md.gz
/usr/share/doc/ruby-json-schema/changelog.Debian.gz
/usr/share/doc/ruby-json-schema/changelog.gz
/usr/share/doc/ruby-json-schema/copyright
/usr/share/ruby-json-schema/resources/draft-01.json
/usr/share/ruby-json-schema/resources/draft-02.json
/usr/share/ruby-json-schema/resources/draft-03.json
/usr/share/ruby-json-schema/resources/draft-04.json
/usr/share/ruby-json-schema/resources/draft-06.json
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/attribute.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/schema.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/validator.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/attributes/additionalitems.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/attributes/additionalproperties.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/attributes/allof.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/attributes/anyof.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/attributes/dependencies.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/attributes/disallow.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/attributes/divisibleby.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/attributes/enum.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/attributes/extends.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/attributes/format.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/attributes/items.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/attributes/limit.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/attributes/maxdecimal.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/attributes/multipleof.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/attributes/not.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/attributes/oneof.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/attributes/pattern.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/attributes/patternproperties.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/attributes/properties.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/attributes/properties_optional.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/attributes/ref.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/attributes/required.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/attributes/type.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/attributes/type_v4.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/attributes/uniqueitems.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/attributes/formats/custom.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/attributes/formats/date.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/attributes/formats/date_time.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/attributes/formats/date_time_v4.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/attributes/formats/ip.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/attributes/formats/time.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/attributes/formats/uri.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/errors/custom_format_error.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/errors/json_load_error.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/errors/json_parse_error.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/errors/schema_error.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/errors/schema_parse_error.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/errors/uri_error.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/errors/validation_error.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/schema/reader.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/schema/validator.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/util/array_set.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/util/uri.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/util/uuid.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/validators/draft1.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/validators/draft2.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/validators/draft3.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/validators/draft4.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/validators/draft6.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/validators/hyper-draft1.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/validators/hyper-draft2.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/validators/hyper-draft3.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/validators/hyper-draft4.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/lib/json-schema/validators/hyper-draft6.rb
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/resources/draft-01.json
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/resources/draft-02.json
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/resources/draft-03.json
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/resources/draft-04.json
/usr/share/rubygems-integration/all/gems/json-schema-2.8.0/resources/draft-06.json
/usr/share/rubygems-integration/all/specifications/json-schema-2.8.0.gemspec

Changelog

2017-07-26 - Sruthi Chandran <srud@disroot.org>
ruby-json-schema (2.8.0-1) unstable; urgency=medium
* Team upload
* New upstream release
* Remove unwanted patch move-resource-draft.patch
* Use gem-install
2016-11-13 - Balasankar C <balasankarc@autistici.org>
ruby-json-schema (2.7.0-1) unstable; urgency=medium
* Upstream update.
* Remove unwanted patches.
* Modify move-resource-draft.patch to handle all locations.  
* Use a rake file instead of yaml to run tests.
2016-06-07 - C├ędric Boutillier <boutil@debian.org>
ruby-json-schema (2.6.2-1) unstable; urgency=medium
* Team upload
* Imported Upstream version 2.6.2
* Bump Standards-Version to 3.9.8 (no changes needed)
* Depend on addressable >= 2.4
* Apply update-addressable-24.patch proposed upstream to work with
addressable 2.4+ (Closes: #826412)
* Install resources/drafts* under usr/share (move-resource-draft.patch)
* Don't overload $LOAD_PATH in tests (no-loadpath-overload-in-tests.patch)
2016-03-05 - Sagar Ippalpalli <i.vikram15@gmail.com>
ruby-json-schema (2.6.0+gh-1) unstable; urgency=medium
* Team Upload 
* Add copyright of lib/json-schema/util/uuid.rb
2015-09-04 - Balasankar C <balasankarc@autistici.org>
ruby-json-schema (2.5.1-1) unstable; urgency=medium
* Initial release (Closes: #797643)

See Also

Package Description
ruby-json-spec_1.1.5-1_all.deb Ruby library that provides JSON helpers for RSpec and Cucumber
ruby-json_2.1.0+dfsg-2+b1_amd64.deb JSON library for Ruby
ruby-jsonapi-renderer_0.1.3-1_all.deb Render JSONAPI documents
ruby-jsonify_0.4.1-3_all.deb builder-style engine to turn Ruby objects into JSON
ruby-jwt_1.5.6-1_all.deb JSON Web Token implementation in Ruby
ruby-kakasi-ffi_1.0.2-2_amd64.deb KAKASI interface for Ruby with Fiddle/DL/FFI
ruby-kaminari-actionview_1.0.1-4_all.deb Kaminari Action View adapter
ruby-kaminari-activerecord_1.0.1-4_all.deb Kaminari Active Record adapter
ruby-kaminari-core_1.0.1-4_all.deb Kaminari's core pagination library
ruby-kaminari_1.0.1-4_all.deb pagination engine plugin for Rails 3+ and other modern frameworks
ruby-kgio_2.11.2-1+b1_amd64.deb Kinder, gentler I/O for Ruby
ruby-knife-acl_1.0.3-2_all.deb Knife plugin to manipulate Chef server access control lists
ruby-kpeg_1.0.0-1_all.deb KPeg is a simple PEG library for Ruby
ruby-kramdown-rfc2629_1.2.9-1_all.deb generate XML2RFC XML from Markdown
ruby-kramdown_1.17.0-1_all.deb Fast, pure-Ruby Markdown-superset converter
Advertisement
Advertisement