ruby-ipaddress_0.8.3-2_all.deb


Advertisement

Description

ruby-ipaddress - Ruby library to manipulate IPv4/IPv6 addresses

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package name ruby-ipaddress
Package version 0.8.3
Package release 2
Package architecture all
Package type deb
Installed size 96 B
Download size 27.96 KB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
ruby-ipaddress_0.8.3-2_all.deb 0.8.3 all Debian Main
ruby-ipaddress - - -

Requires

Name Value
ruby -
ruby-interpreter -

Download

Type URL
Binary Package ruby-ipaddress_0.8.3-2_all.deb
Source Package ruby-ipaddress

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-ipaddress deb package:
    # sudo apt-get install ruby-ipaddress

Files

Path
/usr/lib/ruby/vendor_ruby/ipaddress.rb
/usr/lib/ruby/vendor_ruby/ipaddress/ipv4.rb
/usr/lib/ruby/vendor_ruby/ipaddress/ipv6.rb
/usr/lib/ruby/vendor_ruby/ipaddress/mongoid.rb
/usr/lib/ruby/vendor_ruby/ipaddress/prefix.rb
/usr/lib/ruby/vendor_ruby/ipaddress/version.rb
/usr/share/doc/ruby-ipaddress/README.rdoc.gz
/usr/share/doc/ruby-ipaddress/changelog.Debian.gz
/usr/share/doc/ruby-ipaddress/changelog.gz
/usr/share/doc/ruby-ipaddress/copyright
/usr/share/rubygems-integration/all/specifications/ipaddress-0.8.3.gemspec

Changelog

2016-03-09 - Antonio Terceiro <terceiro@debian.org>
ruby-ipaddress (0.8.3-2) unstable; urgency=medium
* Team upload.
* dh-make-ruby -w:
- debian/rules
- update homepage URL
- add Testsuite: field
- debian/rules:
- cleanup; remove comments generated by an old dh-make-ruby
- check dependency resolution during build; makes sure we will notice
broken rubygems-integration early on.
* debian/patches/0001-gemspec-remove-git-usage.patch: fix rubygems
integration (should fix chef autopkgtest tests)
2016-03-05 - Lucas Kanashiro <kanashiro.duarte@gmail.com>
ruby-ipaddress (0.8.3-1) unstable; urgency=medium
* Team upload.
[ Cédric Boutillier ]
* Bump debhelper compatibility level to 9
* Remove version in the gem2deb build-dependency
* Use https:// in Vcs-* fields
* Use https:// in Vcs-* fields
* Bump Standards-Version to 3.9.7 (no changes needed)
* Run wrap-and-sort on packaging files
[ Lucas Kanashiro ]
* Imported Upstream version 0.8.3
* Drop unnecessary 001-fix-tests-strings-encoding patch
2014-05-02 - David Suárez <david.sephirot@gmail.com>
ruby-ipaddress (0.8.0-3) unstable; urgency=low
* Bump gem2deb build dep to at least 0.7.0
This fix the rubygems integration to allow support all Ruby versions
* Bump Standards-Version to 3.9.5 (no changes needed)
2013-10-06 - David Suárez <david.sephirot@gmail.com>
ruby-ipaddress (0.8.0-2) unstable; urgency=low
* Fix failing tests on ruby2 (Closes: #720251)
* Bump standards version to 3.9.4; no changes needed
* Update the copyright format specification to the latest version
[ Cédric Boutillier ]
* use canonical anonscm.debian.org URI in Vcs-* fields
* remove obsolete DM-Upload-Allowed flag
* use DEP5 copyright-format/1.0 official URL in debian/copyright
2011-07-30 - Lucas Nussbaum <lucas@debian.org>
ruby-ipaddress (0.8.0-1) unstable; urgency=low
* New upstream release.
2011-05-13 - Lucas Nussbaum <lucas@debian.org>
ruby-ipaddress (0.7.5-1) unstable; urgency=low
* Initial release.

See Also

Package Description
ruby-iso8601_0.12.1-1_all.deb Ruby parser to work with ISO 8601 dateTimes and durations
ruby-jar-dependencies_0.3.10-2_all.deb manage jar dependencies for Ruby gems
ruby-jbuilder_2.7.0-1_all.deb creation of JSON structures via a Builder-style DSL
ruby-jekyll-coffeescript_1.0.1-2_all.deb CoffeeScript converter for Jekyll
ruby-jekyll-feed_0.3.1-1_all.deb Atom feed generator for Jekyll
ruby-jekyll-gist_1.1.0-1_all.deb Liquid tag for displaying GitHub Gists in Jekyll sites
ruby-jekyll-paginate_1.1.0-1_all.deb Default pagination generator for Jekyll
ruby-jekyll-sass-converter_1.5.2-1_all.deb Basic Sass converter for Jekyll
ruby-jekyll-test-plugin-malicious_0.2.0-1_all.deb Malicious test plugin for Jekyll
ruby-jekyll-test-plugin_0.1.0-1_all.deb facility to test Jekyll plugins
ruby-jekyll-watch_2.0.0-1_all.deb Rebuild your Jekyll site when a file changes
ruby-jeweler_2.0.1-3_all.deb Opinionated tool for creating and managing RubyGem projects
ruby-jira_1.5.0-1_all.deb Atlassian JIRA REST API client
ruby-jnunemaker-matchy_0.4.0-1_all.deb RSpec-like matcher system for use in Test::Unit
ruby-joiner_0.3.4-2_all.deb builds activerecord joins from association paths
Advertisement
Advertisement