ruby-htree_0.8+dfsg-3_all.deb


Advertisement

Description

ruby-htree - HTML/XML tree library for Ruby

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package name ruby-htree
Package version 0.8+dfsg
Package release 3
Package architecture all
Package type deb
Installed size 212 B
Download size 36.95 KB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
ruby-htree_0.8+dfsg-3_all.deb 0.8+dfsg all Debian Main
ruby-htree - - -

Requires

Name Value
ruby -
ruby-interpreter -

Download

Type URL
Binary Package ruby-htree_0.8+dfsg-3_all.deb
Source Package ruby-htree

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-htree deb package:
    # sudo apt-get install ruby-htree

Files

Path
/usr/lib/ruby/vendor_ruby/htree.rb
/usr/lib/ruby/vendor_ruby/htree/container.rb
/usr/lib/ruby/vendor_ruby/htree/context.rb
/usr/lib/ruby/vendor_ruby/htree/display.rb
/usr/lib/ruby/vendor_ruby/htree/doc.rb
/usr/lib/ruby/vendor_ruby/htree/elem.rb
/usr/lib/ruby/vendor_ruby/htree/encoder.rb
/usr/lib/ruby/vendor_ruby/htree/equality.rb
/usr/lib/ruby/vendor_ruby/htree/extract_text.rb
/usr/lib/ruby/vendor_ruby/htree/fstr.rb
/usr/lib/ruby/vendor_ruby/htree/gencode.rb
/usr/lib/ruby/vendor_ruby/htree/htmlinfo.rb
/usr/lib/ruby/vendor_ruby/htree/inspect.rb
/usr/lib/ruby/vendor_ruby/htree/leaf.rb
/usr/lib/ruby/vendor_ruby/htree/loc.rb
/usr/lib/ruby/vendor_ruby/htree/modules.rb
/usr/lib/ruby/vendor_ruby/htree/name.rb
/usr/lib/ruby/vendor_ruby/htree/output.rb
/usr/lib/ruby/vendor_ruby/htree/parse.rb
/usr/lib/ruby/vendor_ruby/htree/raw_string.rb
/usr/lib/ruby/vendor_ruby/htree/regexp-util.rb
/usr/lib/ruby/vendor_ruby/htree/rexml.rb
/usr/lib/ruby/vendor_ruby/htree/scan.rb
/usr/lib/ruby/vendor_ruby/htree/tag.rb
/usr/lib/ruby/vendor_ruby/htree/template.rb
/usr/lib/ruby/vendor_ruby/htree/text.rb
/usr/lib/ruby/vendor_ruby/htree/traverse.rb
/usr/share/doc/ruby-htree/README
/usr/share/doc/ruby-htree/changelog.Debian.gz
/usr/share/doc/ruby-htree/copyright
/usr/share/rubygems-integration/all/specifications/htree-0.8.gemspec

Changelog

2016-07-05 - Christian Hofstaedtler <zeha@debian.org>
ruby-htree (0.8+dfsg-3) unstable; urgency=medium
* Team upload.
[ Cédric Boutillier ]
* Remove version in the gem2deb build-dependency
* Use https:// in Vcs-* fields
* Bump Standards-Version to 3.9.8 (no changes needed)
[ Christian Hofstaedtler ]
* Drop transitional packages
* Update packaging using dh-make-ruby -w
2014-01-01 - Cédric Boutillier <boutil@debian.org>
ruby-htree (0.8+dfsg-2) unstable; urgency=medium
* Team upload
* Bump Debian version to unbreak version check in transitional packages.
2013-12-29 - Jonas Genannt <jonas.genannt@capi2name.de>
ruby-htree (0.8+dfsg-1) unstable; urgency=medium
* created debian/ with gem2deb
- renamed package to new Debian ruby policy (Closes: #722371)
- updated long description
- d/copyright: to DEP-5 format
* moved package to Ruby pkg extras team (Closes: #677287)
* added myself as Uploader
2013-07-10 - NIIBE Yutaka <gniibe@fsij.org>
htree (0.8-1) unstable; urgency=low
* New upstream release.
* debian/source/format: New.
* debian/patches/01-makefile.diff: New.
* debian/rules: Re-write for newer debhelper.
2010-05-13 - NIIBE Yutaka <gniibe@fsij.org>
htree (0.7-5) unstable; urgency=low
* debian/control (Build-Depends, Build-Depends-Indep):
Added ruby1.8, removed rdoc (Closes: #581317).
Thanks to Lucas Nussbaum <lucas@lucas-nussbaum.net>
(Homepage): Added.
2010-03-24 - NIIBE Yutaka <gniibe@fsij.org>
htree (0.7-4) unstable; urgency=low
Ruby 1.9.1 fixes (Closes: #569878).
Thanks to Lucas Nussbaum <lucas@lucas-nussbaum.net>
* debian/control (Package): Package name is libhtree-ruby1.9.1 now.
(Depends): libruby1.9.1.
* debian/rules: libtree-ruby1.9.1.
* debian/libhtree-ruby1.9.{dirs,docs,install}: Renamed to 1.9.1.
* debian/libhtree-ruby1.9.1.install: Follow the change of pathname.
2010-02-24 - NIIBE Yutaka <gniibe@fsij.org>
htree (0.7-3) unstable; urgency=low
* debian/control (Standards-Version): Updated to 3.8.4.
(Section): Changed to ruby (was: interpreters).
(Depends): Added ${misc:Depends}.
* debian/rules: Use 1.9.1 for load path (Closes: #569878).
* debian/libhtree-ruby1.9.{dirs,install}: Ditto.
2008-06-13 - NIIBE Yutaka <gniibe@fsij.org>
htree (0.7-2) unstable; urgency=low
* debian/rules: Use 1.9.0 for load path (Closes: #484620).
* debian/libhtree-ruby1.9.{dirs,install}: Ditto.
2008-04-14 - NIIBE Yutaka <gniibe@fsij.org>
htree (0.7-1) unstable; urgency=low
* New upstream release.
* debian/watch: New file.
* debian/control: Added libhtree-ruby1.9 (Closes: #379017).
2008-03-28 - NIIBE Yutaka <gniibe@fsij.org>
htree (0.6-1) unstable; urgency=low
* New maintainer (Closes: #472715).
* New upstream release (Closes: #379016).

See Also

Package Description
ruby-http-accept-language_2.1.1-2_all.deb Ruby library that finds out which locale the user prefers
ruby-http-connection_1.4.4-1_all.deb HTTP helper library for Ruby
ruby-http-cookie_1.0.2-1_all.deb Ruby library to handle HTTP Cookies based on RFC 6265
ruby-http-form-data_1.0.1+gemwatch-1_all.deb utility-belt to build form data request bodies
ruby-http-parser.rb-doc_0.6.0-4_all.deb Simple callback-based HTTP request/response parser (documentation)
ruby-http-parser.rb_0.6.0-4+b3_amd64.deb Simple callback-based HTTP request/response parser
ruby-http_2.2.2-1_all.deb easy-to-use client library for making http requests from Ruby
ruby-httparty_0.16.2+dfsg1-2_all.deb quick web service consumption from any Ruby class
ruby-httpauth_0.2.1+gh-1_all.deb Ruby library for the HTTP authentication protocol (RFC 2617)
ruby-httpclient_2.8.3-1_all.deb HTTP client library for ruby
ruby-i18n-inflector-rails_1.0.7-4_all.deb I18n Inflector bindings for Rails
ruby-i18n-inflector_2.6.6-3_all.deb enhance i18n backend with inflections
ruby-i18n_0.7.0-2_all.deb I18n and localization solution for Ruby
ruby-icalendar_2.4.1-1_all.deb ruby implementation of the iCalendar specification (RFC-5545)
ruby-ice-cube_0.12.1-1_all.deb Ruby Date Recurrence Library
Advertisement
Advertisement